Subject: TCP & Path MTU Discovery.

From: "Shankar Vasudevan" <[email-masked]>
Date: Thu, 23 Mar 2000 12:23:01 +0530

Hi,

Can someone point out a TCP implementation that uses the PMTU-D as defined in RFC 1191.

Can any one tell me if there is any reference doc that discusses about
the interface that TCP should have to learn changes in TCP ? 

thanx in advance,
shankar

---

From: Andi Kleen <[email-masked]>
Date: Thu, 23 Mar 2000 19:41:03 +0100

> Can someone point out a TCP implementation that uses the PMTU-D as defined in RFC 1191.

Linux 2.0+ implements path mtu discovery. 2.0 was a rather low tech 
implementation (no shared pmtus between sockets), but in 2.2+ it is fairly
complete. Only thing missing is path mtu black hole detection (it seems
very few TCPs implement that) 

-Andi

-- 
This is like TV. I don't like TV.

---

From: "Shankar Vasudevan" <[email-masked]>
Date: Fri, 24 Mar 2000 11:57:58 +0530

Hi all,

  Thanx a lot for ur suggestions. Am now having lots of codes to look into :) It gave me a lot of inputs, especially  David with his detailed mail gave lot of inputs. 

  The following is off the topic of this mailing list. so pl. excuse me.

  Am implementing PMTU-D for a router. Can we detect that a PMTU-D is not converging ? RFC says we should force it to converge ? First of all how do I detect that a discovery is not converging ? 

  And also where do I store my PMTU information? If i store it in the routing table wouldn't that be wasting a lot of memory, since this is a router and it would have routes to all possible destination ?  If i put it in a separate table then I wouldn't be able to give a per-route configuration whether we should do PMTU-D or not.

  Thanx a lot ,

  regards

  Shankar