Subject: Re: TIME-WAIT assasination implementations

From: Bob Braden <[email-masked]>
Date: Fri, 10 Nov 2000 07:31:14 -0800 (PST)

*> hi,
  *> 
  *> I don't think it is widespread - it is not a standard.  I did
  *> implement it as a compiler option on our stack.  It's a small
  *> change.
  *> 
  *> Is there any interest in moving RFC 1337 onto the standards track?
  *> 
  *> Of course, there are wider issues with RSTs. I am putting together
  *> a web page with references like RFC 1337.
  *> 
  *> cheers
  *> ian
  *>   

Ian,

I am unsure what is meant by "implement 1337".  The RFC describes 3
different possible solutions and only barely recommends one of them.
It was intended as a request for comments, not a proposal for a
particular fix.

Regards,

Bob Braden

  *> 
  *> > Hi,
  *> > 
  *> > does anybody know how well spread the implementation of rfc1337 (TIME-WAIT
  *> > assasination hazards) is? I know that FreeBSD 4.1 has it, and it seems as
  *> > if Linux 2.2 has support for it as well (configurable through a sysctl).  
  *> > 
  *> > /adam
  *> > 
  *> > --
  *> > Adam Dunkels <[email-masked]>
  *> > http://www.sics.se/~adam
  *> > 
  *> 
  *>

---

From: Ian Heavens <[email-masked]>
Date: Fri, 10 Nov 2000 15:56:21 +0000

hi Bob,

I meant the fix of ignoring RSTs in TIME-WAIT, which I
assume FreeBSD 4.1 has done.  As you say, it was a discussion 
document and not intended for standardisation. 

cheers
ian

-- 
Ian Heavens, Spider Software Ltd., http://www.spider.com/
8 John's Place, Leith, Edinburgh EH6 7EL. 
Tel +44 131 475 7015 fax. +44 131 475 7001  [email-masked]

---

From: Joe Touch <[email-masked]>
Date: Fri, 10 Nov 2000 10:04:32 -0800

> document and not intended for standardisation.

Seems like it would be a BCP, not Standards-Track.
However, I'm with Bob in that such a BCP would need
to have a stronger conclusion.

That might motivate us to move forward, so our doc(s)
might move to BCP...

Joe