Subject: RE: Connection Establishment

From: Bob Braden <[email-masked]>
Date: Wed, 6 Feb 2002 20:01:18 GMT

*> From [email-masked]  Wed Feb  6 10:35:39 2002
  *> Date: Wed, 6 Feb 2002 18:23:23 +0000 (GMT)
  *> From: Jeremy Harris - Network Service Providers Division <[email-masked]>
  *> Subject: RE: Connection Establishment
  *> To: [email-masked]
  *> Cc: [email-masked]
  *> MIME-Version: 1.0
  *> Content-MD5: rDSuqNHi4wDEZ/GSrGfi8w==
  *> X-AntiVirus: scanned by AMaViS 0.2.1
  *> 
  *> [email-masked] said:
  *> >   As per TCP standard (not w.r.t. any API implementations, 
  *> >   like sockets)
  *> > 
  *> >   Machine A initiates a connection to machine B.
  *> >   A sends a segment with ISN x, chosen according
  *> >   A's clock, and with SYN bit set to 1, this is the
  *> >   connection request message.
  *> > 	- the ACK flag is set to 0
  *> > 	- this segment is still a regular TCP segment; it
  *> > 	  can carry data too (piggyback 1)
  *> 
  *> I have implemented this; it works nicely.   However, the question
  *> arises: how much data may be piggybacked on a SYN?  What window may
  *> the sender assume?
  *> 

Please see RFC 1644 on T/TCP (July 1994)/

Bob Braden

---

From: Sebastian Zimmermann <[email-masked]>
Date: Thu, 14 Feb 2002 13:34:22 +0100

> Please see RFC 1644 on T/TCP (July 1994)/

FYI: There is also a project at sourceforge:

http://sourceforge.net/projects/ttcplinux/

-- 

+----------------------------------------+
| Technische Universität Hamburg-Harburg |
|        Kommunikationsnetze (4-06)      |
|            Denickestraße 17            |
|             21071 Hamburg              |
|----------------------------------------|
|   Fernsprecher:  +49 40 42878-3387     |
|      Fernkopie:  +49 40 42878-2941     |
|    Elektropost:  [email-masked]  |
|      http://www.tu-harburg.de/et6      |
+----------------------------------------+