Subject: regarding sending of a reset packet....

From: "bhaskar" <[email-masked]>
Date: Tue, 5 Mar 2002 10:28:29 +0530

hi,

  in the case of segment arrives ( rfc 793 pg. no 64 ),  when tcp is in the closed state, if a reset packet has to be sent out,
  the rfc specifies the cases when the ack flag is set in the incoming packet. 
  
  what happens if a syn flag is set or a fin is set along with ack in the incoming packet... what should be the sequence number in that case of the outgoing reset packet ?? 

  to elaborate my doubt,

  suppose for an incoming packet of tcp length 60 and ack num is 500, let us suppose, and the flags set are ack, and syn. what should be the sequence number of the reset packet that has to be sent out.  since the syn occupies one sequence number, should the seq. no be 60 + 500 + 1 or just 60 + 500.

thanx in advance,
uday.

---

From: "Bhuvaneswari R.P" <[email-masked]>
Date: Tue, 5 Mar 2002 18:10:05 +0530

As per my knowledge, SYN/FIN bit will never be set along with RST bit in an
outgoing TCP packet.

-regards,
Bhuvaneswari
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On
Behalf Of bhaskar
  Sent: Tuesday, 5 March 2002 10:28 AM
  To: [email-masked]
  Subject: regarding sending of a reset packet....

  hi,

    in the case of segment arrives ( rfc 793 pg. no 64 ),  when tcp is in the
closed state, if a reset packet has to be sent out,
    the rfc specifies the cases when the ack flag is set in the incoming packet.

    what happens if a syn flag is set or a fin is set along with ack in the
incoming packet... what should be the sequence number in that case of the
outgoing reset packet ??

    to elaborate my doubt,

    suppose for an incoming packet of tcp length 60 and ack num is 500, let us
suppose, and the flags set are ack, and syn. what should be the sequence number
of the reset packet that has to be sent out.  since the syn occupies one
sequence number, should the seq. no be 60 + 500 + 1 or just 60 + 500.

  thanx in advance,
  uday.

---

From: "Bhuvaneswari R.P" <[email-masked]>
Date: Thu, 21 Mar 2002 14:26:37 +0530

Hello,

I have a doubt in sockets. I don't know whether this is the right mailing list
for posting my query.

When I create a socket, the socket will be in Blocking mode.
The socket can be set to Non-Blocking mode using the call 'fcntl'.

Is there some mechanism by which a socket already in Non-Blocking mode,
can be set to Blocking mode.

If this is not the right mailing list, it would be very helpful if someone let's
me know the mailing list
where I can post my queries with respect to sockets.

-Regards,
Bhuvaneswari.

***************************************************************************
This message is proprietary to Future Software Limited (FSL) 
and is intended solely for the use of the individual to whom it
is addressed. It may contain  privileged or confidential information 
and should not be circulated or used for any purpose other than for 
what it is intended. 

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. 
FSL accepts no responsibility for loss or damage arising from 
the use of the information transmitted by this email including
damage from virus.
***************************************************************************