Subject: [tcpm] draft-williams-overlaypath-ip-tcp-rfc-00.txt

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 27 Feb 2012 09:07:15 +0000

Hi,

from draft-williams-overlaypath-ip-tcp-rfc-00.txt:

>    8.  IANA Considerations
> 
>    The assignment of numbers 26 for IPv4, 11 for IPv6, and 30 for TCP
>    are provisional pending official IANA approval.  The Type values
>    could change if IANA assigns different numbers.
> 
>    It may be important to note that some early implementations of this
>    specification use TCP option numbers 28 and 29 due to the fact that
>    these numbers were available at the time of the implementation.
>    These early implementations will require updates after an official
>    option number has been assigned.

We should instruct IANA to indicate in the options number registry that options 28 (TCP-UTO) and 29 (TCP-AO) have also been inappropriately used for other then the assigned TCP extensions.

(This is esp. unfortunate for AO! We had the clash on 253/254, and now we have another one. Sigh.)

Lars

---

From: Joe Touch <[email-masked]>
Date: Mon, 27 Feb 2012 09:55:01 -0800

Agreed.

It's not an issue for AO, though - so long as 29 is interpreted as AO 
for compliant implementations, the keying should end up just dumping 
anyone else's segments that use 29 as "malformed" or incorrectly keyed.

Joe

On 2/27/2012 1:07 AM, Eggert, Lars wrote:
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm