Subject: [tcpm] Timestamp option and ticks

From: Ingemar Johansson S <[email-masked]>
Date: Mon, 26 Mar 2012 16:32:28 +0200

Hi

I have a question related to the time stamp option. Is there any list somewhere what "timebase" various OS use for the timestamp. Thinking of Android, Apple iOS , MS Windows etc.

Then a question regarding http://tools.ietf.org/id/draft-scheffenegger-tcpm-timestamp-negotiation-03.txt
is this draft in an active state ?. Asking because something like this is probably needed for optimal performance for TCP with LEDBAT CC

/Ingemar
=================================
Ingemar Johansson  M.Sc.
Senior Researcher

Ericsson AB
Wireless Access Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]
www.ericsson.com
www.thenodepole.com/
=================================

---

From: Hagen Paul Pfeifer <[email-masked]>
Date: Mon, 26 Mar 2012 16:57:41 +0200

* Ingemar Johansson S | 2012-03-26 16:32:28 [+0200]:

>I have a question related to the time stamp option. Is there any list
>somewhere what "timebase" various OS use for the timestamp. Thinking of
>Android, Apple iOS , MS Windows etc.

I am not aware of this list. Anyway: Linux simple use jiffies (actually
the lower 32 bit on a 64 bit system). Without guaranty: this should also
be true for Android.

Hagen

---

From: "Scheffenegger, Richard" <[email-masked]>
Date: Mon, 26 Mar 2012 15:02:05 +0000

Hi Ingemar,

During my investigation, I didn't find any explicit way how to figure out the timebase; some implementations try to figure out the remote timebase during the three way handshake, and then put the result in one of a small number of  buckets. However, this approach has a couple of obvious drawbacks (ie. missing "timebase" buckets, problems delineating between buckets being close together, transient network conditions during the measurement, to name a few).

The draft has lingered somewhat, but I still want to drive it forward. From what I gathered during the last meetings, there is a general view that something like this is interesting, but the document is not ready for WGLC (or even close).

I believe part of that is, that the draft as it stands now mingles too much of the rationale for this modification, with the simple, straight-forward implementation details. Perhaps I should split the document into two parts. But I really would appreciate any input as to how to proceed with this proposal.

Also, contributors are very welcome :)

Richard Scheffenegger

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ingemar Johansson S
Sent: Montag, 26. März 2012 16:32
To: [email-masked]
Subject: [tcpm] Timestamp option and ticks

Hi

/Ingemar

Ericsson AB
Wireless Access Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]<mailto:[email-masked]>
www.ericsson.com
www.thenodepole.com/
=================================

---

From: Ingemar Johansson S <[email-masked]>
Date: Tue, 27 Mar 2012 10:45:45 +0200

Hi

Thanks for the response. I will read though the draft and see if I can contribute with something useful. It seems to be very well written though.

/Ingemar

________________________________
From: Scheffenegger, Richard [mailto:[email-masked]]
Sent: den 26 mars 2012 17:02
To: Ingemar Johansson S; [email-masked]
Subject: RE: Timestamp option and ticks

Hi Ingemar,

---

From: "Scheffenegger, Richard" <[email-masked]>
Date: Tue, 27 Mar 2012 11:36:42 +0000

Ingemar,

if you would be willing to formally review the draft (Michael Welzl also indicated that he'd volunteer as a  reviewer, if he wouldn't be the only one), that would be great support already. After the reviews I'd like to ask the WG to adopt that draft unless someone has already major objections at this time.

Best regards,

Richard Scheffenegger

From: Ingemar Johansson S [mailto:[email-masked]]
Sent: Dienstag, 27. März 2012 10:46
To: Scheffenegger, Richard; [email-masked]
Subject: RE: Timestamp option and ticks

Hi

/Ingemar

________________________________
From: Scheffenegger, Richard [mailto:[email-masked]]<mailto:[mailto:[email-masked]]>
Sent: den 26 mars 2012 17:02
To: Ingemar Johansson S; [email-masked]<mailto:[email-masked]>
Subject: RE: Timestamp option and ticks
Hi Ingemar,
During my investigation, I didn't find any explicit way how to figure out the timebase; some implementations try to figure out the remote timebase during the three way handshake, and then put the result in one of a small number of  buckets. However, this approach has a couple of obvious drawbacks (ie. missing "timebase" buckets, problems delineating between buckets being close together, transient network conditions during the measurement, to name a few).
The draft has lingered somewhat, but I still want to drive it forward. From what I gathered during the last meetings, there is a general view that something like this is interesting, but the document is not ready for WGLC (or even close).
I believe part of that is, that the draft as it stands now mingles too much of the rationale for this modification, with the simple, straight-forward implementation details. Perhaps I should split the document into two parts. But I really would appreciate any input as to how to proceed with this proposal.
Also, contributors are very welcome :)
Richard Scheffenegger

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> On Behalf Of Ingemar Johansson S
Sent: Montag, 26. März 2012 16:32
To: [email-masked]<mailto:[email-masked]>
Subject: [tcpm] Timestamp option and ticks
Hi
I have a question related to the time stamp option. Is there any list somewhere what "timebase" various OS use for the timestamp. Thinking of Android, Apple iOS , MS Windows etc.
Then a question regarding http://tools.ietf.org/id/draft-scheffenegger-tcpm-timestamp-negotiation-03.txt
is this draft in an active state ?. Asking because something like this is probably needed for optimal performance for TCP with LEDBAT CC
/Ingemar
=================================
Ingemar Johansson  M.Sc.
Senior Researcher
Ericsson AB
Wireless Access Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]<mailto:[email-masked]>
www.ericsson.com
www.thenodepole.com/
=================================