Subject: [tcpm] Summary of feedback on draft-ietf-tcpm-initcwnd-03

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Wed, 4 Apr 2012 10:58:32 +0200

Hi all,

Here is a summary of what the chairs understood as feedback to be added to the next version of draft-ietf-tcpm-initcwnd-03, which we plan to WGLC:

* The wording at the beginning of the draft (and possibly the title) must better highlight the experimental status of the document.

* The document should say that at time of publication there is only limited experimental data regarding the impact on non-TCP traffic.

* In Section 12, the lost packets during the initial burst is explicitly mentioned as one performance metric that SHOULD be monitored.

* The document explicitly states that further work and experiments are needed regarding a backoff mechanism, most notably to avoid repeated connection setup attempts to the same host that each suffer from loss caused by a too large initial window. My suggested phrasing would be: "The sender SHOULD cache information about connection setups using an initial window larger than allowed by RFC 3390, and it SHOULD fall back to the initial window allowed by RFC 3390 if there is evidence of performance issues. Further experiments are needed on the design of such a cache and corresponding heuristics." 

If there are any additional comments or thoughts, please let us know. Please focus on suggestions for specific text. 

Thanks

Michael

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 05 Apr 2012 08:15:14 +0100

I think this captures my issues, except that I think it is important to 
clarify that new connections from the "host" or "sending interface" 
SHOULD fall back to the initial window allowed in....

I'm happy to work with the I-D Editors to precision wording if this 
helps, but overall I think we are ready for a WGLC.

Gorry

On 04/04/2012 09:58, Scharf, Michael (Michael) wrote:
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm
>
>

---

From: Joe Touch <[email-masked]>
Date: Thu, 05 Apr 2012 11:21:19 -0700

> * In Section 12, the lost packets during the initial burst is explicitly mentioned as one performance metric that SHOULD be monitored.

FWIW, draft-touch-tcpm-automatic-iw explains how to detect that without 
impact during regular operation ;-)

Joe

---

From: Joe Touch <[email-masked]>
Date: Thu, 05 Apr 2012 11:22:17 -0700

> SHOULD fall back to the initial window allowed in....

FWIW, that is mentioned briefly at the end of Sec 2, but could be better 
included in the summary recommendations in Sec 12.

Joe

>> Here is a summary of what the chairs understood as feedback to be
>> added to the next version of draft-ietf-tcpm-initcwnd-03, which we
>> plan to WGLC:
>>
>> * The wording at the beginning of the draft (and possibly the title)
>> must better highlight the experimental status of the document.
>>
>> * The document should say that at time of publication there is only
>> limited experimental data regarding the impact on non-TCP traffic.
>>
>> * In Section 12, the lost packets during the initial burst is
>> explicitly mentioned as one performance metric that SHOULD be monitored.
>>
>> * The document explicitly states that further work and experiments are
>> needed regarding a backoff mechanism, most notably to avoid repeated
>> connection setup attempts to the same host that each suffer from loss
>> caused by a too large initial window. My suggested phrasing would be:
>> "The sender SHOULD cache information about connection setups using an
>> initial window larger than allowed by RFC 3390, and it SHOULD fall
>> back to the initial window allowed by RFC 3390 if there is evidence of
>> performance issues. Further experiments are needed on the design of
>> such a cache and corresponding heuristics."
>>
>> If there are any additional comments or thoughts, please let us know.
>> Please focus on suggestions for specific text.
>>
>> Thanks
>>
>> Michael
>>

---

From: Joe Touch <[email-masked]>
Date: Thu, 05 Apr 2012 11:23:38 -0700

PS - +1 on ready for WGLC