Subject: Re: [tcpm] draft-williams-overlaypath-ip-tcp-rfc-00

From: Joe Touch <[email-masked]>
Date: Mon, 02 Apr 2012 13:10:41 -0700

Hi, Brandon,

Thanks for the quick turn on this issue.

Typically, the IANA Considerations section would list the specific 
assignments in detail and provide enough information for IANA to assign 
values:

E.g., for IPv4, to list the Class and Copied flags, etc.

...AND for the RFC-Editor to be able to update the text accordingly.

E.g., use TBD-IP4, TBD-IP6, TBD-TCP rather than just "TBD" in locations 
where each is referred to by value.

So that section could use some expansion, but that can happen as the doc 
is updated. The removal of proposed values was more critical, and thanks 
for doing that quickly.

Joe

On 3/29/2012 3:19 PM, Brandon Williams wrote:
> I have submitted a revised version of the draft which no longer
> inappropriately refers to specific option numbers that have not been
> assigned by IANA. Please let me know if the revision does not meet your
> expectations for clarity in this regard.
>
> Thank you,
> --Brandon
>
>
> A new version of I-D, draft-williams-overlaypath-ip-tcp-rfc-01.txt has
> been successfully submitted by Brandon Williams and posted to the IETF
> repository.
>
> Filename: draft-williams-overlaypath-ip-tcp-rfc
> Revision: 01
> Title: Overlay Path Option for IP and TCP
> Creation date: 2012-03-29
> WG ID: Individual Submission
> Number of pages: 15
>
> Abstract:
> Data transport through overlay networks often uses either connection
> termination or network address translation (NAT) in such a way that
> the public IP addresses of the true endpoint machines involved in the
> data transport are invisible to each other. This document describes
> IPv4, IPv6, and TCP options for communicating this information from
> the overlay network to the endpoint machines.
>
> On 03/29/2012 05:24 PM, Brandon Williams wrote:
>> Thank you for taking the time to look the document over and for noting
>> this shortcoming. You are absolutely right that the document should not
>> have been published with any reference to unassigned numbers. I should
>> have realized that this would be unacceptable.
>>
>> I will make that change and publish a version 01 ASAP in order to
>> facilitate further discussion.
>>
>> --Brandon
>>
>> On 03/29/2012 03:52 PM, Joe Touch wrote:
>>> This doc needs to be updated immediately, and references to numbers not
>>> assigned by IANA replaced with TBDs. Notably IP option 218, TCP option
>>> 30, etc. are NOT assigned by IANA.
>>>
>>> There is no such thing as "provisional pending IANA approval"; this
>>> document establishes squatting, period.
>>>
>>> This document should be revised before being further discussed.
>>>
>>> Joe
>>>
>>>
>>> On 3/29/2012 8:11 AM, Brandon Williams wrote:
>>>> An Internet-Draft is available from the on-line Internet-Drafts
>>>> directories.
>>>>
>>>> Title : Overlay Path Option for IP and TCP
>>>> Author : Brandon Williams
>>>> Filename : draft-williams-overlaypath-ip-tcp-rfc-00.txt
>>>> Pages : 15
>>>> Date : 2012-01-17
>>>>
>>>> This document proposes IPv4, IPv6, and TCP options for
>>>> communicating the true IP address of a TCP connection endpoint
>>>> to its peer when that address is hidden due to the use of NAT on
>>>> an overlay network.
>>>>
>>>> A URL for this Internet-Draft is:
>>>> http://www.ietf.org/id/draft-williams-overlaypath-ip-tcp-rfc-00.txt
>>>>
>>>> Internet-Drafts are also available by anonymous FTP at:
>>>> ftp://ftp.ietf.org/internet-drafts/
>>>>
>>>> This Internet-Draft can be retrieved at:
>>>> http://www.ietf.org/id/draft-williams-overlaypath-ip-tcp-rfc-00.txt
>>>>
>>
>

---

From: Brandon Williams <[email-masked]>
Date: Mon, 02 Apr 2012 17:01:20 -0400

Thanks for the additional explanation Joe. That will help me to make the 
necessary clarifications in the next edit.

--Brandon

-- 
Brandon Williams; Principal Software Engineer
Cloud Engineering; Akamai Technologies Inc.