Subject: [tcpm] Shared memory

From: Jamal Cynthia <[email-masked]>
Date: Mon, 16 Jul 2012 07:35:45 -0700 (PDT)

In computing, shared memory is memory that may be simultaneously accessed by multiple programs with an intent to provide communication among them or avoid redundant copies. Shared memory is an efficient means of passing data between programs. 
Depending on context, programs may run on a single processor or on multiple separate processors. 
Using memory for communication inside a single program, for example among its multiple threads, is generally not referred to as shared memory.
When using shared memory communication between multiple processors the WRAPPER level shields user applications from certain counter-intuitive system behaviors. In particular, one issue the WRAPPER layer must deal with is a systems memory model. In general the order of reads and writes expressed by the textual order of an application code may not be the ordering of instructions executed by the processor performing the application. 
The processor performing the application instructions will always operate so that, for the application instructions the processor is executing, any reordering is not apparent. However,in general machines are often designed so that reordering of instructions is not hidden from other second processors. 
This means that, in general, even on a shared memory system two processors can observe inconsistent memory values.

---

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 16 Jul 2012 16:11:35 +0000

Can we block this address from the list? I suspect it's a bot that spews Wikipedia paragraphs to the list. (Google for some of the sentences from the recent emails.)

Lars

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Mon, 16 Jul 2012 19:00:40 +0200

I removed the address from the list.

Michael

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Eggert, Lars
> Sent: Monday, July 16, 2012 6:12 PM
> To: [email-masked]
> Subject: [tcpm] bot? [email-masked]
> 
> Can we block this address from the list? I suspect it's a bot 
> that spews Wikipedia paragraphs to the list. (Google for some 
> of the sentences from the recent emails.)
> 
> Lars