Subject: Re: [tcpm] I-D Action: draft-ietf-tcpm-experimental-options-01.txt

From: Yuchung Cheng <[email-masked]>
Date: Sun, 5 Aug 2012 17:12:28 -0700

On Wed, May 30, 2012 at 3:45 PM, Joe Touch <[email-masked]> wrote:
> Hi, all,
>
> This version incorporates feedback from the list. In specific:
>
> - minimum magic number length is not specified
>
> There are minor reorganization and revisions as well.
>
> Joe
Two questions:

1) how to share the magic value with other developers (for other OSes)?

Since I don't know, I am doing this on the list:
We implemented this draft in the Fast Open for Linux. The magic is 0xF989
by this simple formula (suggested by Eric Dumazet):
time_t now = time(NULL);
printf("0x%04x\n", 0xFFFF & (now ^ (now >> 16)));

   Maybe a simple text file under ietf.org work?

2) While the draft does not address the transition plan, we developers have
   to. TFO plan is that once IANA grants the precious number, Linux will
   support both values for a while, until most clients use the new value.
   It's hassle but well ... but other TCP features may have different plans.

   Should this kind of transition plan be part of any new TCP draft that
   needs new option?

Thanks.

>
>
> On 5/30/2012 3:40 PM, [email-masked] wrote:
>>
>>
>> A New Internet-Draft is available from the on-line Internet-Drafts
>> directories. This draft is a work item of the TCP Maintenance and Minor
>> Extensions Working Group of the IETF.
>>
>>         Title           : Shared Use of Experimental TCP Options
>>         Author(s)       : Joe Touch
>>         Filename        : draft-ietf-tcpm-experimental-options-01.txt
>>         Pages           : 8
>>         Date            : 2012-05-30
>>
>>     This document describes how TCP option codepoints can support
>>     concurrent experiments using a magic number field. This mechanism
>>     avoids the need for a coordinated registry, and is backward-
>>     compatible with currently known uses.
>>
>>
>> A URL for this Internet-Draft is:
>>
>> http://www.ietf.org/internet-drafts/draft-ietf-tcpm-experimental-options-01.txt
>>
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>>
>> This Internet-Draft can be retrieved at:
>>
>> ftp://ftp.ietf.org/internet-drafts/draft-ietf-tcpm-experimental-options-01.txt
>>
>> The IETF datatracker page for this Internet-Draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-tcpm-experimental-options/
>>
>> _______________________________________________
>> tcpm mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/tcpm
>
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

---

From: Joe Touch <[email-masked]>
Date: Mon, 6 Aug 2012 08:40:28 -0700

>   Maybe a simple text file under ietf.org work?

The magic numbers should be noted in the document that defines the option. We can ask IANA to manage the list of such known numbers, but two key issues need to be ensured:

1) the numbers in such a list are voluntarily reported, and IANA doesn't enforce ownership
	i.e., it's just a list of known uses, not a registry

2) numbers in the list need to comply with the recommendations of this doc, i.e., at least 32-bits long

>   support both values for a while, until most clients use the new value.

Correct. We'll make that more clear in an update of this doc.

Support for the magic-number variant can be dropped either when it's desired (to reduce code) or to deliberately transition to production code (vs. experimental, which may differ).

>   Should this kind of transition plan be part of any new TCP draft that

Yes. I'll add that recommendation to this doc as well.

Note that the assigned option SHOULD NOT include the magic number, though - to conserve SYN space.

Joe