Subject: Re: [tcpm] [R-C] Fwd: video and TCP interaction

From: Murari Sridharan <[email-masked]>
Date: Thu, 9 Aug 2012 22:05:02 +0000

It is interesting that this paper references RFC 5681 when it finds that the OS after a period of inactivity goes back to initial (restart) cwnd of 10 packets :-)

Thanks,
Murari

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Matt Mathis
Sent: Thursday, August 9, 2012 9:56 AM
To: rtp-congestion
Cc: Nandita Dukkipati
Subject: [R-C] Fwd: video and TCP interaction

This seem particularly relevant here.

Confused, Timid, and Unstable:
Picking a Video Streaming Rate is Hard

http://www.stanford.edu/~huangty/videoRateAdapt.pdf

>From IMC 2012

Thanks,
--MM--
_______________________________________________
Rtp-congestion mailing list
[email-masked]
http://www.alvestrand.no/mailman/listinfo/rtp-congestion

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Thu, 9 Aug 2012 22:32:31 +0000

SSR is a killer in http streaming apps and there are certain ways to avoid that long inactivity that will trigger SSR. There are quite a number of servers out there running a particular OS that do not implement SSR at all.

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Murari Sridharan
> Sent: Thursday, August 09, 2012 6:05 PM
> To: Matt Mathis; rtp-congestion; tcpm ([email-masked])
> Subject: Re: [tcpm] [R-C] Fwd: video and TCP interaction
> 
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

---

From: Rick Jones <[email-masked]>
Date: Thu, 09 Aug 2012 15:36:54 -0700

On 08/09/2012 03:05 PM, Murari Sridharan wrote:
> It is interesting that this paper references RFC 5681 when it finds
> that the OS after a period of inactivity goes back to initial
> (restart) cwnd of 10 packets :-)

I personally am not much of a fan of slow-start after idle (or persist I 
suppose) but this:

>> The competing wget flow has already filled the buffer during the
>> OFF period, and so the video flow sees very high packet loss.

caught my eye and immediately made me think of the likes of codel and 
wonder how that might have changed behaviour of the overall system.  It 
also made me wonder if the three services might have tested their 
heuristics in an environment with lots and lots of buffering at the 
bottleneck...

rick jones

---

From: "Mo Zanaty (mzanaty)" <[email-masked]>
Date: Fri, 10 Aug 2012 02:17:27 +0000

More interesting than IW10 on CDNs, "Service C" (which must be Vudu) streams at 9M! The RMCAT evaluation criteria should include testing with competing DASH flows (Vudu for fireworks bigger than those in Vancouver).

Mo

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Murari Sridharan
Sent: Thursday, August 09, 2012 6:05 PM
To: Matt Mathis; rtp-congestion; tcpm ([email-masked])
Cc: Nandita Dukkipati
Subject: Re: [R-C] Fwd: video and TCP interaction

Thanks,
Murari

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Matt Mathis
Sent: Thursday, August 9, 2012 9:56 AM
To: rtp-congestion
Cc: Nandita Dukkipati
Subject: [R-C] Fwd: video and TCP interaction

Thanks,
--MM--