Subject: [tcpm] TCPM charter milestone for detailed ECN feedback

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Thu, 4 Oct 2012 10:24:06 +0200

Dear all,

In the last meeting, we had quite strong interest in more detailed ECN feedback, and I therefore proposed the following milestone for the TCPM charter:

  "Sep 2013 	Submit document on more detailed ECN feedback in TCP to the IESG for publication as an Experimental RFC"

Due to the recent IPR statement on related drafts (https://datatracker.ietf.org/ipr/1881/), the chairs want to verify that there is still strong interest and support for that potential charter item.

Could you please send a short note if you are willing to work on that milestone, by contributing text, reviewing drafts, evaluating/implementing mechanisms, etc.?

Thanks

Michael (TCPM co-chair)

---

From: "Scheffenegger, Richard" <[email-masked]>
Date: Thu, 4 Oct 2012 08:33:50 +0000

Hi Michael,

I'm biased (obviously), but yes. I'm trying to learn if the current draft (or extensions of it) can be implemented efficiently in hardware without breaking fastpath processing. [I understand that current hw reverts to slowpath as soon as any "uncommon" TCP or IP header bits like ECE/CWR or ECT/CE are present, diminishing throughput often below wirespeed].

Best regards,

Richard Scheffenegger

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Scharf, Michael (Michael)
> Sent: Donnerstag, 04. Oktober 2012 10:24
> To: [email-masked]
> Subject: [tcpm] TCPM charter milestone for detailed ECN feedback
> 
> Dear all,
> 
> In the last meeting, we had quite strong interest in more detailed ECN
> feedback, and I therefore proposed the following milestone for the TCPM
> charter:
> 
>   "Sep 2013 	Submit document on more detailed ECN feedback in TCP to
> the IESG for publication as an Experimental RFC"
> 
> Due to the recent IPR statement on related drafts
> (https://datatracker.ietf.org/ipr/1881/), the chairs want to verify that
> there is still strong interest and support for that potential charter
> item.
> 
> Could you please send a short note if you are willing to work on that
> milestone, by contributing text, reviewing drafts, evaluating/implementing
> mechanisms, etc.?
> 
> Thanks
> 
> Michael (TCPM co-chair)
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 9 Oct 2012 19:27:21 +0200

Hi Michael,

I want to try and submitt a draft on requirement and kind of a problem 
statement for the more accurate ECN before the initial draft deadline. Maybe 
also including some discussion on pros and cons of different solutions 
(re-using ECN bits, new  header bits, tcp option). You think that's anything 
useful?

Mirja

On Thursday 04 October 2012 10:24:06 Scharf, Michael (Michael) wrote:
>   "Sep 2013 	Submit document on more detailed ECN feedback in TCP to the
> IESG for publication as an Experimental RFC"
>
> there is still strong interest and support for that potential charter item.
>

-- 
-------------------------------------------------------------------
Dipl.-Ing. Mirja Kühlewind
Institute of Communication Networks and Computer Engineering (IKR)
University of Stuttgart, Germany
Pfaffenwaldring 47, D-70569 Stuttgart

tel: +49(0)711/685-67973
email: [email-masked]
web: www.ikr.uni-stuttgart.de
-------------------------------------------------------------------

---

From: [email-masked]
Date: Tue, 9 Oct 2012 20:18:56 +0100

Mirja,

Will the new draft also assess variants that are not known to be covered
by IPR disclosures? That may be indeed be a useful point for input.

Gorry

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Wed, 10 Oct 2012 09:32:41 +0200

Hi Mirja,

As individual TCPM contributor, I think that we still lack a full understanding of the pros and cons of the different variants, and it is worth to discuss this (also in the next meeting).

But the group first has to decide whether to indeed add the charter milestone. Given the complexity and impact of this topic, we need sufficient interest in TCPM. As far as I recall, in Vancouver there was broad support (between 15 and 20 participants) for working on detailed ECN feedback. It would help a lot if those participants could confirm their willingness to contribute on the list.

Michael

> From: Mirja Kuehlewind [mailto:[email-masked]] 
> Sent: Tuesday, October 09, 2012 7:27 PM
> To: [email-masked]
> Cc: Scharf, Michael (Michael)
> Subject: Re: [tcpm] TCPM charter milestone for detailed ECN feedback
> 
> Hi Michael,
> 
> I want to try and submitt a draft on requirement and kind of 
> a problem statement for the more accurate ECN before the 
> initial draft deadline. Maybe also including some discussion 
> on pros and cons of different solutions (re-using ECN bits, 
> new  header bits, tcp option). You think that's anything useful?
> 
> Mirja
> 
> 
> > (https://datatracker.ietf.org/ipr/1881/), the chairs want to verify 
> > that there is still strong interest and support for that 
> potential charter item.
> >
> > milestone, by contributing text, reviewing drafts, 
> > evaluating/implementing mechanisms, etc.?
> >
> > Thanks
> >
> > Michael (TCPM co-chair)
> Institute of Communication Networks and Computer Engineering 
> (IKR) University of Stuttgart, Germany Pfaffenwaldring 47, 
> D-70569 Stuttgart
> 
> tel: +49(0)711/685-67973

---

From: Michael Welzl <[email-masked]>
Date: Wed, 10 Oct 2012 10:50:23 +0200

On Oct 10, 2012, at 9:32 AM, Scharf, Michael (Michael) wrote:

> Hi Mirja,
>
> As individual TCPM contributor, I think that we still lack a full  
> understanding of the pros and cons of the different variants, and it  
> is worth to discuss this (also in the next meeting).
>
> But the group first has to decide whether to indeed add the charter  
> milestone. Given the complexity and impact of this topic, we need  
> sufficient interest in TCPM. As far as I recall, in Vancouver there  
> was broad support (between 15 and 20 participants) for working on  
> detailed ECN feedback. It would help a lot if those participants  
> could confirm their willingness to contribute on the list.

I confirm my willingness to contribute.

Cheers,
Michael

---

From: "Scheffenegger, Richard" <[email-masked]>
Date: Thu, 18 Oct 2012 10:28:50 +0000

Hi Michael,

Same here... (I guess co-authorship is active participation)

I did have an offline discussion with Matt in between, discussing some of the limitations the current proposals have.
http://tools.ietf.org/html/draft-kuehlewind-tcpm-accurate-ecn-option-01
http://tools.ietf.org/html/draft-kuehlewind-tcpm-accurate-ecn-01

Even though we did agree on the definitive usefulness of having that information available, it was unclear what are the exact circumstances the signaling protocol has to fulfill eventually and to what extent...

Thus we didn't arrive at a conclusion, if these proposals fit all the (potential) needs, but we also didn't came up with an example mechanism, that would need more information than what is available with these proposals.

Best regards,

Richard Scheffenegger

> Michael Welzl
> Sent: Mittwoch, 10. Oktober 2012 10:50
> To: Scharf, Michael (Michael)
> Cc: [email-masked]
> > detailed ECN feedback. It would help a lot if those participants could
> > confirm their willingness to contribute on the list.
>