Subject: [tcpm] ECN feedback discussion

From: Ingemar Johansson S <[email-masked]>
Date: Mon, 12 Nov 2012 08:00:17 +0000

Hi

A few comments on an interesting topic.
 
QoS dependent ECN marking: 
I believe the idea to use different ECN marking strategies depending on QoS (or perhaps QCI=QoS class identifier in LTE) has been discussed earlier. 
I am however pretty much in favor of having one strategy regardless of QoS, mainly because of the relative simplicity compared to a special ECN treatment depending on QCI. This may in the end mean that services with a higher QoS will have a higher ECN marking rate  than services with a lower QoS but I don't really see a problem with that and long as it is allowed by operator policies. Also it blends well with the "weighted farness" ideas. In fact ConEx (if it flies) is a good policing framework for this in the sense that services with higher QoS can cause a higher congestion volume.

High density vs Low Density ECN marking:
I really like the idea as it can for instance enable a smoother rate adaptation for e.g video because of the higher number of congestion signals.
Had a look into 3GPP TS36.300, no distinction is made between ECT(0) and ECT(1) there. This means that additional specification is needed to specify that ECT(1) means smomething like "apply high density ECN marking if implemented". When 3GPP TS 26.114 was specified it was explicitly mentioned that ECT(0) should be used, the idea behind was that at some stage there may pop up some interesting use for ECT(1) so it is then best to avoid messing with it. Low/High density ECN is a good cantidate.

/Ingemar
=================================
Ingemar Johansson  M.Sc. 
Senior Researcher

Ericsson AB
Wireless Access Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]
www.ericsson.com

"However beautiful the strategy, 
 you should occasionally look at the results" 
        Sir Winston Churchill
=================================

----------------------------------------------------------------------

Message: 1
Date: Sat, 10 Nov 2012 16:35:12 +0000
From: "Scheffenegger, Richard" <[email-masked]>
Subject: Re: [Iccrg] Re: [tcpm] ECN feedback discussion
To: Michael Welzl <[email-masked]>
Cc: "[email-masked] list" <[email-masked]>
Message-ID: <[email-masked]>
Content-Type: text/plain; charset="utf-8"

That would be my stance too...

Imho, part of why ecn has failed to get traction was/is the complex and nondeterministic way in which the end systems and the network in between are supposed to run a distributed control loop that should keep congestion (standing buffer queues/buffer overflows) at bay.

Imho, dctcp has a very good point in keeping the control loop entirely in the end systems and have a very simple, straight forward and deterministic marking scheme in the network...

I think we need first and foremost a signaling scheme that should lend itself to the most broad applications.

A counter (of some sort, however implemented) would be a huge step forward.

I'm also wondering, if there is information to be had off the exact "pattern" (in the time domain) from CE (or ECT1 too) marks...

I.e. Is a sudden jump from no marks to all marks and then a slow drop of marking probability - all in one RTT - different from a slow rise in markin probabiliy up to 100%, followed by a sudden drop to no marks? With the total number of marks in one RTT equal in both cases? Can anyone think that such a 2nd order signal might be useful, or does anyone know of research into such aspects?

Best regards,
   Richard

Von meinem iPhone gesendet

Am 09.11.2012 um 09:20 schrieb "Michael Welzl" <[email-masked]>:

> Hi,
> 
> I'd prefer a simpler approach. We haven't seen ECN happen, and trying to embed QoS in it isn't exactly going to improve the probability of success IMO.
> 
> Cheers,
> Michael
> 
> 
> On Nov 9, 2012, at 7:21 AM, Arjuna Sathiaseelan wrote:
> 
>> I think updating the behaviour of ECN would be a great idea -
>> 
>> We could have different behaviours for different types of 
>> communication - for e.g.
>> 
>> (1) we could be less aggressive to emergency communications
>> (2) We could be more aggressive to scavenger type traffic
>> (3) We do the normal ecn behaviour inbetween
>> 
>> So probably we-ve got to map QoS behaviour to ECN I guess..
>> 
>> Arjuna
>> 
>> On 9 November 2012 04:50,  <[email-masked]> wrote:
>>> Send Iccrg mailing list submissions to
>>>       [email-masked]
>>> 
>>> To subscribe or unsubscribe via the World Wide Web, visit
>>>       http://oakham.cs.ucl.ac.uk/mailman/listinfo/iccrg
>>> or, via email, send a message with subject or body 'help' to
>>>       [email-masked]
>>> 
>>> You can reach the person managing the list at
>>>       [email-masked]
>>> 
>>> When replying, please edit your Subject line so it is more specific 
>>> than "Re: Contents of Iccrg digest..."
>>> 
>>> 
>>> Today's Topics:
>>> 
>>>  1. Re: [tcpm] ECN feedback discussion (Michael Welzl)  2. Re: New 
>>> co-chair (Eggert, Lars)  3. Re: [tcpm] ECN feedback discussion 
>>> (Yuchung Cheng)  4. Re: [tcpm] ECN feedback discussion (Michael 
>>> Welzl)  5. Re: Re: [tcpm] ECN feedback discussion (Mikael 
>>> Abrahamsson)
>>> 
>>> 
>>> --------------------------------------------------------------------
>>> --
>>>

---

From: "Scheffenegger, Richard" <[email-masked]>
Date: Mon, 12 Nov 2012 10:03:58 +0000

Alternative to using ect1 by the sender (allowing high density ecn marking), what about the sender continuing to use ect0, but high density ecn marking by routers changing that from ect0 to ect1 and ect1 to ce (or ect0 directl to ce on very high load)?

Some papers claim that having an counter to allow multiple routers marking the same packet enables better signal for cc...

also, legacy receivers would only react to ce as usual and not fine grained...

Best regards, richard

Am 12.11.2012 um 09:02 schrieb "Ingemar Johansson S" <[email-masked]>:

> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

---

From: John Leslie <[email-masked]>
Date: Mon, 12 Nov 2012 08:48:25 -0500

Scheffenegger, Richard <[email-masked]> wrote:
> 
> Alternative to using ect1 by the sender (allowing high density ecn
> marking), what about the sender continuing to use ect0, but high
> density ecn marking by routers changing that from ect0 to ect1 andi
> ect1 to ce (or ect0 directl to ce on very high load)?

   A truly interesting idea! Deployable...

   Of course, we'd need research to determine a good thresshold for
marking ect0 to ect1.

--
John Leslie <[email-masked]>

---

From: "Scheffenegger, Richard" <[email-masked]>
Date: Mon, 12 Nov 2012 14:35:20 +0000

I'm back at a decent computer; this is the paper which mentions how the highest congestion rate on one of multiple congested routers can be determined (needs to know the number of hops though; with L2-to-L3 mapping of marks, simple TTL assumtions may not be enough).

"ECN verbose mode: a statistical method for network path congestion estimation", Remi Diana, Emmanuel Lochin, 2010

http://arxiv.org/pdf/0910.4455v2.pdf

I think Emmanuel is listening on one of these groups;

For the signaling aspect, using ECT1 as the initial signal of a high-density marking scheme, and CE for both low-density and when two high-density schemes overlap (mark the same packet) would be an improvement along the lines mentioned in that paper.

However, even the current TCP ECN Nonce feedback wouldn't work properly, as a feedback channel from the receiver to the sender. I'm deliberately excluding other protocols for now...

As Matt suggested, if such a scheme were to be standardized, the balance between feedback for CE and ECT(1) would generally shift more to ECT(1); the codepoint scheme described in draft-kuehlewind-tcpm-accurate-ecn could be adapted to that easily...

Best regards,

Richard Scheffenegger

> -----Original Message-----
> From: John Leslie [mailto:[email-masked]]
> Sent: Montag, 12. November 2012 14:48
> To: Scheffenegger, Richard
> Cc: Ingemar Johansson S; [email-masked]; [email-masked]

---

From: "Scheffenegger, Richard" <[email-masked]>
Date: Mon, 12 Nov 2012 14:55:57 +0000

Hi John,

Assuming that the mechanisms of DCTCP get deployed, the threshold could be a small static number of packets in queue (K ~= 0.17*C*d [pps] and [s]); have you had a read of the analysis paper http://www.stanford.edu/~alizade/Site/DCTCP_files/dctcp_analysis-full.pdf
 
If / how the simple dctcp queue marking could be modified with queue delay (PIE, CoDel) instead of queue depth as signal is still open. But these two algorithms currently assume a low density marking paradigm...

Best regards, 

Richard Scheffenegger

---

From: John Leslie <[email-masked]>
Date: Mon, 12 Nov 2012 17:48:29 -0500

Scheffenegger, Richard <[email-masked]> wrote:
> 
> "ECN verbose mode: a statistical method for network path congestion
> estimation", Remi Diana, Emmanuel Lochin, 2010
> 

   I have replied to this in <iccrg> only -- IMHO the thread belongs there.