Subject: [tcpm] Fwd: New Version Notification for draft-touch-tcpm-2140bis-02.txt

From: Michael Welzl <[email-masked]>
Date: Fri, 13 Jan 2017 10:02:18 +0100

Dear all,

Here's an update of our 2140bis draft; I'd like to request a short slot (maybe 10 mins, like last time) to present this in Chicago, if possible.

Cheers,
Michael

> Begin forwarded message:
> 
> From: <[email-masked]>
> Subject: New Version Notification for draft-touch-tcpm-2140bis-02.txt
> Date: 13 Jan 2017 01:44:04 CET
> To: Jianjie You <[email-masked]>, Joe Touch <[email-masked]>, "Safiqul Islam" <[email-masked]>, Joseph Touch <[email-masked]>, Michael Welzl <[email-masked]>
> Resent-From: <[email-masked]>
> 
> 
> A new version of I-D, draft-touch-tcpm-2140bis-02.txt
> has been successfully submitted by Joe Touch and posted to the
> IETF repository.
> 
> Name:		draft-touch-tcpm-2140bis
> Revision:	02
> Title:		TCP Control Block Interdependence
> Document date:	2017-01-12
> Group:		Individual Submission
> Pages:		23
> URL:            https://www.ietf.org/internet-drafts/draft-touch-tcpm-2140bis-02.txt
> Status:         https://datatracker.ietf.org/doc/draft-touch-tcpm-2140bis/
> Htmlized:       https://tools.ietf.org/html/draft-touch-tcpm-2140bis-02
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-touch-tcpm-2140bis-02
> 
> Abstract:
>   This memo describes interdependent TCP control blocks, where part of
>   the TCP state is shared among similar concurrent or consecutive
>   connections. TCP state includes a combination of parameters, such as
>   connection state, current round-trip time estimates, congestion
>   control information, and process information. Most of this state is
>   maintained on a per-connection basis in the TCP Control Block (TCB),
>   but implementations can (and do) share certain TCB information
>   across connections to the same host. Such sharing is intended to
>   improve overall transient transport performance, while maintaining
>   backward-compatibility with existing implementations. The sharing
>   described herein is limited to only the TCB initialization and so
>   has no effect on the long-term behavior of TCP after a connection
>   has been established.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Yoshifumi Nishida <[email-masked]>
Date: Tue, 17 Jan 2017 00:11:12 -0800

Hello,

I remember that there were some discussions about the status of the draft.
Whether this should be informational or BCP. (
https://tools.ietf.org/wg/tcpm/minutes?item=minutes-97-tcpm-00.html)
Should we proceed it as an informational draft? Or, do we explore some ways
to make it BCP?

Thanks,
--
Yoshi

On Fri, Jan 13, 2017 at 1:02 AM, Michael Welzl <[email-masked]> wrote:

> Dear all,
>
> Here's an update of our 2140bis draft; I'd like to request a short slot
> (maybe 10 mins, like last time) to present this in Chicago, if possible.
>
> Cheers,
> Michael
>
>
> > Begin forwarded message:
> >
> > To: Jianjie You <[email-masked]>, Joe Touch <[email-masked]>,
> "Safiqul Islam" <[email-masked]>, Joseph Touch <[email-masked]>,
> Michael Welzl <[email-masked]>
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm
>

---

From: Joe Touch <[email-masked]>
Date: Tue, 17 Jan 2017 15:27:47 -0800

Hi, Yoshi,

We're open to either one. I'd be glad to see it move towards BCP as
we're incorporating exactly that - best current practice - into the doc
during these revisions.

However, I think we can also make the final decision on that after the
doc is adopted and based on the final content. At this point, IMO, it
should qualify as a WG doc at least as one of those two.

Joe

On 1/17/2017 12:11 AM, Yoshifumi Nishida wrote:
> Hello,
>
> I remember that there were some discussions about the status of the
> draft. Whether this should be informational or BCP.
> (https://tools.ietf.org/wg/tcpm/minutes?item=minutes-97-tcpm-00.html)
> Should we proceed it as an informational draft? Or, do we explore some
> ways to make it BCP?
>
> Thanks,
> --
> Yoshi
>
> On Fri, Jan 13, 2017 at 1:02 AM, Michael Welzl <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Dear all,
>
>     Here's an update of our 2140bis draft; I'd like to request a short
>     slot (maybe 10 mins, like last time) to present this in Chicago,
>     if possible.
>
>     Cheers,
>     Michael
>
>
>     > Begin forwarded message:
>     >
>     > From: <[email-masked] <mailto:[email-masked]>>
>     > To: Jianjie You <[email-masked]
>     <mailto:[email-masked]>>, Joe Touch <[email-masked]
>     <mailto:[email-masked]>>, "Safiqul Islam" <[email-masked]
>     <mailto:[email-masked]>>, Joseph Touch <[email-masked]
>     <mailto:[email-masked]>>, Michael Welzl <[email-masked]
>     <mailto:[email-masked]>>
>     > Resent-From: <[email-masked] <mailto:[email-masked]>>
>     >
>     >
>     > URL:           
>     https://www.ietf.org/internet-drafts/draft-touch-tcpm-2140bis-02.txt
>     <https://www.ietf.org/internet-drafts/draft-touch-tcpm-2140bis-02.txt>
>     > Status:       
>      https://datatracker.ietf.org/doc/draft-touch-tcpm-2140bis/
>     <https://datatracker.ietf.org/doc/draft-touch-tcpm-2140bis/>
>     > Htmlized:     
>      https://tools.ietf.org/html/draft-touch-tcpm-2140bis-02
>     <https://tools.ietf.org/html/draft-touch-tcpm-2140bis-02>
>     > Diff:         
>      https://www.ietf.org/rfcdiff?url2=draft-touch-tcpm-2140bis-02
>     <https://www.ietf.org/rfcdiff?url2=draft-touch-tcpm-2140bis-02>
>     >
>     > Abstract:
>     > until the htmlized version and diff are available at
>     tools.ietf.org <http://tools.ietf.org>.
>     >
>     > The IETF Secretariat
>     >
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/tcpm>
>
>
>
>