Subject: [tcpm] draft-ietf-tcpm-rack-02 - TLP algorithm question

From: Felix Weinrank <[email-masked]>
Date: Tue, 21 Mar 2017 23:53:00 +0100

Hey all,

I have a question regarding the TLP algorithm in draft-ietf-tcpm-rack-02
In 6.2.1.  Phase 1: Scheduling a loss probe:

>         If an SRTT estimate is available:
>             PTO = 2 * SRTT
>         Else:
>             PTO = initial RTO of 1 sec
>         If FlightSize = 1:
>             PTO = max(PTO, 1.5 * SRTT + WCDelAckT)
>         PTO = max(10ms, PTO)
>         PTO = max(RTO, PTO)
The last line "PTO = max(RTO, PTO)" makes no sense to me.
It has been changed from "min" to "max" in the 02 version.

The explaining paragraph below also hints for "min"
> If RTO is smaller than the computed value for PTO, then a probe is scheduled to be sent
> at the RTO time.

Greetings
Felix Weinrank

---

From: Neal Cardwell <[email-masked]>
Date: Tue, 21 Mar 2017 19:51:07 -0400

> In 6.2.1.  Phase 1: Scheduling a loss probe:
...
> It has been changed from "min" to "max" in the 02 version.

Yes, I believe you are right that a bug crept in between
draft-ietf-tcpm-rack-01 and draft-ietf-tcpm-rack-02. I have reverted
to:

   PTO = min(RTO, PTO)

 in our internal copy, so this fix should be reflected in the next
version of the RACK Internet Draft.

Thanks for catching that!

neal