Subject: Re: [tcpm] WGLC for draft-ietf-tcpm-cubic-04

From: Yoshifumi Nishida <[email-masked]>
Date: Thu, 23 Mar 2017 14:23:27 -0700

Hello,
The WGLC for this draft has already finished, but we haven't seen many
comments on this draft.
We are trying to interpret this is an indication that people are satisfied
with the current draft, but we just would like to be sure.
Please let us know in case you have very last minute comments.
We'll do similar final check at the venue. If nothing happens, we will try
to proceed the doc after reviewing the updated version.

Thanks,
--
tcpm co-chairs

On Wed, Feb 15, 2017 at 1:13 AM, Yoshifumi Nishida <[email-masked]>
wrote:

> Hello,
>
> In addition to the dctcp draft, TCP chairs conclude that
> draft-ietf-tcpm-cubic-04 is ready for WGLC as well and decided to initiate
> the call.
>
> The WGLC for this draft runs until * Friday March 3 *.
> Please send your feedback to the ML.
>
> BTW, the intended status of the draft is Informational.
> The draft is available from the following URL.
> https://tools.ietf.org/html/draft-ietf-tcpm-cubic-04
>
> Thanks,
> --
> Yoshi
>

---

From: Michael Welzl <[email-masked]>
Date: Wed, 29 Mar 2017 09:42:38 -0500

Hi all,

I have a comment:

When we did tests with Cubic in a local testbed, it exhibited nonlinear behavior as we varied the BDP (e.g. changing capacity or RTT).

We found the “Fast convergence” mechanism in section 4.6 to be the culprit: it assumes that, when W_max < W_last_max, new flows have joined and Cubic should make room for them.
However, when doing tests of only a single flow in a controlled environment, and the BDP is e.g. around 10.5 packets, in reality, a flow may get W_max of 10, 11, 10, 11, … etc. This means that the mechanism keeps kicking in. Next, you do a test with a BDP of 0.5 packets more, and then W_max is statically 11 … so the behavior fluctuates quite a bit as a result of small changes to the BDP.

When testing flows in controlled condition and in isolation, I think this mechanism doesn’t make sense to use anyway. So I think it would be useful to insert a comment about this in section 4.6 for people doing such experiments.

Besides, I think the last paragraph of section 4.6 is hard to understand. It just doesn’t seem clear to say that flows with smaller shares can better increase their windows because flows with larger shares “spend more time around the plateau”.

The comments in the code snippet are also confusing: “check downward trend” and “check upward trend”, what is that supposed to mean? I think “check downward trend” could be “should we make room for other flows?” or something like that.

Cheers,
Michael

> On Mar 23, 2017, at 4:23 PM, Yoshifumi Nishida <[email-masked]> wrote:
> 
> Hello,
> The WGLC for this draft has already finished, but we haven't seen many comments on this draft.
> We are trying to interpret this is an indication that people are satisfied with the current draft, but we just would like to be sure. 
> We'll do similar final check at the venue. If nothing happens, we will try to proceed the doc after reviewing the updated version.
> 
> Thanks,
> --
> tcpm co-chairs
> 
> On Wed, Feb 15, 2017 at 1:13 AM, Yoshifumi Nishida <[email-masked] <mailto:[email-masked]>> wrote:
> Hello,
> 
> In addition to the dctcp draft, TCP chairs conclude that draft-ietf-tcpm-cubic-04 is ready for WGLC as well and decided to initiate the call.
> 
> https://tools.ietf.org/html/draft-ietf-tcpm-cubic-04 <https://tools.ietf.org/html/draft-ietf-tcpm-cubic-04>
> 
> Thanks,
> --
> Yoshi
> 
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm