Subject: [tcpm] slowstart after idle question

From: Ingemar Johansson S <[email-masked]>
Date: Thu, 20 Apr 2017 06:42:38 +0000

Hi

Possibly a question that would fit better in a Linux net dev forum but anyway..

I have one short question. Is slow start after idle generally disabled (net.ipv4.tcp_slow_start_after_idle=0) for instance  for HTTP video streaming ?.

I can imagine that there are some benefits with avoiding the CWND decrease in idle periods.
Of course there is a problem that a large amount of data is transmitted when new objects are sent to the TCP sockets (shown on page 12 in https://www.ietf.org/proceedings/96/slides/slides-96-iccrg-1.pdf ), but packet pacing can solve this issue.

/Ingemar
==================================
Ingemar Johansson  M.Sc.
Master Researcher

Ericsson AB
Wireless Access Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]<mailto:[email-masked]>
www.ericsson.com

A mistake is to commit a misunderstanding
                     Bob Dylan
==================================

---

From: Neal Cardwell <[email-masked]>
Date: Thu, 20 Apr 2017 14:26:44 -0700

Hi Ingemar,

As one data point, YouTube disables tcp_slow_start_after_idle, but
paces when restarting from idle. This is true both in the previous
CUBIC era and also now that BBR is deployed for YouTube TCP traffic.

Yuchung's  presentation from a few years back also has a nice
discussion of some of the related issues:

  https://www.ietf.org/proceedings/88/slides/slides-88-tcpm-9.pdf

neal

On Wed, Apr 19, 2017 at 11:42 PM, Ingemar Johansson S
<[email-masked]> wrote:
> I have one short question. Is slow start after idle generally disabled
> (net.ipv4.tcp_slow_start_after_idle=0) for instance  for HTTP video
> streaming ?.
>
>
>
> Of course there is a problem that a large amount of data is transmitted when
> new objects are sent to the TCP sockets (shown on page 12 in
> https://www.ietf.org/proceedings/96/slides/slides-96-iccrg-1.pdf ), but
> packet pacing can solve this issue.
>
>
>
>
>
> /Ingemar
>
> [email-masked]
>
> www.ericsson.com
>
>
>
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm
>

---

From: Ingemar Johansson S <[email-masked]>
Date: Fri, 21 Apr 2017 10:25:35 +0000

Thanks for the help !

/Ingemar

> -----Original Message-----
> From: Neal Cardwell [mailto:[email-masked]]
> Sent: den 20 april 2017 23:27
> To: Ingemar Johansson S <[email-masked]>
> Cc: [email-masked]; Yuchung Cheng <[email-masked]>
> Subject: Re: [tcpm] slowstart after idle question
> 
> Hi Ingemar,
> 
> As one data point, YouTube disables tcp_slow_start_after_idle, but paces
> when restarting from idle. This is true both in the previous CUBIC era and also
> now that BBR is deployed for YouTube TCP traffic.
> 
> Yuchung's  presentation from a few years back also has a nice discussion of
> some of the related issues:
> 
> > Of course there is a problem that a large amount of data is
> > transmitted when new objects are sent to the TCP sockets (shown on
> > page 12 in