Subject: [tcpm] Working group acceptance call draft-bagnulo-tcpm-generalized-ecn-04

From: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Fri, 16 Jun 2017 06:06:43 +0000

Hi all,

As requested by the authors, this e-mail starts a working group acceptance call for draft-bagnulo-tcpm-generalized-ecn-04, which will run on the list until June 30.

The proposal is to add a new milestone to the  TCPM charter

  Submit document on adding Explicit Congestion Notification (ECN) to TCP Control Packets to the IESG for publication as Experimental RFC

and to use draft-bagnulo-tcpm-generalized-ecn as a starting point.

If you believe that TCPM should work on a document in this space, and in particular if you are willing to review it, please reply to this e-mails. Please also speak up if you have any concerns or objections.

Thanks

Michael

---

From: Bob Briscoe <[email-masked]>
Date: Fri, 23 Jun 2017 18:50:56 +0100

Michael, Randall, Xuesong,

Are you considering implementing ECN in SCTP? I noticed that your 
initial SCTP/ECN draft prohibits ECN on similar control packets to those 
prohibited in TCP. So I wrote this section about transferability to SCTP 
<https://tools.ietf.org/html/draft-bagnulo-tcpm-generalized-ecn-04#section-5.1> 
into the ECN++ draft, which is targeted at TCP but also has a section on 
variants.
(The adoption call for the draft is below - deadline: 30 Jun).

I know the details of handshake and other control packets are different, 
but I think the principles are transferable.
Is this a correct understanding of the position wrt SCTP?

Cheers

Bob

-------- Forwarded Message --------
Subject: 	[tcpm] Working group acceptance call 
draft-bagnulo-tcpm-generalized-ecn-04
Date: 	Fri, 16 Jun 2017 06:06:43 +0000
From: 	Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]>
To: 	[email-masked] <[email-masked]>
CC: 	[email-masked] <[email-masked]>

Hi all,

As requested by the authors, this e-mail starts a working group 
acceptance call for draft-bagnulo-tcpm-generalized-ecn-04, which will 
run on the list until June 30.

   Submit document on adding Explicit Congestion Notification (ECN) to 
TCP Control Packets to the IESG for publication as Experimental RFC

If you believe that TCPM should work on a document in this space, and in 
particular if you are willing to review it, please reply to this 
e-mails. Please also speak up if you have any concerns or objections.

Thanks

Michael

-- 
________________________________________________________________
Bob Briscoehttp://bobbriscoe.net/

---

From: David Schinazi <[email-masked]>
Date: Fri, 23 Jun 2017 18:56:09 -0700

Hi,

I believe there is value in this work and I think it should be adopted by the working group.

Thanks,
David Schinazi

> On Jun 15, 2017, at 23:06, Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]> wrote:
> 
> Hi all,
>  
> _______________________________________________
> tcpm mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/tcpm <https://www.ietf.org/mailman/listinfo/tcpm>

---

From: "Gorry (erg)" <[email-masked]>
Date: Sat, 24 Jun 2017 10:17:23 +0100

I do have this on my list to review. I did not expect this draft to mention SCTP. I will certainly comment, but do not expect to see new protocol work for SCTP being done in TCPM.

Gorry 

> On 23 Jun 2017, at 18:50, Bob Briscoe <[email-masked]> wrote:
> 
> Are you considering implementing ECN in SCTP? I noticed that your initial SCTP/ECN draft prohibits ECN on similar control packets to those prohibited in TCP. So I wrote this section about transferability to SCTP into the ECN++ draft, which is targeted at TCP but also has a section on variants. 
> I know the details of handshake and other control packets are different, but I think the principles are transferable.
> Subject:	[tcpm] Working group acceptance call draft-bagnulo-tcpm-generalized-ecn-04
> Bob Briscoe                               http://bobbriscoe.net/
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

---

From: Bob Briscoe <[email-masked]>
Date: Sat, 24 Jun 2017 10:49:28 +0100

Gorry,

Thx for promising to review.

The draft does not affect SCTP. We have included a section at the end on 
the (non-)interaction of Generalized ECN with TCP variants (SCTP, TFO, 
IW10, SYN cookies, L4S).
https://tools.ietf.org/html/draft-bagnulo-tcpm-generalized-ecn-04#section-5

We note that, currently, the only draft on adding ECN to SCTP mimics 
RFC3168 by prohibiting ECN support on all control packets. We then 
merely note that:
    "When ECN is finally added to SCTP, experience
    from experiments on adding ECN support to all TCP packets ought to be
    directly transferable to SCTP."

I know TFO, IW10, etc in depth. However, I was just checking with the 
authors whether this statement hides complexity in SCTP that I'm not 
aware of (cos I don't know SCTP in depth).

Bob

On 24/06/17 10:17, Gorry (erg) wrote:
> I do have this on my list to review. I did not expect this draft to 
> mention SCTP. I will certainly comment, but do not expect to see new 
> protocol work for SCTP being done in TCPM.
>
> Gorry
>
> On 23 Jun 2017, at 18:50, Bob Briscoe <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>> initial SCTP/ECN draft prohibits ECN on similar control packets to 
>> those prohibited in TCP. So I wrote this section about 
>> transferability to SCTP 
>> into the ECN++ draft, which is targeted at TCP but also has a section 
>> on variants.
>> I know the details of handshake and other control packets are 
>> different, but I think the principles are transferable.
>> If you believe that TCPM should work on a document in this space, and 
>> in particular if you are willing to review it, please reply to this

---

From: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Sat, 24 Jun 2017 20:02:12 +0000

As a reminder, we have two ongoing working group adoption calls. Further feedback would be highly welcome.

Michael

From: [email-masked] [mailto:[email-masked]]
Sent: Samstag, 24. Juni 2017 03:56
To: Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [tcpm] Working group acceptance call draft-bagnulo-tcpm-generalized-ecn-04

Hi,

Thanks,
David Schinazi

On Jun 15, 2017, at 23:06, Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Thanks

Michael
_______________________________________________
tcpm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tcpm