Subject: Re: [tcpm] Working group acceptance call for draft-touch-tcpm-2140bis

From: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Fri, 21 Jul 2017 09:37:06 +0000

Hi all,

On Monday, there was substantial support in the room to adopt 2140bis and the chairs believe the WG consensus is to adopt this document. The open question is the status.

In the room, there was some support for a BCP but there is no clear consensus on that at this point in time.

The chair proposal is as follows. The following charter item will be added to the TCPM charter:

  "Submit 2140bis document to the IESG for publication targeting a Best Current Practice RFC" (target: November 2018)

This charter item would allow the working group to work on and discuss a BCP.
It would be up to the editors to convince the working group that the document content will warrant a BCP. The status would be reviewed during WGLC. If reviews would disagree with BCP status, a consensus call will be required and TCPM may decide to request publication as INFO instead, which would be a simple editorial change without wasting work. In a nutshell, there chairs want to highlight that is no automatism that this document would indeed get BCP status and the WG consensus can change. However, the chairs believe that we should not prevent a BCP at this point in time.

Feedback would be welcome. In absence of feedback chairs will ask the AD to add the milestone as suggested.

Thanks

Michael

> -----Original Message-----
> From: Scharf, Michael (Nokia - DE/Stuttgart)
> [mailto:[email-masked]]
> Sent: Tuesday, June 13, 2017 12:07 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Working group acceptance call for draft-touch-tcpm-2140bis
> 
> Hi all,
> 
> As requested by the authors, this e-mail starts a working group acceptance
> call for draft-touch-tcpm-2140bis-02, which will run on the list until June 30.
> 
> The proposal is to add a new milestone to the  TCPM charter and to use
> draft-touch-tcpm-2140bis as a starting point.
> 
> More specifically, the TCPM chairs look for community feedback on the
> target status. Two options for a charter milestone would be:
> 
> (1) "Submit document on TCP Control Block Interdependence to the IESG for
> publication as Informational RFC"
> 
> or
> 
> (2) "Submit document on TCP Control Block Interdependence to the IESG for
> publication as either Informational RFC or BCP; the status will be decided by
> working group consensus prior to the WGLC"
> 
> Note that RFC 2140 is informational. Feedback on the charter wording would
> be highly welcome.
> 
> It is understood that the document content requires significant further work
> and discussion in TCPM. The purpose of this adoption call is to check whether
> there is sufficient interest to discuss and further improve the document
> under change control of the TCPM working group.
> 
> If you believe that TCPM should work on a document in this space, and in
> particular if you are willing to review it, please reply to this e-mails. Please
> also speak up if you have any concerns or objections.
> 
> Thanks
> 
> Michael
> TCPM cat herder

---

From: Joe Touch <[email-masked]>
Date: Fri, 21 Jul 2017 08:18:26 -0700

Hi Michael, et al,

On 7/21/2017 2:37 AM, Scharf, Michael (Nokia - DE/Stuttgart) wrote:
> If reviews would disagree with BCP status, a consensus call will be required and TCPM may decide to request publication as INFO instead, which would be a simple editorial change without wasting work.
I disagree with both this approach and this conclusion.

The original RFC was informational because it provided no specific
recommendations.

The whole point of this document centers around the concept of BCP:
- a survey of existing deployed practice
- an analysis of which behaviors are recommended and which should be
corrected
- an indication of the boundaries within which future deployments can be
safe

If the WG were to decide that this doc were to be informational, then
there would be no reason to have spent WG time and resources debating
those issues, and (more to the point) the specific recommendations would
need to be removed.

Speaking for myself both as author and WG member, I don't think it is
useful to waste those resources if we don't have consensus to create a
BCP document. Although any document could be reclassified at any time in
the WG process, I see no reason to delay that debate for this document
or treat it differently.

I.e., if there is insufficient WG consensus to move forward as BCP, I
propose that this revision is not needed and we can save a lot of time
and effort now.

Joe

---

From: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Fri, 21 Jul 2017 17:03:07 +0000

Joe,

The feedback in the room is clearly different to your conclusion, as a substantial part of the community seems to see value in an informational document but not a BCP.

It is not uncommon that authors are convinced that their document warrants a more normative status than parts of the working group. But in that case it is up to the authors to work with the WG to reach consensus. The proposed charter milestone allows that.

I do not believe that the TCPM chairs should declare rough consensus on a BCP document, in particular not at early stage. It is TCPM's tradition to try to achieve unanimous consensus.

Michael

> From: Joe Touch [mailto:[email-masked]]
> Sent: Friday, July 21, 2017 5:18 PM
> To: Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]>;
> [email-masked]
> Cc: [email-masked]
> Subject: Re: [tcpm] Working group acceptance call for draft-touch-tcpm-
> 2140bis
> 
> 
> Hi Michael, et al,
> 
> > If reviews would disagree with BCP status, a consensus call will be required
> and TCPM may decide to request publication as INFO instead, which would
> be a simple editorial change without wasting work.
> If the WG were to decide that this doc were to be informational, then there
> would be no reason to have spent WG time and resources debating those
> issues, and (more to the point) the specific recommendations would need to
> be removed.
> 
> Speaking for myself both as author and WG member, I don't think it is useful
> to waste those resources if we don't have consensus to create a BCP
> document. Although any document could be reclassified at any time in the
> WG process, I see no reason to delay that debate for this document or treat
> it differently.
> 
> I.e., if there is insufficient WG consensus to move forward as BCP, I propose
> that this revision is not needed and we can save a lot of time and effort now.
> 
> Joe

---

From: Joe Touch <[email-masked]>
Date: Fri, 21 Jul 2017 10:12:10 -0700

> On Jul 21, 2017, at 10:03 AM, Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]> wrote:
> 
> Joe,
> 

An informational doc would not appropriately include recommendations. 

> I do not believe that the TCPM chairs should declare rough consensus on a BCP document, in particular not at early stage. It is TCPM's tradition to try to achieve unanimous consensus.

I was not asking for that. I am claiming that there is a misunderstanding of the work difference between informational and BCP. The items the WG appears to want added would imply BCP. If BCP isn't the target, then we can excise a lot of the current material and jump to WGLC.

I'm saying the WG can't "eat it's cake and have it too".  If the consensus is to add BCP material, then it needs to adopt as a BCP work item. If there is no consensus on BCP,  then the work should not progress along those lines.

Joe

---

From: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Fri, 21 Jul 2017 20:35:18 +0000

> > The feedback in the room is clearly different to your conclusion, as a
> substantial part of the community seems to see value in an informational
> document but not a BCP.
> 

An informational document can document existing practice without normative recommendations and at least my take is that this is what the WG is comfortable with as there is no need to define "best", which is challenging for stack-internal implementation choices.

> > It is not uncommon that authors are convinced that their document
> warrants a more normative status than parts of the working group. But in
> that case it is up to the authors to work with the WG to reach consensus. The
> proposed charter milestone allows that.
> >
> > I do not believe that the TCPM chairs should declare rough consensus on a
> BCP document, in particular not at early stage. It is TCPM's tradition to try to
> achieve unanimous consensus.
> 
> I was not asking for that. I am claiming that there is a misunderstanding of the
> work difference between informational and BCP. The items the WG appears
> to want added would imply BCP. If BCP isn't the target, then we can excise a
> lot of the current material and jump to WGLC.

It is a misconception of the working group consensus that a BCP is needed or wanted. A subset of the working group believes that a BCP document can be worked out while there is consensus that an INFO document can be published.
 
An informational document can document implementation behavior and provide rationale for that, but probably should avoid RFC 2119 language. A BCP would make normative recommendations. As of now, it is unclear whether the WG would reach unanimous consensus on normative statements of what is "best" for implementation internals so it seems difficult to make a call right now. 

> I'm saying the WG can't "eat it's cake and have it too".  If the consensus is to
> add BCP material, then it needs to adopt as a BCP work item. If there is no
> consensus on BCP,  then the work should not progress along those lines.

The WG can only make a call on BCP when there is exact wording for the proposed BCP material. And this requires a specific text proposal with a clear separation between BCP and informational material. The authors have not proposed so far such a split between BCP and INFO and so they cannot ask the WG to make a call on that.

I think the consensus is that the WG is open to a proposal for BCP material but careful review is needed and in case no consensus will be achieved on the BCP material, the document would have to be INFO as a whole, or INFO for all parts that do not get strong consensus. I don't think the authors can ask for more from the WG with their wording in -02, which does not describe the scope of a BCP.

It is understood that a BCP would require more work in the WG but the proposed charter milestone would allow that work, provided that the authors are willing to engage.

I also think the WG would be very happy with an informational document that just updates 2140 and surveys actual implementation practice, which is basically what the authors have proposed in -02 so far. Also in that case the rationale for statements would have to be carefully reviewed. But it would be easier to deal with all cases where implementation-internal choices are different or where it is difficult to define "best", "safe", etc. This could save a lot of WG cycles on discussing implementation-internals.

If the authors (and the other supporters of BCP) would agree to a target status of INFO, I would be more than willing to change my proposed charter wording to INFO.

Michael