Subject: [tcpm] RTO and PTO (tlp)

From: hiren panchasara <[email-masked]>
Date: Sun, 15 Oct 2017 19:08:22 -0700

Seems that only one "timeout" mechanism needs to be active at any point
in time. Is that the correct assessment?

It seems to me that linux schedules RTO only when PTO can't be
scheduled. And when that PTO fires, at the end it makes sure either PTO
or RTO is scheduled.

Cheers,
Hiren

---

From: Praveen Balasubramanian <[email-masked]>
Date: Mon, 16 Oct 2017 02:49:26 +0000

In the Windows implementation of TLP, the retransmit timer (which typically schedules RTO) is used for scheduling PTO. Only one timeout mechanism is active and it simplifies the logic. The implementation can distinguish in the expiration handler that PTO was armed versus the RTO by using a bit that tracks this.

-----Original Message-----
From: tcpm [mailto:[email-masked]] On Behalf Of hiren panchasara
Sent: Sunday, October 15, 2017 7:08 PM
To: [email-masked]
Subject: [tcpm] RTO and PTO (tlp)

Seems that only one "timeout" mechanism needs to be active at any point in time. Is that the correct assessment?

It seems to me that linux schedules RTO only when PTO can't be scheduled. And when that PTO fires, at the end it makes sure either PTO or RTO is scheduled.

Cheers,
Hiren

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 15 Oct 2017 22:57:48 -0700

Hi Hiren,

This is how we implement it in QUIC. We use the same timer, first for TLP
and then after for RTO.

- jana

On Sun, Oct 15, 2017 at 7:08 PM, hiren panchasara <
[email-masked]> wrote:

> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm
>
>

---

From: hiren panchasara <[email-masked]>
Date: Mon, 16 Oct 2017 00:25:15 -0700

Thanks Praveen and Jana!

This seems quite logical and at least 3 major implementations are also
doing this so I wonder if this is something that can be noted in the TLP
draft to help implementers. Or is it too much of an implementation
detail?

Cheers,
Hiren

---

From: Neal Cardwell <[email-masked]>
Date: Mon, 16 Oct 2017 06:49:52 -0700

> draft to help implementers. Or is it too much of an implementation

Hiren - Good point. I agree it would be useful to clarify this in the
RACK+TLP draft. I have proposed some text to my co-authors, and we will
iterate on this. So hopefully this should be more clear in the next
revision.

thanks,
neal

---

From: hiren panchasara <[email-masked]>
Date: Mon, 16 Oct 2017 07:23:44 -0700

> iterate on this. So hopefully this should be more clear in the next

Thank you!

Cheers,
Hiren