Subject: Re: [Techspec] Requirement about pre-aaproved (or consensus reached) text in doc uments

From: Bob Braden <[email-masked]>
Date: Wed, 16 Nov 2005 11:36:05 -0800 (PST)

*> 
  *> Not sure how to word this. But I think we have a requirement that
  *> the RFC-editing/publication function does leave alone text in
  *> approved internet-drafts that has been "pre-approved" or has reached
  *> "wide consensus" before the doc gets to the Approved state.
  *> 

I don't see what's hard.  Pre-approved IETF boilerplate should not
be further edited.  This is one of those "yes, of course" requirements,
that seem to go without saying.  It is equivalent to "Don't do anything
stupid".  And of course the RFC Editor (for example ;-)) follows this
policy (except when we screw up, but we already apologized to you
for the most recent case and corrected it).

Does every error the RFC Editor makes have to be made into a federal
case?  Is that the function of this group?

Bob Braden

_______________________________________________
Techspec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/techspec

---

From: Leslie Daigle <[email-masked]>
Date: Wed, 16 Nov 2005 14:59:14 -0500

> case?  Is that the function of this group?

Bob, please understand "this isn't about you".  Using
recent experience to capture another requirement is
a case of making the implicit knowledge explicit. Which
is useful for a number of reasons, no the least of which
is raising IETF awareness to what is required and making
sure (for eg) it's easier to transition from one AD to
the next without having to do a Vulcan mind-meld.

Leslie.

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 18 Nov 2005 13:43:58 +0100

Bob Braden wrote:
> be further edited. 

Actually, I don't think that standard boilerplate was the issue.
Barring human error, that's already taken care of.

It is more that sometimes, consensus in a WG or between the IESG and
WG has been very hard won, and even a comma can make a difference in
such a case. So some pieces of text may become the moral equivalent
of embedded code and MUST NOT [RFC 2119] be edited.

I don't think this is hard. It could simply be handled by

[Note to RFC Editor: the following paragraph is consensus text
and must not be edited for style or content.]

    Brian