Subject: Re: [Techspec] New requirement for early permanent ID allocation

From: Brian E Carpenter <[email-masked]>
Date: Wed, 01 Mar 2006 09:37:03 +0100

Pekka Savola wrote:
> On Thu, 23 Feb 2006, Wijnen, Bert (Bert) wrote:
> 
>> Let me (repeat) state that my opinion is that we SHOULD be able
>> to achieve RFC-publication within 2 months (or less) after
>> IESG approval. And if we can achieve that, then I maintain
>> that early stable references is farr less of a problem (if at all).
>>
>> Just my personal opinion of course.
>>
>> I would rather work on trying to get to a fast-publication-after-approval
>> than thinking of stop-ga[p measures to deal with too-slow-publication.
> 
> 
> FWIW, I agree completely.  If you add fast-tracking to this, we should 
> already have enough tools to allow fast document publication in general, 
> and even faster when required.

That is all true. But I don't believe that the permanent identifier issue
is a big deal. In fact, I bet you that today the RFC number is internally
assigned pretty much as soon as a draft gets in the publication queue.
The question is when it gets published, and that is something we can
choose quite independently of everything else. I think it's important
that the IETF states a requirement that this publication occurs when we
need it to occur.

     Brian

_______________________________________________
Techspec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/techspec

---

From: "Stephen Hayes (TX/EUS)" <[email-masked]>
Date: Wed, 1 Mar 2006 13:40:06 -0600

I think we are in agreement, but I want to make sure.

Stephen Hayes

> -----Original Message-----
> From: Paul Hoffman [mailto:[email-masked]]
> Sent: Wednesday, March 01, 2006 12:24 PM
> To: [email-masked]
> Subject: Re: [Techspec] New requirement for early permanent ID
> allocation
> 
> 
> At 8:34 AM -0500 3/1/06, John C Klensin wrote:
> >So I read the
> >description of this issue/ requirement, saw what "permanent
> >IDs", especially early ones, were for, and got "these are
> >identifiers of the _standards_, not identifiers of the
> >documents".
> 
> Another way to say this is that we are required to have a naming 
> system for documents, and are required to have a naming system for 
> standards. Documents that are not standards will have a name only in 
> the first, while documents that are standards will have a name in 
> both.
> 
pub-req is intended to address identifiers for documents that pass through the IETF publication process.  I guess even given John's taxonomy of standards, there are some which will fall outside of the categories listed.

Whatever identifers are agreed upon, they will be publicly visible.  This means that the technical publisher (who I assume maintains the index) will need to provide lookup based upon those identifiers.

>  From the Techspec perspective, there is not a requirement 
> for how the 
> naming system for standards is organized, nor when the names in the 
> naming system for standards are allocated.

Agree. In pub-req we have tried not to make too many assumptions:
- It does not assume the documents are standards
- It does not preclude multiple identifiers being associated with a published document. 
- It does not make any assumptions on the format of the identifier(s)
- It does not assume that the IETF publication process has exclusive ownership of an identifier series other than the uniqueness requirement (read: independent submissions)
> 
> IESGers: do the external bodies who want permanent identifiers need 
> all of the identifiers that will be associated with the document (the 
> document naming system *and* the standards naming system), or just a 
> document identifier?
> 
Not an IESGer, but 99% of the references I have seen are to RFC numbers.  I don't think external bodies care particularly what the identifier is as long as it is permanent and stable.  I know this is true for 3GPP.  Many of the references may be to non-standards track documents.

Also note that when the term "stable" is used in relation to "permanent and stable identifiers" this is referring to being able to the stability of the document reference, not to the stability or maturity of the protocol or standard itself.

If the IESG wants to "encourage" external bodies to preferentially cite one class of identifiers over another, that is an issue outside of techpub.  As long as an identifier is externally visible, the publisher must be able to resolve it in the index.

> --Paul Hoffman, Director
> --VPN Consortium