Subject: RE: [Techspec] New requirement for early permanent ID allocation

From: "Stephen Hayes (TX/EUS)" <[email-masked]>
Date: Fri, 3 Mar 2006 09:12:07 -0600

> Brian Carpenter wrote
> 
> In the techspec context, I think the basic requirement
> remains that the publisher follows IETF instructions on
> how to assign identifiers, and assigns them as early
> in the processing of a document as the IETF requests.

pub-req does not currently preclude the publisher from having their own identifier.
Suppose the IETF comes up with several bright shiny new types of identifiers.  The publisher continues to also allocate their identifier (lets call it RFCxxxx for sake of argument).  External bodies may be slow to adopt the new identifiers.

So a possible requirement is that the publisher only uses identifiers as instructed by the IETF and not also allocate them to a publisher defined series.

> 
> And we should note for clarity that identifiers may come
> in multiple types, exactly as you say.
> 
> I think that for defining contractual requirements on
> the publisher, that is sufficient.
> 
> 

_______________________________________________
Techspec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/techspec

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 03 Mar 2006 16:46:54 +0100

Stephen Hayes (TX/EUS) wrote:
>> remains that the publisher follows IETF instructions on how
>> to assign identifiers, and assigns them as early in the
>> processing of a document as the IETF requests.
> 
> 
> pub-req does not currently preclude the publisher from having
> their own identifier. Suppose the IETF comes up with several
> bright shiny new types of identifiers.  The publisher
> continues to also allocate their identifier (lets call it
> RFCxxxx for sake of argument).  External bodies may be slow
> to adopt the new identifiers.

I'm not sure we're in agreement. Let's assume that we switch
contractors every two years. We can't have even the serial
numbers (RFCxxxx for sake of argument) changing or resetting
whenever we change contractor. So I think the IETF has to
govern all types of identifier, including the basic document
serial number.

> So a possible requirement is that the publisher only uses
> identifiers as instructed by the IETF and not also allocate
> them to a publisher defined series.

Yes. But I didn't get that from your previous paragraph.

    Brian
> 
> 
>> And we should note for clarity that identifiers may come in
>> multiple types, exactly as you say.
>> 
>> I think that for defining contractual requirements on the
>> publisher, that is sufficient.
>> 
>> 
> 
>