Subject: RE: [Techspec] Cutoff for post-approval corrections

From: "Stephen Hayes (TX/EUS)" <[email-masked]>
Date: Tue, 7 Mar 2006 20:07:40 -0600

> -----Original Message-----
> From: Paul Hoffman [mailto:[email-masked]]
> Sent: Tuesday, March 07, 2006 5:36 PM
> To: [email-masked]
> Subject: [Techspec] Cutoff for post-approval corrections
> 
> 
> At 4:37 PM -0600 3/7/06, Stephen Hayes (TX/EUS) wrote:
> >My response to Eric's comments inline.
> >  > S 3.7:
> >>
> >  >    o  Potential Req-POSTCORR-3 - The IETF technical 
> publisher should
> >>        have the discretion to reject post-approval 
> corrections as too
> >>        late in the process and propose that it be handled 
> as errata.
> >>
> >>  I'm not sure I agree with this. Fundamentally, that seems like the
> >>  kind of discretion that should rest with the IESG. The publisher
> >>  can of course say "this will require reflowing the document" or
> >>  "this will delay the document X weeks" but up until the moment
> >>  of publication I'm not sure why IESG shouldn't be able to direct
> >>  changes.
> >>
> >Ultimately, the publisher should be at the command of the IESG.
> 
> I think that might be "pentultimately"; ultimately, isn't the 
> publishers at the command of IASA?
> 
> >But this is analogous to the 11th hour appeal.  If the document is 
> >ready to be published, there will be a process in the publisher to 
> >put it in the index and announce its availability.  At what point 
> >can the IESG say "Stop"?  Maybe it's like the movies and stopping 
> >the process is ok as long as they can rush in, throw themselves 
> >across the room, and stop the publisher from hitting the "Enter" key.
> 
> Fully agree. But, in the movie scenario, if the publisher sees the 
> IESG collectively throw themselves across the room (well worth the 
> price of admission alone!), the publisher would take its finger off 
> the button. The wording of Req-POSTCORR-3 doesn't reflect that. A 
> more accurate wording might be:
> 
>     o  Potential Req-POSTCORR-3 - The IETF technical publisher should
>        have the discretion to publish the document as soon as all
>        the parties that must approve the final document have done so.
> 
> This allows the IESG can dramatically leap in at any point before 
> publication. Further, if the IESG wants the discretion to make 
> changes in the document, it might make itself one of the parties that 
> must approve the final document, most likely through one or more Area 
> Directors. That is already the case now for any WG document and 
> (possibly) any individual submission that has a sponsoring AD. The 
> IESG and IASA can figure out exactly what the rules should be here.

If this is the case, I'm not sure we need to keep this requirement at all.  I think the requirement captured in the reworded version is somewhat implied.  The original idea was whether or not to give the technical publisher the ability to say "sorry, too late".  If we don't want to give them that authority then we should just remove this potential requirement all together.
> 
> --Paul Hoffman, Director
> --VPN Consortium
> 
> _______________________________________________
> Techspec mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/techspec
> 

_______________________________________________
Techspec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/techspec

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 08 Mar 2006 16:07:20 +0100

> If this is the case, I'm not sure we need to keep this requirement at all.  I think the requirement captured in the reworded version is somewhat implied.  The original idea was whether or not to gi…

Basically we need to be sure we keep the equivalent of AUTH48
where the authors and AD have a final look; but if they ask
for excessive changes at that stage, which *does* happen,
the publisher needs to be able to say no. On the other hand we
need the publisher to stop if someone on the technical side
finds a major problem at the last moment. Whether that makes
two requirements or one, I leave to Stephen.

    Brian

---

From: "Spencer Dawkins" <[email-masked]>
Date: Wed, 8 Mar 2006 10:33:55 -0600

I'm not sure whether I lack understanding or lack clue on this...

> where the authors and AD have a final look; but if they ask

... with Brian so far, why would this be wrong ...

> the publisher needs to be able to say no.

... and get lost here. I'm fine with the AD saying "that change is excessive 
for AUTH48" to authors, but having the technical publisher tell the AD(s, or 
the IESG), "that change is excessive for AUTH48" seems like a stretch.

Maybe I have the wrong understanding of "excessive". Is "excessive" simply a 
quantitative issue ("we can't possibly do that terminology change so 
quickly"), or is technical judgement involved ("adding IDN support is too 
big for AUTH48, and needs to be discussed within the working group")?

> On the other hand we

Thanks,

Spencer