Subject: RE: [Techspec] Editorial notes on draft-mankin-pub-req-08.txt

From: "Stephen Hayes (TX/EUS)" <[email-masked]>
Date: Wed, 24 May 2006 23:32:24 -0500

Hi Paul,

See my comments inline.

Thanks, Stephen

> -----Original Message-----
> From: Paul Hoffman [mailto:[email-masked]]
> Sent: Wednesday, May 24, 2006 1:39 PM
> To: [email-masked]
> Subject: [Techspec] Editorial notes on draft-mankin-pub-req-08.txt
> 
> 
> The terminology used for who signs off on post-IESG changes is 
> inconsistent in the document. It is fine that this document doesn't 
> specify who does the sign-off (that's an IETF decision), but the 
> document should be consistent in who it says is doing it. The wording 
> is "appropriate technical representatives" in 3.3, but "appropriate 
> IETF party (often the document shepherd, but sometimes, by referral, 
> the IESG)" in 3.7.

Agree
> 
> -----
> 
> In section 3.4:
>     o  Req-REFVAL-1 - The IETF technical publisher should ensure that
>        references within specifications are available.
> That should probably be "...that all references..."; some of them are 
> sure to be available. :-)

Agree
> 
> -----
> 
> In section 4.1:
>     o  Req-TIMEFRAMES-2 - The consensus of the IETF community is that
>        the time required for a pre-publication review should 
> be under 10
>        days. The actual performance targets and metrics are 
> expected to
>        be determined as part of the contract negotiation process.
> The term "pre-publication review" is not defined anywhere in the 
> document, and it probably should, given this consensus statement.

It should probably refer to section 3.1.
> 
> -----
> 
> Section 5 talks about "potential issues" for the IETF. Two bullet 
> items do not match the earlier part of the document.
> 
>     o  Pre- vs Post-Approval Editing: If emphasis switches from post-
>        approval editing to pre-approval editing, then IETF 
> processes must
>        be adapted to make use of this service.  The processes 
> for post-
>        approval editing can also be streamlined.
> Section 3.1 makes a requirement that the emphasis must switch. So, 
> "If" should probably be "When".

I'm not sure that 3.1 requires that the emphasis must switch to pre-approval reviews.  We are putting a requirement that the publisher support pre-approval reviews, but we have not yet decided if the IETF will really make use of it.
> 
>     o  Allocation of Permanent Stable Identifiers: IETF needs 
> to clearly
>        identify the naming/numbering schemes and classes of 
> documents to
>        which those names and numbers apply.  Furthermore, the
>        responsibility for allocation of those names/numbers 
> needs to be
>        identified.
> Section 3.8 says that it is the IETF publisher's responsibility, so 
> the second sentence should probably be removed.

This wording should be cleaned up.  The idea was that the technical publisher would own and allocate the RFC number series.  Other identifiers might not be owned by the technical publisher.  So the technical publisher would be directed to assign a given number/name to a document.  The problem is that the handling of these non-RFC identifiers is not stable.
> 
> --Paul Hoffman, Director
> --VPN Consortium
> 
> _______________________________________________
> Techspec mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/techspec
> 

_______________________________________________
Techspec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/techspec

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 25 May 2006 07:57:59 -0700

>It should probably refer to section 3.1.

That sounds fine. You might also want to change "pre-publication 
review" to "Pre-approval review or editing" to match the heading of 
3.1. "Pre-publication review" sounds like what is done just before 
the RFC is emitted.

>I'm not sure that 3.1 requires that the emphasis must switch to 
>pre-approval reviews.  We are putting a requirement that the 
>publisher support pre-approval reviews, but we have not yet decided 
>if the IETF will really make use of it.

    o  Req-PREEDIT-1: The IETF technical publisher should perform an
       editorial review of documents before WG last call and provide
       feedback to the authors to improve quality of the documents.  This
       review should strive to maintain consistency in appearance with
       previously published documents.
The phrase "should perform" is quite different than "should support". 
It seems that the consensus was that this should be done, so "should 
perform" is correct.

--Paul Hoffman, Director
--VPN Consortium