Subject: RE: [Techspec] Validation of formal languages

From: "Stephen Hayes (TX/EUS)" <[email-masked]>
Date: Wed, 24 May 2006 23:38:22 -0500

See inline

> -----Original Message-----
> From: Paul Hoffman [mailto:[email-masked]]
> Sent: Wednesday, May 24, 2006 1:37 PM
> To: [email-masked]
> Subject: [Techspec] Validation of formal languages
> 
> 
> Section 3.5 that seems out of place in that it is the only part of 
> this document that says "the IETF technical publisher will review 
> this part of documents for technical correctness". It makes sense to 
> say "if automated tools are available to check formal languages, the 
> IETF technical publisher should run the tools late in the editing 
> process", but not to make it seem like that validation is the job of 
> the technical publisher.

I agree.  It was intended to refer to validation using tools.
> 
> This section might also add a requirement that the IETF technical 
> publisher should not change any examples (changing words, 
> reformatting with line breaks, and so on) without explicitly alerting 
> the document authors. Some formal languages are quite sensitive to 
> byte counts and line breaks.

In general, I think the publisher should work with the authors for any changes required to formal language sections.
> 
> --Paul Hoffman, Director
> --VPN Consortium
> 
> _______________________________________________
> Techspec mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/techspec
> 

_______________________________________________
Techspec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/techspec

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 25 May 2006 08:00:40 -0700

At 11:38 PM -0500 5/24/06, Stephen Hayes (TX/EUS) wrote:
>In general, I think the publisher should work with the authors for 
>any changes required to formal language sections.

Right. That is obvious enough to be a requirement, it seems.

--Paul Hoffman, Director
--VPN Consortium