Subject: [Techspec] RFC Author Count and IPR

From: Russ Housley <[email-masked]>
Date: Wed, 24 May 2006 12:37:25 -0400

I am concerned that the current RFC Editor practice that limits the 
number of authors is in conflict with the IETF IPR policies.  The RFC 
Editor currently limits the author count to five people.  Recent IPR 
WG discussions make it clear to me that authors retain significant copyright.

In one of the working groups in the Security Area, there is a 
document with six authors on it.  I asked the WG chairs to reduce the 
author count in the hope of avoiding a problem down the road.  At 
that time, I was not aware of the copyright.  Now, I think I gave the 
WG Chairs inappropriate directions.

The IESG and the whole Internet Community needs clear direction on 
this issue.  I suspect that the IPR WG will be a part of the process 
to resolve it.  Also, the Tech Spec document, which is currently in 
Last Call, many need to include a requirement that the RFC Editor 
explicitly acknowledge copyright holders in some fashion.

Russ

_______________________________________________
Techspec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/techspec

---

From: "Gray, Eric" <[email-masked]>
Date: Wed, 24 May 2006 14:48:08 -0400

Sam, et al,

	There are so many things tied up in this, that I am
afraid it is bound to turn into a rat-hole.

	For one thing, I thought Russ was talking about the
complication that arise from whether or not the BCP 78/79
stuff applies to people who made some contribution but are
not listed as "Authors".  I may have missed his point, but
this probably is an issue as there are other things in IPR
than "copyrights".

	For another, there is a clear distinction between
attribution and being listed as an author.  Most drafts I've
seen acknowledge the people making contributions.

	Also, RFCs are not (at least usually) a compilation of
related works by separate authors. An RFC typically requires
some unification and typically this is performed by one or 
more editors.  Because of churn-and-merge complexity, it is
usually the case that there is only one "editor" at any given
moment, and the list of "token holders" is both well defined
and small - consequently is is quite reasonable to ask that
a long list of authors be replaced by a shorter list of the
people who actually took turns as editors.

	I think the biggest issue is that the RFC Editor has
established guidelines that use a fixed number.  This can
lead to rather arbitrary decisions about who is an editor,
author or contributor.  Probably a better approach would be
to explicitly define what the RFC Editor means by the terms
contributor, author, editor and - perhaps - something even
more specific that that (e.g. - final editor?) and then
saying that some number of names MAY be listed on the first 
page and that the approach to determining what names should
be included is to pick the category that has no more than
that many in the list.

	I was pretty much under the impression that this is 
the informal approach used now. 

--
Eric

--> -----Original Message-----
--> From: Sam Hartman [mailto:[email-masked]] 
--> Sent: Wednesday, May 24, 2006 2:06 PM
--> To: Russ Housley
--> Cc: [email-masked]; [email-masked]; 
--> [email-masked]; [email-masked]
--> Subject: Re: RFC Author Count and IPR
--> 
--> >>>>> "Russ" == Russ Housley <[email-masked]> writes:
--> 
-->     Russ> I am concerned that the current RFC Editor practice that
-->     Russ> limits the number of authors is in conflict with the IETF
-->     Russ> IPR policies.  The RFC Editor currently limits the author
-->     Russ> count to five people.  Recent IPR WG discussions make it
-->     Russ> clear to me that authors retain significant copyright.
--> 
--> [There is this concept in US copyright law called a joint work.  I'm
--> ignoring that concept for the moment basically because I don't
--> understand how it applies to either software or text developed using
--> an open process.  As far as I can tell, no one else understands it
--> either.  Please be aware that this may be a huge gap in my advice.]
--> 
--> So, here we have a conflicting definitions problem.
--> 
--> The author of a work retains the copyright interest.  That's true if
--> if I'm listed as an author or not.
--> 
--> If I write text and do not assign the copyright to someone, I retain
--> copyright interest in that text.
--> 
--> So the sixth person still owns the copyright interest in 
--> the text they
--> write even if they are not listed.
--> 
--> That means if you have unlisted authors who have contributed
--> significant chunks of text, you still need to get their clearance to
--> do anything interesting with that text.
--> 
--> _______________________________________________
--> Ietf mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/ietf
-->

---

From: "Gray, Eric" <[email-masked]>
Date: Wed, 24 May 2006 14:48:08 -0400

Sam, et al,

--
Eric

---

From: Bob Braden <[email-masked]>
Date: Wed, 24 May 2006 13:22:44 -0700 (PDT)

Lucy Lynch wrote:

  *> a little history:
  *> 
  *> 28 authors!
  *> http://www.arkko.com/tools/rfcstats/authdistr.html
  *> 
  *> 20 authors!
  *> http://www.arkko.com/tools/stats/authdistr.html
  *> 
  *> Bob -
  *> 
  *> I think the 5 author rule applies to the listing in the ID/RFC header 
  *> and not to the authors listed under "Author Information" - is that 
  *> correct?
  *> 
  *> - lel
  *> 

Lucy,

Please see the URL I posted earlier; the policy was carefully crafted.

I would avoid calling it a "rule".  We think of it as a guideline, a
threshold below which no discussion is necessary.

Bob Braden

  *> > Bob Braden for the RFC Editor
  *> >
  *> >
  *> >
  *> > _______________________________________________
  *> > Ietf mailing list
  *> > [email-masked]
  *> > https://www1.ietf.org/mailman/listinfo/ietf
  *> >
  *> 
  *> -- 
  *> Lucy E. Lynch 				Academic User Services
  *> Computing Center			University of Oregon
  *> llynch  @darkwing.uoregon.edu		(541) 346-1774
  *>

---

From: "John Loughney" <[email-masked]>
Date: Wed, 24 May 2006 22:42:19 +0300

Andy,

For what it's worth, I agree with you. Having a single editor simplifies many things, but having a authors list allows full credit to all parties.

John 

- original message -
Subject:	Re: RFC Author Count and IPR
From:	Andy Bierman <[email-masked]>
Date:		05/24/2006 7:19 pm

David Harrington wrote:
> If I remember correctly, we only limit the number of suthors on the
> first page of the document. 
> 
> It is perfectly acceptable to list a longer set of names inside the
> document in an contributors section.

It's not just the first page.
It also affects the reference citation used in
the RFC Index and all other RFCs.

I believe the 5 author rule was used as justification to remove
most of the original SNMPv2 authors from the author list and all
further reference citations, when the RFC 1901-1909 series was
advanced.  I don't really understand what purpose this serves.

> 
> I also have concerns about who should be listed as an "author" and
> have copyrights when a work is developed by a WG. The demand to do
> things with IETF documents beyond IETF standards work seems to be
> growing, so it will be an increasingly difficult problem if we do not
> identify all the people who contributed significant portions of a
> document (where significant is of course open to debate).

There is a problem with companies piling on the authors
for I-D proposals to make it look like lots of people
worked really hard on it and all agree on the contents.
(This is hardly ever the case.)

Then when you go to WG draft, there are already 5 or 7 names
as authors, and the WG wants to add more.  I think then, you
have to pick a real Editor (responsible for all edits all
the way through AUTH48) and just list that person as Editor
on the first page and citations, and put everybody in
the Authors section in the back.

IMO, this is different than removing the author(s) of a previous
version of an RFC.  I object to that practice.

> dbh

Andy

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf