From owner-tn3270e@LIST.NIH.GOV  Mon May  5 05:14:49 2003
Received: from gdecker.net.nih.gov (gdecker.net.nih.gov [165.112.130.6])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id FAA27546
	for <tn3270e-archive@LISTS.IETF.ORG>; Mon, 5 May 2003 05:14:33 -0400 (EDT)
Received: from list.nih.gov (gdecker.net.nih.gov [165.112.130.6])
	by gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h4598XbI016845;
	Mon, 5 May 2003 05:08:34 -0400 (EDT)
Received: from LIST.NIH.GOV by LIST.NIH.GOV (LISTSERV-TCP/IP release 1.8d) with
          spool id 11545 for TN3270E@LIST.NIH.GOV; Mon, 5 May 2003 05:08:33
          -0400
Received: from mx5.net.nih.gov (mx5.net.nih.gov [165.112.130.36]) by
          gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h458wXbI016243 for
          <TN3270E@LIST.NIH.GOV>; Mon, 5 May 2003 04:58:33 -0400 (EDT)
Received: from mx5.net.nih.gov (localhost [127.0.0.1]) by mx5.net.nih.gov
          (8.12.8p1/8.12.5) with ESMTP id h458xNYx009962 for
          <TN3270E@LIST.NIH.GOV>; Mon, 5 May 2003 04:59:23 -0400
Received: from tilmax.tatainfotech.co.in (180.tatainfotech.com
          [203.124.134.180] (may be forged)) by mx5.net.nih.gov
          (8.12.8p1/8.11.6) with ESMTP id h458xKKB009949 for
          <TN3270E@LIST.NIH.GOV>; Mon, 5 May 2003 04:59:21 -0400
Received: from goamail.in.tatainfotech.com
          (IDENT:root@tilmax.tatainfotech.co.in [127.0.0.1]) by
          tilmax.tatainfotech.co.in (8.11.0/8.11.0) with ESMTP id h458wQ809879
          for <TN3270E@LIST.NIH.GOV>; Mon, 5 May 2003 14:28:26 +0530
Received: from glory ([163.122.44.210]) by goamail.in.tatainfotech.com
          (8.8.7/8.8.7) with SMTP id OAA32736 for <TN3270E@LIST.NIH.GOV>; Mon,
          5 May 2003 14:18:44 +0530
Reply-To: <sameer.neugui@tatainfotech.com>
From: "sameer" <sameer.neugui@tatainfotech.com>
To: <TN3270E@LIST.NIH.GOV>
Date: Mon, 5 May 2003 14:31:06 +0530
Message-ID: <002301c312e4$dd0d36a0$d22c7aa3@glory>
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: 7bit
X-Priority: 3 (Normal)
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook CWS, Build 9.0.2416 (9.0.2911.0)
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4522.1200
Importance: Normal
Sender: owner-tn3270e@LIST.NIH.GOV
Content-Transfer-Encoding: 7bit

Hi all,

I am new to this type of technology and have just joined the list.

I want to develop a terminal emulation software for Telnet server on 5250
and 3270. I checked for the specs on the internet just to find the RFCs.
These RFCs seems to be based on the "IBM 5250 Information Display System,
Functions Reference Manual", SA21-9247-6". This is one document I could not
find on the IBM site. Can anyone tell me how to obtain this document. Which
are the RFCs I should refer to to get sufficient knowldege about the two
protocols.

Regards
Sameer


From owner-tn3270e@list.nih.gov  Wed May  7 02:41:50 2003
Received: from gdecker.net.nih.gov (gdecker.net.nih.gov [165.112.130.6])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id CAA18236
	for <tn3270e-archive@LISTS.IETF.ORG>; Wed, 7 May 2003 02:41:50 -0400 (EDT)
Received: from list.nih.gov (gdecker.net.nih.gov [165.112.130.6])
	by gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h476V4bM016740;
	Wed, 7 May 2003 02:36:08 -0400 (EDT)
Received: from LIST.NIH.GOV by LIST.NIH.GOV (LISTSERV-TCP/IP release 1.8d) with
          spool id 23645 for TN3270E@LIST.NIH.GOV; Wed, 7 May 2003 02:36:08
          -0400
Received: from mx5.net.nih.gov (mx5.net.nih.gov [165.112.130.36]) by
          gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h476a7bI016928 for
          <TN3270E@list.nih.gov>; Wed, 7 May 2003 02:36:07 -0400 (EDT)
Received: from mx5.net.nih.gov (localhost [127.0.0.1]) by mx5.net.nih.gov
          (8.12.8p1/8.12.5) with ESMTP id h476bIYx002194 for
          <TN3270E@list.nih.gov>; Wed, 7 May 2003 02:37:18 -0400
Received: from cfs-nt1.cfsoft.com (h-69-3-227-68.CHCGILGM.covad.net
          [69.3.227.68]) by mx5.net.nih.gov (8.12.8p1/8.11.6) with ESMTP id
          h476bIKB002189 for <TN3270E@list.nih.gov>; Wed, 7 May 2003 02:37:18
          -0400
Received: from wessel (unverified) by cfs-nt1.cfsoft.com (Content Technologies
          SMTPRS 2.0.15) with SMTP id <B0000172021@cfs-nt1.cfsoft.com>; Wed, 07
          May 2003 01:35:55 -0500
Message-Id: <3.0.5.32.20030507013628.0096de40@cfs-dns-2.cfsoft.com>
X-Sender: rwessel@cfs-dns-2.cfsoft.com
X-Mailer: QUALCOMM Windows Eudora Pro Version 3.0.5 (32)
Date: Wed, 07 May 2003 01:36:28 -0500
To: <sameer.neugui@tatainfotech.com>, <TN3270E@list.nih.gov>
From: "Robert C. Wessel" <rwessel@cfsoft.com>
Subject: Re:
In-Reply-To: <002301c312e4$dd0d36a0$d22c7aa3@glory>
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Sender: owner-tn3270e@list.nih.gov

Sameer,

You can order many back level and "out-of-print" IBM publications from:

http://www.elink.ibmlink.ibm.com/public/applications/publications/cgibin/pbi
.cgi

(Select search and enter SA21-9247 as the publication number).

For the "out-of-print" stuff, this is a POD system, so anything "old" you
order (at least in my experience) arrives in black and white and on 8.5x11
paper, which is rather funny if you've ordered a pocket reference card.
But heck, so long as you can read it...

-Robert

At 02:31 PM 5/5/03 +0530, sameer wrote:
>Hi all,
>
>I am new to this type of technology and have just joined the list.
>
>I want to develop a terminal emulation software for Telnet server on 5250
>and 3270. I checked for the specs on the internet just to find the RFCs.
>These RFCs seems to be based on the "IBM 5250 Information Display System,
>Functions Reference Manual", SA21-9247-6". This is one document I could not
>find on the IBM site. Can anyone tell me how to obtain this document. Which
>are the RFCs I should refer to to get sufficient knowldege about the two
>protocols.
>
>Regards
>Sameer
>


From owner-tn3270e@LIST.NIH.GOV  Wed May  7 02:46:55 2003
Received: from gdecker.net.nih.gov (gdecker.net.nih.gov [165.112.130.6])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id CAA18334
	for <tn3270e-archive@LISTS.IETF.ORG>; Wed, 7 May 2003 02:46:55 -0400 (EDT)
Received: from list.nih.gov (gdecker.net.nih.gov [165.112.130.6])
	by gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h476V4bS016740;
	Wed, 7 May 2003 02:42:57 -0400 (EDT)
Received: from LIST.NIH.GOV by LIST.NIH.GOV (LISTSERV-TCP/IP release 1.8d) with
          spool id 23703 for TN3270E@LIST.NIH.GOV; Wed, 7 May 2003 02:42:57
          -0400
Received: from seaquest.net.nih.gov (seaquest.net.nih.gov [165.112.130.34]) by
          gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h476gvbI017188 for
          <TN3270E@LIST.NIH.GOV>; Wed, 7 May 2003 02:42:57 -0400 (EDT)
Received: from seaquest.net.nih.gov (localhost [127.0.0.1]) by
          seaquest.net.nih.gov (8.12.8p1/8.12.5) with ESMTP id h476gjIM016948
          for <TN3270E@LIST.NIH.GOV>; Wed, 7 May 2003 02:42:45 -0400
Received: from tilmax.tatainfotech.co.in (180.tatainfotech.com
          [203.124.134.180] (may be forged)) by seaquest.net.nih.gov
          (8.12.8p1/8.12.5) with ESMTP id h476ggim016943 for
          <TN3270E@LIST.NIH.GOV>; Wed, 7 May 2003 02:42:43 -0400
Received: from goamail.in.tatainfotech.com
          (IDENT:root@tilmax.tatainfotech.co.in [127.0.0.1]) by
          tilmax.tatainfotech.co.in (8.11.0/8.11.0) with ESMTP id h476gkl29285;
          Wed, 7 May 2003 12:12:46 +0530
Received: from glory ([163.122.44.210]) by goamail.in.tatainfotech.com
          (8.8.7/8.8.7) with SMTP id MAA25724; Wed, 7 May 2003 12:03:24 +0530
Reply-To: <sameer.neugui@tatainfotech.com>
From: "sameer" <sameer.neugui@tatainfotech.com>
To: "'Robert C. Wessel'" <rwessel@cfsoft.com>, <TN3270E@LIST.NIH.GOV>
Subject: RE:
Date: Wed, 7 May 2003 12:15:26 +0530
Message-ID: <000a01c31464$3e231ec0$d22c7aa3@glory>
MIME-Version: 1.0
Content-Type: text/plain; charset="US-ASCII"
Content-Transfer-Encoding: 7bit
X-Priority: 3 (Normal)
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook CWS, Build 9.0.2416 (9.0.2911.0)
In-Reply-To: <3.0.5.32.20030507013628.0096de40@cfs-dns-2.cfsoft.com>
Importance: Normal
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4522.1200
Sender: owner-tn3270e@LIST.NIH.GOV
Content-Transfer-Encoding: 7bit

Hi Robert,

Are there any latest documents which should give me all functions to be
implemented without referring to the old out of print documents, in order to
develop a terminal emulation?

Sameer

-----Original Message-----
From: Robert C. Wessel [mailto:rwessel@cfsoft.com]
Sent: Wednesday, May 07, 2003 12:06 PM
To: sameer.neugui@tatainfotech.com; TN3270E@LIST.NIH.GOV
Subject: Re:


Sameer,

You can order many back level and "out-of-print" IBM publications from:

http://www.elink.ibmlink.ibm.com/public/applications/publications/cgibin/pbi
.cgi

(Select search and enter SA21-9247 as the publication number).

For the "out-of-print" stuff, this is a POD system, so anything "old" you
order (at least in my experience) arrives in black and white and on 8.5x11
paper, which is rather funny if you've ordered a pocket reference card.
But heck, so long as you can read it...

-Robert

At 02:31 PM 5/5/03 +0530, sameer wrote:
>Hi all,
>
>I am new to this type of technology and have just joined the list.
>
>I want to develop a terminal emulation software for Telnet server on 5250
>and 3270. I checked for the specs on the internet just to find the RFCs.
>These RFCs seems to be based on the "IBM 5250 Information Display System,
>Functions Reference Manual", SA21-9247-6". This is one document I could not
>find on the IBM site. Can anyone tell me how to obtain this document. Which
>are the RFCs I should refer to to get sufficient knowldege about the two
>protocols.
>
>Regards
>Sameer
>


From owner-tn3270e@LIST.NIH.GOV  Wed May  7 03:09:07 2003
Received: from gdecker.net.nih.gov (gdecker.net.nih.gov [165.112.130.6])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id DAA18773
	for <tn3270e-archive@LISTS.IETF.ORG>; Wed, 7 May 2003 03:09:06 -0400 (EDT)
Received: from list.nih.gov (list.nih.gov [165.112.130.6])
	by gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h4775gbI017869;
	Wed, 7 May 2003 03:05:42 -0400 (EDT)
Received: from LIST.NIH.GOV by LIST.NIH.GOV (LISTSERV-TCP/IP release 1.8d) with
          spool id 21970 for TN3270E@LIST.NIH.GOV; Wed, 7 May 2003 03:05:42
          -0400
Received: from mx5.net.nih.gov (mx5.net.nih.gov [165.112.130.36]) by
          gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h4771BbI017707 for
          <TN3270E@list.nih.gov>; Wed, 7 May 2003 03:01:11 -0400 (EDT)
Received: from mx5.net.nih.gov (localhost [127.0.0.1]) by mx5.net.nih.gov
          (8.12.8p1/8.12.5) with ESMTP id h4772NYx002720 for
          <TN3270E@list.nih.gov>; Wed, 7 May 2003 03:02:23 -0400
Received: from cfs-nt1.cfsoft.com (h-69-3-227-68.CHCGILGM.covad.net
          [69.3.227.68]) by mx5.net.nih.gov (8.12.8p1/8.11.6) with ESMTP id
          h4772MKB002715 for <TN3270E@list.nih.gov>; Wed, 7 May 2003 03:02:23
          -0400
Received: from wessel (unverified) by cfs-nt1.cfsoft.com (Content Technologies
          SMTPRS 2.0.15) with SMTP id <B0000172045@cfs-nt1.cfsoft.com>; Wed, 07
          May 2003 02:01:07 -0500
Message-Id: <3.0.5.32.20030507020141.009fca90@cfs-dns-2.cfsoft.com>
X-Sender: rwessel@cfs-dns-2.cfsoft.com
X-Mailer: QUALCOMM Windows Eudora Pro Version 3.0.5 (32)
Date: Wed, 07 May 2003 02:01:41 -0500
To: <sameer.neugui@tatainfotech.com>, <TN3270E@LIST.NIH.GOV>
From: "Robert C. Wessel" <rwessel@cfsoft.com>
Subject: RE: 5250 Documentation
In-Reply-To: <000a01c31464$3e231ec0$d22c7aa3@glory>
References: <3.0.5.32.20030507013628.0096de40@cfs-dns-2.cfsoft.com>
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Sender: owner-tn3270e@LIST.NIH.GOV

Sameer,

There are new features in some newer terminals, but you'll want to start
with the 5250 Functions Reference (SA21-9247).  Unless you have special
requirements, you'll probably not need any of the newer stuff anyway.

A word of advice: You'll obviously want to have some other 5250
implementations  available so that you can do the usual reverse
engineering.  5250 is rather complex, and the implementations have vary
considerable in quality, so don't put too much faith in any one 5250
emulator (TN5250 or otherwise) as regards the performance of the more
obscure features (for example, the implementations of autofill, autoskip,
mandatory enter and the like are just all over the place, and those aren't
all that obscure).  We picked up a few different models of "real" 5250
terminals (used and cheap, of course) for baseline testing, which was helpful.

-Robert

At 12:15 PM 5/7/03 +0530, sameer wrote:
>Hi Robert,
>
>Are there any latest documents which should give me all functions to be
>implemented without referring to the old out of print documents, in order to
>develop a terminal emulation?
>
>Sameer
>
>-----Original Message-----
>From: Robert C. Wessel [mailto:rwessel@cfsoft.com]
>Sent: Wednesday, May 07, 2003 12:06 PM
>To: sameer.neugui@tatainfotech.com; TN3270E@LIST.NIH.GOV
>Subject: Re:
>
>
>Sameer,
>
>You can order many back level and "out-of-print" IBM publications from:
>
>http://www.elink.ibmlink.ibm.com/public/applications/publications/cgibin/pbi
>.cgi
>
>(Select search and enter SA21-9247 as the publication number).
>
>For the "out-of-print" stuff, this is a POD system, so anything "old" you
>order (at least in my experience) arrives in black and white and on 8.5x11
>paper, which is rather funny if you've ordered a pocket reference card.
>But heck, so long as you can read it...
>
>-Robert
>
>At 02:31 PM 5/5/03 +0530, sameer wrote:
>>Hi all,
>>
>>I am new to this type of technology and have just joined the list.
>>
>>I want to develop a terminal emulation software for Telnet server on 5250
>>and 3270. I checked for the specs on the internet just to find the RFCs.
>>These RFCs seems to be based on the "IBM 5250 Information Display System,
>>Functions Reference Manual", SA21-9247-6". This is one document I could not
>>find on the IBM site. Can anyone tell me how to obtain this document. Which
>>are the RFCs I should refer to to get sufficient knowldege about the two
>>protocols.
>>
>>Regards
>>Sameer
>>
>


From owner-tn3270e@LIST.NIH.GOV  Wed May  7 03:40:19 2003
Received: from gdecker.net.nih.gov (gdecker.net.nih.gov [165.112.130.6])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id DAA19585
	for <tn3270e-archive@LISTS.IETF.ORG>; Wed, 7 May 2003 03:40:19 -0400 (EDT)
Received: from list.nih.gov (list.nih.gov [165.112.130.6])
	by gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h477UMbK019149;
	Wed, 7 May 2003 03:34:33 -0400 (EDT)
Received: from LIST.NIH.GOV by LIST.NIH.GOV (LISTSERV-TCP/IP release 1.8d) with
          spool id 22492 for TN3270E@LIST.NIH.GOV; Wed, 7 May 2003 03:34:32
          -0400
Received: from viper.net.nih.gov (viper.net.nih.gov [165.112.130.32]) by
          gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h477YWbI019292 for
          <TN3270E@LIST.NIH.GOV>; Wed, 7 May 2003 03:34:32 -0400 (EDT)
Received: from viper.net.nih.gov (localhost [127.0.0.1]) by viper.net.nih.gov
          (8.12.8p1/8.12.5) with ESMTP id h477YK7R016492 for
          <TN3270E@LIST.NIH.GOV>; Wed, 7 May 2003 03:34:20 -0400
Received: from tilmax.tatainfotech.co.in (180.tatainfotech.com
          [203.124.134.180] (may be forged)) by viper.net.nih.gov
          (8.12.8p1/8.12.5) with ESMTP id h477YHLx016480 for
          <TN3270E@LIST.NIH.GOV>; Wed, 7 May 2003 03:34:18 -0400
Received: from goamail.in.tatainfotech.com
          (IDENT:root@tilmax.tatainfotech.co.in [127.0.0.1]) by
          tilmax.tatainfotech.co.in (8.11.0/8.11.0) with ESMTP id h477YQM01060;
          Wed, 7 May 2003 13:04:27 +0530
Received: from glory ([163.122.44.210]) by goamail.in.tatainfotech.com
          (8.8.7/8.8.7) with SMTP id MAA26886; Wed, 7 May 2003 12:55:03 +0530
Reply-To: <sameer.neugui@tatainfotech.com>
From: "sameer" <sameer.neugui@tatainfotech.com>
To: "'Robert C. Wessel'" <rwessel@cfsoft.com>, <TN3270E@LIST.NIH.GOV>
Subject: RE: 5250 Documentation
Date: Wed, 7 May 2003 13:07:03 +0530
Message-ID: <000c01c3146b$753f3a40$d22c7aa3@glory>
MIME-Version: 1.0
Content-Type: text/plain; charset="US-ASCII"
Content-Transfer-Encoding: 7bit
X-Priority: 3 (Normal)
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook CWS, Build 9.0.2416 (9.0.2911.0)
In-Reply-To: <3.0.5.32.20030507020141.009fca90@cfs-dns-2.cfsoft.com>
Importance: Normal
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4522.1200
Sender: owner-tn3270e@LIST.NIH.GOV
Content-Transfer-Encoding: 7bit

Robert,

I have IBM Manager print preview of 3270 programmers reference
(GA23-0059-07). Is this enough to start with terminal emulation development.
If not, what are the other documents I should refer to?

-Sameer

-----Original Message-----
From: owner-tn3270e@LIST.NIH.GOV [mailto:owner-tn3270e@LIST.NIH.GOV]On
Behalf Of Robert C. Wessel
Sent: Wednesday, May 07, 2003 12:32 PM
To: sameer.neugui@TATAINFOTECH.COM; TN3270E@LIST.NIH.GOV
Subject: RE: 5250 Documentation


Sameer,

There are new features in some newer terminals, but you'll want to start
with the 5250 Functions Reference (SA21-9247).  Unless you have special
requirements, you'll probably not need any of the newer stuff anyway.

A word of advice: You'll obviously want to have some other 5250
implementations  available so that you can do the usual reverse
engineering.  5250 is rather complex, and the implementations have vary
considerable in quality, so don't put too much faith in any one 5250
emulator (TN5250 or otherwise) as regards the performance of the more
obscure features (for example, the implementations of autofill, autoskip,
mandatory enter and the like are just all over the place, and those aren't
all that obscure).  We picked up a few different models of "real" 5250
terminals (used and cheap, of course) for baseline testing, which was
helpful.

-Robert

At 12:15 PM 5/7/03 +0530, sameer wrote:
>Hi Robert,
>
>Are there any latest documents which should give me all functions to be
>implemented without referring to the old out of print documents, in order
to
>develop a terminal emulation?
>
>Sameer
>
>-----Original Message-----
>From: Robert C. Wessel [mailto:rwessel@cfsoft.com]
>Sent: Wednesday, May 07, 2003 12:06 PM
>To: sameer.neugui@tatainfotech.com; TN3270E@LIST.NIH.GOV
>Subject: Re:
>
>
>Sameer,
>
>You can order many back level and "out-of-print" IBM publications from:
>
>http://www.elink.ibmlink.ibm.com/public/applications/publications/cgibin/pb
i
>.cgi
>
>(Select search and enter SA21-9247 as the publication number).
>
>For the "out-of-print" stuff, this is a POD system, so anything "old" you
>order (at least in my experience) arrives in black and white and on 8.5x11
>paper, which is rather funny if you've ordered a pocket reference card.
>But heck, so long as you can read it...
>
>-Robert
>
>At 02:31 PM 5/5/03 +0530, sameer wrote:
>>Hi all,
>>
>>I am new to this type of technology and have just joined the list.
>>
>>I want to develop a terminal emulation software for Telnet server on 5250
>>and 3270. I checked for the specs on the internet just to find the RFCs.
>>These RFCs seems to be based on the "IBM 5250 Information Display System,
>>Functions Reference Manual", SA21-9247-6". This is one document I could
not
>>find on the IBM site. Can anyone tell me how to obtain this document.
Which
>>are the RFCs I should refer to to get sufficient knowldege about the two
>>protocols.
>>
>>Regards
>>Sameer
>>
>


From owner-tn3270e@LIST.NIH.GOV  Wed May  7 03:51:56 2003
Received: from gdecker.net.nih.gov (gdecker.net.nih.gov [165.112.130.6])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id DAA19749
	for <tn3270e-archive@LISTS.IETF.ORG>; Wed, 7 May 2003 03:51:56 -0400 (EDT)
Received: from list.nih.gov (list.nih.gov [165.112.130.6])
	by gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h477UMbO019149;
	Wed, 7 May 2003 03:44:08 -0400 (EDT)
Received: from LIST.NIH.GOV by LIST.NIH.GOV (LISTSERV-TCP/IP release 1.8d) with
          spool id 22548 for TN3270E@LIST.NIH.GOV; Wed, 7 May 2003 03:44:08
          -0400
Received: from mx5.net.nih.gov (mx5.net.nih.gov [165.112.130.36]) by
          gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h477i8bI019588 for
          <TN3270E@LIST.NIH.GOV>; Wed, 7 May 2003 03:44:08 -0400 (EDT)
Received: from mx5.net.nih.gov (localhost [127.0.0.1]) by mx5.net.nih.gov
          (8.12.8p1/8.12.5) with ESMTP id h477jJYx003546 for
          <TN3270E@LIST.NIH.GOV>; Wed, 7 May 2003 03:45:20 -0400
Received: from mail46.fg.online.no (mail46-s.fg.online.no [148.122.161.46]) by
          mx5.net.nih.gov (8.12.8p1/8.11.6) with ESMTP id h477jJKB003533 for
          <TN3270E@LIST.NIH.GOV>; Wed, 7 May 2003 03:45:19 -0400
Received: from smtp.online.no ([193.212.217.203]) by mail46.fg.online.no
          (8.9.3p2/8.9.3) with ESMTP id JAA26649; Wed, 7 May 2003 09:43:53
          +0200 (MEST)
Message-ID: <200305070946440005.002DB1EA@smtp.online.no>
In-Reply-To: <000c01c3146b$753f3a40$d22c7aa3@glory>
References: <000c01c3146b$753f3a40$d22c7aa3@glory>
X-Mailer: Calypso Version 3.30.00.00 (4)
Date: Wed, 07 May 2003 09:46:44 +0200
Reply-To: nihen@online.no
From: "Hans Erik Nesheim" <nihen@online.no>
To: sameer.neugui@TATAINFOTECH.COM, rwessel@cfsoft.com, TN3270E@LIST.NIH.GOV
Subject: RE: 5250 Documentation
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 8bit
X-MIME-Autoconverted: from quoted-printable to 8bit by gdecker.net.nih.gov id
                      h477i8bI019589
Sender: owner-tn3270e@LIST.NIH.GOV
Content-Transfer-Encoding: 8bit

Sameer,

I have written a telnet 3270 and 5250 test service, which can be very usefully for your development.
It's a NT service, which can handle both tn3270 and tn5250 clients. The reply from the service is
different 3270 or 5250 screen images with most of the attributes needed. The service has three
different ports for connections. One is a normal reply mode port, one is a slow mode reply port
and the other is a stress test (performance) connection port. More information and download in the
services section at www.nexit.com It can also be downloaded from the test center at www.tn3270.com

Regards,
Hans Erik


*********** REPLY SEPARATOR  ***********

On 5/7/2003 at 13:07 sameer wrote:

>Robert,
>
>I have IBM Manager print preview of 3270 programmers reference
>(GA23-0059-07). Is this enough to start with terminal emulation
>development.
>If not, what are the other documents I should refer to?
>
>-Sameer
>
>-----Original Message-----
>From: owner-tn3270e@LIST.NIH.GOV [mailto:owner-tn3270e@LIST.NIH.GOV]On
>Behalf Of Robert C. Wessel
>Sent: Wednesday, May 07, 2003 12:32 PM
>To: sameer.neugui@TATAINFOTECH.COM; TN3270E@LIST.NIH.GOV
>Subject: RE: 5250 Documentation
>
>
>Sameer,
>
>There are new features in some newer terminals, but you'll want to start
>with the 5250 Functions Reference (SA21-9247).  Unless you have special
>requirements, you'll probably not need any of the newer stuff anyway.
>
>A word of advice: You'll obviously want to have some other 5250
>implementations  available so that you can do the usual reverse
>engineering.  5250 is rather complex, and the implementations have vary
>considerable in quality, so don't put too much faith in any one 5250
>emulator (TN5250 or otherwise) as regards the performance of the more
>obscure features (for example, the implementations of autofill, autoskip,
>mandatory enter and the like are just all over the place, and those aren't
>all that obscure).  We picked up a few different models of "real" 5250
>terminals (used and cheap, of course) for baseline testing, which was
>helpful.
>
>-Robert
>
>At 12:15 PM 5/7/03 +0530, sameer wrote:
>>Hi Robert,
>>
>>Are there any latest documents which should give me all functions to be
>>implemented without referring to the old out of print documents, in order
>to
>>develop a terminal emulation?
>>
>>Sameer
>>
>>-----Original Message-----
>>From: Robert C. Wessel [mailto:rwessel@cfsoft.com]
>>Sent: Wednesday, May 07, 2003 12:06 PM
>>To: sameer.neugui@tatainfotech.com; TN3270E@LIST.NIH.GOV
>>Subject: Re:
>>
>>
>>Sameer,
>>
>>You can order many back level and "out-of-print" IBM publications from:
>>
>>http://www.elink.ibmlink.ibm.com/public/applications/publications/cgibin/pb
>i
>>.cgi
>>
>>(Select search and enter SA21-9247 as the publication number).
>>
>>For the "out-of-print" stuff, this is a POD system, so anything "old" you
>>order (at least in my experience) arrives in black and white and on 8.5x11
>>paper, which is rather funny if you've ordered a pocket reference card.
>>But heck, so long as you can read it...
>>
>>-Robert
>>
>>At 02:31 PM 5/5/03 +0530, sameer wrote:
>>>Hi all,
>>>
>>>I am new to this type of technology and have just joined the list.
>>>
>>>I want to develop a terminal emulation software for Telnet server on 5250
>>>and 3270. I checked for the specs on the internet just to find the RFCs.
>>>These RFCs seems to be based on the "IBM 5250 Information Display System,
>>>Functions Reference Manual", SA21-9247-6". This is one document I could
>not
>>>find on the IBM site. Can anyone tell me how to obtain this document.
>Which
>>>are the RFCs I should refer to to get sufficient knowldege about the two
>>>protocols.
>>>
>>>Regards
>>>Sameer
>>>
>>


From owner-tn3270e@list.nih.gov  Wed May  7 04:01:22 2003
Received: from gdecker.net.nih.gov (gdecker.net.nih.gov [165.112.130.6])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id EAA19977
	for <tn3270e-archive@LISTS.IETF.ORG>; Wed, 7 May 2003 04:01:21 -0400 (EDT)
Received: from list.nih.gov (list.nih.gov [165.112.130.6])
	by gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h477wEbI019942;
	Wed, 7 May 2003 03:58:14 -0400 (EDT)
Received: from LIST.NIH.GOV by LIST.NIH.GOV (LISTSERV-TCP/IP release 1.8d) with
          spool id 22617 for TN3270E@LIST.NIH.GOV; Wed, 7 May 2003 03:58:13
          -0400
Received: from seaquest.net.nih.gov (seaquest.net.nih.gov [165.112.130.34]) by
          gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h477wDbI019938 for
          <TN3270E@list.nih.gov>; Wed, 7 May 2003 03:58:13 -0400 (EDT)
Received: from seaquest.net.nih.gov (localhost [127.0.0.1]) by
          seaquest.net.nih.gov (8.12.8p1/8.12.5) with ESMTP id h477w1IM018575
          for <TN3270E@list.nih.gov>; Wed, 7 May 2003 03:58:01 -0400
Received: from cfs-nt1.cfsoft.com (h-69-3-227-68.CHCGILGM.covad.net
          [69.3.227.68]) by seaquest.net.nih.gov (8.12.8p1/8.12.5) with ESMTP
          id h477w1im018570 for <TN3270E@list.nih.gov>; Wed, 7 May 2003
          03:58:01 -0400
Received: from wessel (unverified) by cfs-nt1.cfsoft.com (Content Technologies
          SMTPRS 2.0.15) with SMTP id <B0000172067@cfs-nt1.cfsoft.com>; Wed, 07
          May 2003 02:58:03 -0500
Message-Id: <3.0.5.32.20030507025838.00939a30@cfs-dns-2.cfsoft.com>
X-Sender: rwessel@cfs-dns-2.cfsoft.com
X-Mailer: QUALCOMM Windows Eudora Pro Version 3.0.5 (32)
Date: Wed, 07 May 2003 02:58:38 -0500
To: <sameer.neugui@tatainfotech.com>, <TN3270E@list.nih.gov>
From: "Robert C. Wessel" <rwessel@cfsoft.com>
Subject: Re: 3270 Documentation
In-Reply-To: <000d01c3146c$6c6b4a20$d22c7aa3@glory>
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Sender: owner-tn3270e@list.nih.gov

Sameer,

That's the one you want.  I'm pretty sure -07 is the latest revision.

You'll also want to check out the following RFCs: RFC1576*, RFC1646,
RFC1647, RFC2355*, RFC2561, RFC2562, RFC2877*, and RFC3049.  The ones with
an asterisk are the most likely to be of use.  There's some other
TELNET/TN3270/TLS related documents you may want to dig up if that's an
issue for you.

-Robert

At 01:13 PM 5/7/03 +0530, you wrote:
>Robert,
>
>I have IBM Manager print preview of 3270 programmers reference
>(GA23-0059-07). Is this enough to start with terminal emulation development.
>If not, what are the other documents I should refer to?
>
>-Sameer
>


From owner-tn3270e@LIST.NIH.GOV  Wed May  7 05:04:39 2003
Received: from gdecker.net.nih.gov (list.nih.gov [165.112.130.6])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id FAA21473
	for <tn3270e-archive@LISTS.IETF.ORG>; Wed, 7 May 2003 05:04:39 -0400 (EDT)
Received: from list.nih.gov (list.nih.gov [165.112.130.6])
	by gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h478utbQ021599;
	Wed, 7 May 2003 05:00:40 -0400 (EDT)
Received: from LIST.NIH.GOV by LIST.NIH.GOV (LISTSERV-TCP/IP release 1.8d) with
          spool id 22866 for TN3270E@LIST.NIH.GOV; Wed, 7 May 2003 05:00:40
          -0400
Received: from mx5.net.nih.gov (mx5.net.nih.gov [165.112.130.36]) by
          gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h4790ebI021748 for
          <TN3270E@LIST.NIH.GOV>; Wed, 7 May 2003 05:00:40 -0400 (EDT)
Received: from mx5.net.nih.gov (localhost [127.0.0.1]) by mx5.net.nih.gov
          (8.12.8p1/8.12.5) with ESMTP id h4791qYx005064 for
          <TN3270E@LIST.NIH.GOV>; Wed, 7 May 2003 05:01:52 -0400
Received: from tilmax.tatainfotech.co.in (180.tatainfotech.com
          [203.124.134.180] (may be forged)) by mx5.net.nih.gov
          (8.12.8p1/8.11.6) with ESMTP id h4791oKB005058 for
          <TN3270E@LIST.NIH.GOV>; Wed, 7 May 2003 05:01:51 -0400
Received: from goamail.in.tatainfotech.com
          (IDENT:root@tilmax.tatainfotech.co.in [127.0.0.1]) by
          tilmax.tatainfotech.co.in (8.11.0/8.11.0) with ESMTP id h4790T407234;
          Wed, 7 May 2003 14:30:30 +0530
Received: from glory ([163.122.44.210]) by goamail.in.tatainfotech.com
          (8.8.7/8.8.7) with SMTP id OAA28543; Wed, 7 May 2003 14:21:02 +0530
Reply-To: <sameer.neugui@tatainfotech.com>
From: "sameer" <sameer.neugui@tatainfotech.com>
To: <nihen@ONLINE.NO>, <rwessel@cfsoft.com>, <TN3270E@LIST.NIH.GOV>
Subject: RE: 5250 Documentation
Date: Wed, 7 May 2003 14:33:02 +0530
Message-ID: <000f01c31477$779df450$d22c7aa3@glory>
MIME-Version: 1.0
Content-Type: text/plain; charset="US-ASCII"
Content-Transfer-Encoding: 7bit
X-Priority: 3 (Normal)
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook CWS, Build 9.0.2416 (9.0.2911.0)
In-Reply-To: <200305070946440005.002DB1EA@smtp.online.no>
Importance: Normal
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4522.1200
Sender: owner-tn3270e@LIST.NIH.GOV
Content-Transfer-Encoding: 7bit

thanks, that's very kind of you Hans.
-Sameer

-----Original Message-----
From: owner-tn3270e@LIST.NIH.GOV [mailto:owner-tn3270e@LIST.NIH.GOV]On
Behalf Of Hans Erik Nesheim
Sent: Wednesday, May 07, 2003 1:17 PM
To: sameer.neugui@TATAINFOTECH.COM; rwessel@cfsoft.com;
TN3270E@LIST.NIH.GOV
Subject: RE: 5250 Documentation


Sameer,

I have written a telnet 3270 and 5250 test service, which can be very
usefully for your development.
It's a NT service, which can handle both tn3270 and tn5250 clients. The
reply from the service is
different 3270 or 5250 screen images with most of the attributes needed. The
service has three
different ports for connections. One is a normal reply mode port, one is a
slow mode reply port
and the other is a stress test (performance) connection port. More
information and download in the
services section at www.nexit.com It can also be downloaded from the test
center at www.tn3270.com

Regards,
Hans Erik


*********** REPLY SEPARATOR  ***********

On 5/7/2003 at 13:07 sameer wrote:

>Robert,
>
>I have IBM Manager print preview of 3270 programmers reference
>(GA23-0059-07). Is this enough to start with terminal emulation
>development.
>If not, what are the other documents I should refer to?
>
>-Sameer
>
>-----Original Message-----
>From: owner-tn3270e@LIST.NIH.GOV [mailto:owner-tn3270e@LIST.NIH.GOV]On
>Behalf Of Robert C. Wessel
>Sent: Wednesday, May 07, 2003 12:32 PM
>To: sameer.neugui@TATAINFOTECH.COM; TN3270E@LIST.NIH.GOV
>Subject: RE: 5250 Documentation
>
>
>Sameer,
>
>There are new features in some newer terminals, but you'll want to start
>with the 5250 Functions Reference (SA21-9247).  Unless you have special
>requirements, you'll probably not need any of the newer stuff anyway.
>
>A word of advice: You'll obviously want to have some other 5250
>implementations  available so that you can do the usual reverse
>engineering.  5250 is rather complex, and the implementations have vary
>considerable in quality, so don't put too much faith in any one 5250
>emulator (TN5250 or otherwise) as regards the performance of the more
>obscure features (for example, the implementations of autofill, autoskip,
>mandatory enter and the like are just all over the place, and those aren't
>all that obscure).  We picked up a few different models of "real" 5250
>terminals (used and cheap, of course) for baseline testing, which was
>helpful.
>
>-Robert
>
>At 12:15 PM 5/7/03 +0530, sameer wrote:
>>Hi Robert,
>>
>>Are there any latest documents which should give me all functions to be
>>implemented without referring to the old out of print documents, in order
>to
>>develop a terminal emulation?
>>
>>Sameer
>>
>>-----Original Message-----
>>From: Robert C. Wessel [mailto:rwessel@cfsoft.com]
>>Sent: Wednesday, May 07, 2003 12:06 PM
>>To: sameer.neugui@tatainfotech.com; TN3270E@LIST.NIH.GOV
>>Subject: Re:
>>
>>
>>Sameer,
>>
>>You can order many back level and "out-of-print" IBM publications from:
>>
>>http://www.elink.ibmlink.ibm.com/public/applications/publications/cgibin/p
b
>i
>>.cgi
>>
>>(Select search and enter SA21-9247 as the publication number).
>>
>>For the "out-of-print" stuff, this is a POD system, so anything "old" you
>>order (at least in my experience) arrives in black and white and on 8.5x11
>>paper, which is rather funny if you've ordered a pocket reference card.
>>But heck, so long as you can read it...
>>
>>-Robert
>>
>>At 02:31 PM 5/5/03 +0530, sameer wrote:
>>>Hi all,
>>>
>>>I am new to this type of technology and have just joined the list.
>>>
>>>I want to develop a terminal emulation software for Telnet server on 5250
>>>and 3270. I checked for the specs on the internet just to find the RFCs.
>>>These RFCs seems to be based on the "IBM 5250 Information Display System,
>>>Functions Reference Manual", SA21-9247-6". This is one document I could
>not
>>>find on the IBM site. Can anyone tell me how to obtain this document.
>Which
>>>are the RFCs I should refer to to get sufficient knowldege about the two
>>>protocols.
>>>
>>>Regards
>>>Sameer
>>>
>>


From owner-tn3270e@LIST.NIH.GOV  Wed May  7 05:04:47 2003
Received: from gdecker.net.nih.gov (list.nih.gov [165.112.130.6])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id FAA21487
	for <tn3270e-archive@LISTS.IETF.ORG>; Wed, 7 May 2003 05:04:47 -0400 (EDT)
Received: from list.nih.gov (list.nih.gov [165.112.130.6])
	by gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h478utbK021599;
	Wed, 7 May 2003 04:57:36 -0400 (EDT)
Received: from LIST.NIH.GOV by LIST.NIH.GOV (LISTSERV-TCP/IP release 1.8d) with
          spool id 22840 for TN3270E@LIST.NIH.GOV; Wed, 7 May 2003 04:57:36
          -0400
Received: from mx5.net.nih.gov (mx5.net.nih.gov [165.112.130.36]) by
          gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h478vabI021613 for
          <TN3270E@LIST.NIH.GOV>; Wed, 7 May 2003 04:57:36 -0400 (EDT)
Received: from mx5.net.nih.gov (localhost [127.0.0.1]) by mx5.net.nih.gov
          (8.12.8p1/8.12.5) with ESMTP id h478wnYx004945 for
          <TN3270E@LIST.NIH.GOV>; Wed, 7 May 2003 04:58:49 -0400
Received: from tilmax.tatainfotech.co.in (180.tatainfotech.com
          [203.124.134.180] (may be forged)) by mx5.net.nih.gov
          (8.12.8p1/8.11.6) with ESMTP id h478wkKB004932 for
          <TN3270E@LIST.NIH.GOV>; Wed, 7 May 2003 04:58:47 -0400
Received: from goamail.in.tatainfotech.com
          (IDENT:root@tilmax.tatainfotech.co.in [127.0.0.1]) by
          tilmax.tatainfotech.co.in (8.11.0/8.11.0) with ESMTP id h478vRj06973;
          Wed, 7 May 2003 14:27:28 +0530
Received: from glory ([163.122.44.210]) by goamail.in.tatainfotech.com
          (8.8.7/8.8.7) with SMTP id OAA28471; Wed, 7 May 2003 14:18:00 +0530
Reply-To: <sameer.neugui@tatainfotech.com>
From: "sameer" <sameer.neugui@tatainfotech.com>
To: "'Robert C. Wessel'" <rwessel@cfsoft.com>, <TN3270E@LIST.NIH.GOV>
Subject: RE: 3270 Documentation
Date: Wed, 7 May 2003 14:30:00 +0530
Message-ID: <000e01c31477$0b34f6b0$d22c7aa3@glory>
MIME-Version: 1.0
Content-Type: text/plain; charset="US-ASCII"
Content-Transfer-Encoding: 7bit
X-Priority: 3 (Normal)
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook CWS, Build 9.0.2416 (9.0.2911.0)
In-Reply-To: <3.0.5.32.20030507025838.00939a30@cfs-dns-2.cfsoft.com>
Importance: Normal
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4522.1200
Sender: owner-tn3270e@LIST.NIH.GOV
Content-Transfer-Encoding: 7bit

Robert,

Could u give me a similar list for 5250, if I m not asking for too much? I
have the following 5250 related RFCs with me RFC 1010, RFC 1091, RFC 1205,
RFC 1572, RFC 2877. Can anyone share the Functions Reference SA21-9247 for
5250?

Thanks
-Sameer

-----Original Message-----
From: Robert C. Wessel [mailto:rwessel@cfsoft.com]
Sent: Wednesday, May 07, 2003 1:29 PM
To: sameer.neugui@tatainfotech.com; TN3270E@LIST.NIH.GOV
Subject: Re: 3270 Documentation


Sameer,

That's the one you want.  I'm pretty sure -07 is the latest revision.

You'll also want to check out the following RFCs: RFC1576*, RFC1646,
RFC1647, RFC2355*, RFC2561, RFC2562, RFC2877*, and RFC3049.  The ones with
an asterisk are the most likely to be of use.  There's some other
TELNET/TN3270/TLS related documents you may want to dig up if that's an
issue for you.

-Robert

At 01:13 PM 5/7/03 +0530, you wrote:
>Robert,
>
>I have IBM Manager print preview of 3270 programmers reference
>(GA23-0059-07). Is this enough to start with terminal emulation
development.
>If not, what are the other documents I should refer to?
>
>-Sameer
>


From owner-tn3270e@list.nih.gov  Thu May  8 03:36:01 2003
Received: from gdecker.net.nih.gov (list.nih.gov [165.112.130.6])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id DAA14846
	for <tn3270e-archive@LISTS.IETF.ORG>; Thu, 8 May 2003 03:36:01 -0400 (EDT)
Received: from list.nih.gov (list.nih.gov [165.112.130.6])
	by gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h487SvbK011033;
	Thu, 8 May 2003 03:32:09 -0400 (EDT)
Received: from LIST.NIH.GOV by LIST.NIH.GOV (LISTSERV-TCP/IP release 1.8d) with
          spool id 42777 for TN3270E@LIST.NIH.GOV; Thu, 8 May 2003 03:32:08
          -0400
Received: from seaquest.net.nih.gov (seaquest.net.nih.gov [165.112.130.34]) by
          gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h487W7bI011105 for
          <TN3270E@list.nih.gov>; Thu, 8 May 2003 03:32:07 -0400 (EDT)
Received: from seaquest.net.nih.gov (localhost [127.0.0.1]) by
          seaquest.net.nih.gov (8.12.8p1/8.12.5) with ESMTP id h487VrIM012914
          for <TN3270E@list.nih.gov>; Thu, 8 May 2003 03:31:53 -0400
Received: from cfs-nt1.cfsoft.com (h-69-3-227-68.CHCGILGM.covad.net
          [69.3.227.68]) by seaquest.net.nih.gov (8.12.8p1/8.12.5) with ESMTP
          id h487Vqim012901 for <TN3270E@list.nih.gov>; Thu, 8 May 2003
          03:31:52 -0400
Received: from wessel (unverified) by cfs-nt1.cfsoft.com (Content Technologies
          SMTPRS 2.0.15) with SMTP id <B0000172422@cfs-nt1.cfsoft.com>; Thu, 08
          May 2003 02:31:55 -0500
Message-Id: <3.0.5.32.20030508023134.009a0210@cfs-dns-2.cfsoft.com>
X-Sender: rwessel@cfs-dns-2.cfsoft.com
X-Mailer: QUALCOMM Windows Eudora Pro Version 3.0.5 (32)
Date: Thu, 08 May 2003 02:31:34 -0500
To: <sameer.neugui@tatainfotech.com>, <TN3270E@list.nih.gov>
From: "Robert C. Wessel" <rwessel@cfsoft.com>
Subject: RE: 3270 Documentation
In-Reply-To: <000e01c31477$0b34f6b0$d22c7aa3@glory>
References: <3.0.5.32.20030507025838.00939a30@cfs-dns-2.cfsoft.com>
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Sender: owner-tn3270e@list.nih.gov

Sameer,

RFC1205 is the base for TN5250.  The other stuff you need is general Telnet
and the various options.  Be aware that RFC1010 is way out of date, and is
replaced by STD2.

-Robert

At 02:30 PM 5/7/03 +0530, sameer wrote:
>Robert,
>
>Could u give me a similar list for 5250, if I m not asking for too much? I
>have the following 5250 related RFCs with me RFC 1010, RFC 1091, RFC 1205,
>RFC 1572, RFC 2877. Can anyone share the Functions Reference SA21-9247 for
>5250?
>
>Thanks
>-Sameer
>
>-----Original Message-----
>From: Robert C. Wessel [mailto:rwessel@cfsoft.com]
>Sent: Wednesday, May 07, 2003 1:29 PM
>To: sameer.neugui@tatainfotech.com; TN3270E@LIST.NIH.GOV
>Subject: Re: 3270 Documentation
>
>
>Sameer,
>
>That's the one you want.  I'm pretty sure -07 is the latest revision.
>
>You'll also want to check out the following RFCs: RFC1576*, RFC1646,
>RFC1647, RFC2355*, RFC2561, RFC2562, RFC2877*, and RFC3049.  The ones with
>an asterisk are the most likely to be of use.  There's some other
>TELNET/TN3270/TLS related documents you may want to dig up if that's an
>issue for you.
>
>-Robert
>
>At 01:13 PM 5/7/03 +0530, you wrote:
>>Robert,
>>
>>I have IBM Manager print preview of 3270 programmers reference
>>(GA23-0059-07). Is this enough to start with terminal emulation
>development.
>>If not, what are the other documents I should refer to?
>>
>>-Sameer
>>
>
>


From owner-tn3270e@LIST.NIH.GOV  Wed May 28 00:05:54 2003
Received: from gdecker.net.nih.gov (list.nih.gov [165.112.130.6])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id AAA18509
	for <tn3270e-archive@LISTS.IETF.ORG>; Wed, 28 May 2003 00:05:53 -0400 (EDT)
Received: from list.nih.gov (list.nih.gov [165.112.130.6])
	by gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h4S3iKbS023045;
	Tue, 27 May 2003 23:52:22 -0400 (EDT)
Received: from LIST.NIH.GOV by LIST.NIH.GOV (LISTSERV-TCP/IP release 1.8d) with
          spool id 48853 for TN3270E@LIST.NIH.GOV; Tue, 27 May 2003 23:52:22
          -0400
Received: from viper.net.nih.gov (viper.net.nih.gov [165.112.130.32]) by
          gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h4S3qMbI023842 for
          <TN3270E@LIST.NIH.GOV>; Tue, 27 May 2003 23:52:22 -0400 (EDT)
Received: from viper.net.nih.gov (localhost [127.0.0.1]) by viper.net.nih.gov
          (8.12.8p1/8.12.5) with ESMTP id h4S3pp7Q014353 for
          <TN3270E@LIST.NIH.GOV>; Tue, 27 May 2003 23:51:52 -0400
Received: from tilmax.tatainfotech.co.in (180.tatainfotech.com
          [203.124.134.180] (may be forged)) by viper.net.nih.gov
          (8.12.8p1/8.12.5) with ESMTP id h4S3pnha014347 for
          <TN3270E@LIST.NIH.GOV>; Tue, 27 May 2003 23:51:50 -0400
Received: from goamail.in.tatainfotech.com
          (IDENT:root@tilmax.tatainfotech.co.in [127.0.0.1]) by
          tilmax.tatainfotech.co.in (8.11.0/8.11.0) with ESMTP id h4S3qCZ14265
          for <TN3270E@LIST.NIH.GOV>; Wed, 28 May 2003 09:22:12 +0530
Received: from glory ([163.122.44.210]) by goamail.in.tatainfotech.com
          (8.8.7/8.8.7) with SMTP id JAA26276; Wed, 28 May 2003 09:11:12 +0530
Reply-To: <sameer.neugui@tatainfotech.com>
From: "sameer" <sameer.neugui@tatainfotech.com>
To: <TN3270E@LIST.NIH.GOV>
Subject: graphics for 3270/5250
Date: Wed, 28 May 2003 09:24:48 +0530
Message-ID: <000501c324cc$e2d3b740$d22c7aa3@glory>
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: 7bit
X-Priority: 3 (Normal)
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook CWS, Build 9.0.2416 (9.0.2911.0)
Importance: Normal
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4522.1200
Sender: owner-tn3270e@LIST.NIH.GOV
Content-Transfer-Encoding: 7bit

Hi,
    I am interested in the type of graphic capabilities that are supported
in 3270/5250 terminal emulation. Basically I want to know how to handle the
Graphic information from the IBM server. Can the graphics be handled using
Visual Basic? Can somebody please provide me with useful pointers?


From owner-tn3270e@LIST.NIH.GOV  Fri May 30 02:39:39 2003
Received: from gdecker.net.nih.gov (list.nih.gov [165.112.130.6])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id CAA21314
	for <tn3270e-archive@LISTS.IETF.ORG>; Fri, 30 May 2003 02:39:38 -0400 (EDT)
Received: from list.nih.gov (list.nih.gov [165.112.130.6])
	by gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h4U6PgbM022730;
	Fri, 30 May 2003 02:32:14 -0400 (EDT)
Received: from LIST.NIH.GOV by LIST.NIH.GOV (LISTSERV-TCP/IP release 1.8d) with
          spool id 33946 for TN3270E@LIST.NIH.GOV; Fri, 30 May 2003 02:32:14
          -0400
Received: from mx5.net.nih.gov (mx5.net.nih.gov [165.112.130.36]) by
          gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h4U6WEbI023178 for
          <TN3270E@LIST.NIH.GOV>; Fri, 30 May 2003 02:32:14 -0400 (EDT)
Received: from mx5.net.nih.gov (localhost [127.0.0.1]) by mx5.net.nih.gov
          (8.12.8p1/8.12.5) with ESMTP id h4U6ZHP0026663 for
          <TN3270E@LIST.NIH.GOV>; Fri, 30 May 2003 02:35:18 -0400
Received: from tilmax.tatainfotech.co.in (180.tatainfotech.com
          [203.124.134.180] (may be forged)) by mx5.net.nih.gov
          (8.12.8p1/8.11.6) with ESMTP id h4U6ZFjK021949 for
          <TN3270E@LIST.NIH.GOV>; Fri, 30 May 2003 02:35:16 -0400
Received: from goamail.in.tatainfotech.com
          (IDENT:root@tilmax.tatainfotech.co.in [127.0.0.1]) by
          tilmax.tatainfotech.co.in (8.11.0/8.11.0) with ESMTP id h4U6W4E03594
          for <TN3270E@LIST.NIH.GOV>; Fri, 30 May 2003 12:02:04 +0530
Received: from glory ([163.122.44.210]) by goamail.in.tatainfotech.com
          (8.8.7/8.8.7) with SMTP id LAA22029 for <TN3270E@LIST.NIH.GOV>; Fri,
          30 May 2003 11:51:24 +0530
Reply-To: <sameer.neugui@tatainfotech.com>
From: "sameer" <sameer.neugui@tatainfotech.com>
To: <TN3270E@LIST.NIH.GOV>
Subject: GUI mode
Date: Fri, 30 May 2003 12:04:39 +0530
Message-ID: <002401c32675$8c92b5c0$d22c7aa3@glory>
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: 7bit
X-Priority: 3 (Normal)
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook CWS, Build 9.0.2416 (9.0.2911.0)
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4522.1200
Importance: Normal
In-Reply-To: <000501c324cc$e2d3b740$d22c7aa3@glory>
Sender: owner-tn3270e@LIST.NIH.GOV
Content-Transfer-Encoding: 7bit

Dear all,

Is this forum so dumb? I did not receive any answers to my previous post. Or
was my question very much outdated? Anyway, can anyone tell me whats a GUI
mode and whats non GUI mode in 5250/3270 emulation?

can anybody please list out the documents needed to developed both
emulations?

regards
Sameer


From owner-tn3270e@LIST.NIH.GOV  Fri May 30 02:51:35 2003
Received: from gdecker.net.nih.gov (list.nih.gov [165.112.130.6])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id CAA21524
	for <tn3270e-archive@LISTS.IETF.ORG>; Fri, 30 May 2003 02:51:34 -0400 (EDT)
Received: from list.nih.gov (list.nih.gov [165.112.130.6])
	by gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h4U6gqbK023954;
	Fri, 30 May 2003 02:45:05 -0400 (EDT)
Received: from LIST.NIH.GOV by LIST.NIH.GOV (LISTSERV-TCP/IP release 1.8d) with
          spool id 34023 for TN3270E@LIST.NIH.GOV; Fri, 30 May 2003 02:45:05
          -0400
Received: from viper.net.nih.gov (viper.net.nih.gov [165.112.130.32]) by
          gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h4U6j4bI024145 for
          <TN3270E@LIST.NIH.GOV>; Fri, 30 May 2003 02:45:04 -0400 (EDT)
Received: from viper.net.nih.gov (localhost [127.0.0.1]) by viper.net.nih.gov
          (8.12.8p1/8.12.5) with ESMTP id h4U6iV7Q025510 for
          <TN3270E@LIST.NIH.GOV>; Fri, 30 May 2003 02:44:31 -0400
Received: from rtp-core-1.cisco.com (rtp-core-1.cisco.com [64.102.124.12]) by
          viper.net.nih.gov (8.12.8p1/8.12.5) with ESMTP id h4U6iUha025505 for
          <TN3270E@LIST.NIH.GOV>; Fri, 30 May 2003 02:44:30 -0400
Received: from cisco.com (shako.cisco.com [64.102.17.78]) by
          rtp-core-1.cisco.com (8.12.9/8.12.6) with ESMTP id h4U6ipFV011949;
          Fri, 30 May 2003 02:44:52 -0400 (EDT)
Received: from localhost (localhost [127.0.0.1]) by cisco.com (8.8.8/2.6/Cisco
          List Logging/8.8.8) with ESMTP id CAA28031; Fri, 30 May 2003 02:44:50
          -0400 (EDT)
Subject: Re: GUI mode
From: Michael Boe <mboe@CISCO.COM>
To: sameer.neugui@TATAINFOTECH.COM
Cc: TN3270E@LIST.NIH.GOV
In-Reply-To: <002401c32675$8c92b5c0$d22c7aa3@glory>
References: <002401c32675$8c92b5c0$d22c7aa3@glory>
Content-Type: text/plain
Message-Id: <1054277804.19726.103.camel@localhost.localdomain>
Mime-Version: 1.0
X-Mailer: Ximian Evolution 1.2.4
Date: 29 May 2003 23:56:44 -0700
Content-Transfer-Encoding: 7bit
Sender: owner-tn3270e@LIST.NIH.GOV
Content-Transfer-Encoding: 7bit

Well...this forum is really for the standardization of protocols
relating to TN3270(E) clients and servers, and also addresses protocol
issues with TN5250 clients and servers.  It is not about how to
implement clients, and not really about any of the topics you've sought
help on so far.

regards,
/msb


On Thu, 2003-05-29 at 23:34, sameer wrote:
> Dear all,
>
> Is this forum so dumb? I did not receive any answers to my previous post. Or
> was my question very much outdated? Anyway, can anyone tell me whats a GUI
> mode and whats non GUI mode in 5250/3270 emulation?
>
> can anybody please list out the documents needed to developed both
> emulations?
>
> regards
> Sameer
--
Michael Boe <mboe@cisco.com>


From owner-tn3270e@list.nih.gov  Fri May 30 03:28:08 2003
Received: from gdecker.net.nih.gov (list.nih.gov [165.112.130.6])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id DAA22807
	for <tn3270e-archive@LISTS.IETF.ORG>; Fri, 30 May 2003 03:28:08 -0400 (EDT)
Received: from list.nih.gov (list.nih.gov [165.112.130.6])
	by gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h4U7BobU025947;
	Fri, 30 May 2003 03:18:40 -0400 (EDT)
Received: from LIST.NIH.GOV by LIST.NIH.GOV (LISTSERV-TCP/IP release 1.8d) with
          spool id 0081 for TN3270E@LIST.NIH.GOV; Fri, 30 May 2003 03:18:40
          -0400
Received: from mx5.net.nih.gov (mx5.net.nih.gov [165.112.130.36]) by
          gdecker.net.nih.gov (8.12.9/8.12.9) with ESMTP id h4U7IebI026391 for
          <TN3270E@list.nih.gov>; Fri, 30 May 2003 03:18:40 -0400 (EDT)
Received: from mx5.net.nih.gov (localhost [127.0.0.1]) by mx5.net.nih.gov
          (8.12.8p1/8.12.5) with ESMTP id h4U7LjP0030381 for
          <TN3270E@list.nih.gov>; Fri, 30 May 2003 03:21:45 -0400
Received: from cfs-nt1.cfsoft.com (h-69-3-227-68.CHCGILGM.covad.net
          [69.3.227.68]) by mx5.net.nih.gov (8.12.8p1/8.11.6) with ESMTP id
          h4U7LijK030376 for <TN3270E@list.nih.gov>; Fri, 30 May 2003 03:21:44
          -0400
Received: from wessel (unverified) by cfs-nt1.cfsoft.com (Content Technologies
          SMTPRS 2.0.15) with SMTP id <B0000179221@cfs-nt1.cfsoft.com>; Fri, 30
          May 2003 02:18:31 -0500
Message-Id: <3.0.5.32.20030530021832.009d26d0@cfs-dns-2.cfsoft.com>
X-Sender: rwessel@cfs-dns-2.cfsoft.com
X-Mailer: QUALCOMM Windows Eudora Pro Version 3.0.5 (32)
Date: Fri, 30 May 2003 02:18:32 -0500
To: <sameer.neugui@tatainfotech.com>, <TN3270E@list.nih.gov>
From: "Robert C. Wessel" <rwessel@cfsoft.com>
Subject: Re: GUI mode
In-Reply-To: <002401c32675$8c92b5c0$d22c7aa3@glory>
References: <000501c324cc$e2d3b740$d22c7aa3@glory>
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Sender: owner-tn3270e@list.nih.gov

Sameer,

The IBM "3270 Information Display System, Datastream Programmer's
Reference", GA23-0059-07, available from IBM, both electronically and in
hardcopy, covers all of the relevant 3270 stuff.  Go to:

http://publibz.boulder.ibm.com/cgi-bin/bookmgr_OS390/library

and search on the document number.

Graphics on 3270 are handled by defining character sets with symbols
matching a character cell sized piece of your image (see the "Load
Programmed Symbols" outbound structured field).  Once defined, you select
the character set and symbols to display with the "Character Set" extended
attribute, or with the "Graphics Escape" (GE) order.

In addition, you need to properly respond to the "Character Set" "Read
Partition Query", and a few other things (amongst other things, review the
"Graphic Color" and "Graphic Symbol Sets" RPQRs).

There are also the "Object *" Inbound/Outbound SFs, which are supported on
some devices, but I don't know many details, so you'll have to do some
research.

-Robert

At 12:04 PM 5/30/03 +0530, sameer wrote:
>Dear all,
>
>Is this forum so dumb? I did not receive any answers to my previous post. Or
>was my question very much outdated? Anyway, can anyone tell me whats a GUI
>mode and whats non GUI mode in 5250/3270 emulation?
>
>can anybody please list out the documents needed to developed both
>emulations?
>
>regards
>Sameer
>


