Subject: Re: Fwd: Re: [Tools-discuss] Mangled Internet-Drafts

From: Albert Vezza <[email-masked]>
Date: Thu, 2 Dec 2004 16:22:41 -0500

Hi Jordi,

I am not on any of the mailing lists that you sent your email to, so 
Barbara forwarded me your email.  Anyway I talked to the technical 
folks and I have concluded that it is just too risky to accept zip 
and tar files, because  one virus that might get through the virus 
filters could disrupt operations.  If that disruption came at a busy 
time such as just before a meeting there would be a great many people 
unhappy.

Sorry but we need to be careful about such things.

Al

>Hi Al:
>
>Here is a response to your message that I don't believe was sent to you.
>
>B.
>------------------------------------------------------
>>Envelope-to: [email-masked]
>>User-Agent: Microsoft-Entourage/10.1.4.030702.0
>>Date: Tue, 23 Nov 2004 00:12:12 +0100
>>Subject: Re: [Tools-discuss] Mangled Internet-Drafts
>>From: JORDI PALET MARTINEZ <[email-masked]>
>>To: IESG <[email-masked]>, WG Chairs <[email-masked]>,
>>         Tools Team Discussion <[email-masked]>
>>X-MDRemoteIP: 217.126.187.160
>>X-Return-Path: [email-masked]
>>X-Spam-Checker-Version: SpamAssassin 2.64 (2004-01-11) on mail.consulintel.es
>>X-Spam-Status: No, hits=-4.9 required=5.0 tests=BAYES_00 autolearn=no
>>         version=2.64
>>X-Spam-Processed: consulintel.es, Tue, 23 Nov 2004 00:19:44 +0100
>>X-MDAV-Processed: consulintel.es, Tue, 23 Nov 2004 00:19:44 +0100
>>X-Spam-Score: 2.9 (++)
>>X-Scan-Signature: 00e94c813bef7832af255170dca19e36
>>Cc: [email-masked], [email-masked], [email-masked],
>>         Scott Blomquist <[email-masked]>, [email-masked]
>>X-BeenThere: [email-masked]
>>X-Mailman-Version: 2.1.5
>>Reply-To: [email-masked]
>>List-Id: IETF Tools Discussion <tools-discuss.ietf.org>
>>List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/tools-discuss>,
>>         <mailto:[email-masked]?subject=unsubscribe>
>>List-Archive: <http://www1.ietf.org/pipermail/tools-discuss>
>>List-Post: <mailto:[email-masked]>
>>List-Help: <mailto:[email-masked]?subject=help>
>>List-Subscribe: <https://www1.ietf.org/mailman/listinfo/tools-discuss>,
>>         <mailto:[email-masked]?subject=subscribe>
>>Sender: [email-masked]
>>X-Spam-Score: 2.9 (++)
>>X-Scan-Signature: d185fa790257f526fedfd5d01ed9c976
>>
>>Hi Albert, all,
>>
>>As someone already indicated, it will be helpful anyway to allow sending zip
>>and tar files.
>>
>>Some corporate email servers compress all the attachments, and actually is
>>not so easy for some to tell their IT services not to compress attachments
>>sent to IETF ;-)
>>
>>On the other way around, this doesn't harm to the process, right ?
>>
>>Regards,
>>Jordi
>>
>>
>>>  De: Albert Vezza <[email-masked]>
>>>  Responder a: [email-masked]
>>>  Fecha: Mon, 22 Nov 2004 17:36:39 -0500
>>>  Para: IESG <[email-masked]>, WG Chairs <[email-masked]>, Tools Team
>>>  Discussion <[email-masked]>
>>>  CC: [email-masked], [email-masked], [email-masked], 
>>>Scott Blomquist
>>>  <[email-masked]>, [email-masked]
>>>  Asunto: Re: [Tools-discuss] Mangled Internet-Drafts
>>>
>>>  After more testing we determined that a filter could be placed to
>>>  intercept email sent to [email-masked] and
>>>  [email-masked] and ensure email containing attachments sent to
>>>  those addresses had a "Content-disposition: attachment" as part of
>>>  the file header.
>>>
>>>  A preliminary filter changing "Content-disposition: inline" to
>>>  "Content-disposition: attachment" was placed in service on 11/18/04.
>>>  We will soon have a more comprehensive  filter in place that will
>>>  also handle email from older composers that do not specify a
>>>  "Content-disposition:".  I will send an update when that filter is in
>>>  place.
>>>
>>>  We belive that this will take care of all three problems that have
>>  > been observed:  concatenated files, extra linefeeds in IDs, and
>>>  missing form-feed.  If such problems are found in the future please
>>>  let us know so we can track down the problem.
>>>
>>>  Al
>>>  --
>>>  Albert Vezza
>>>  President
>>>  Foretec Seminars, Inc
>>>  1895 Preston White Drive
>>>  Suite 100
>>>  Reston, VA 20191-5434
>>>
>>>  Internet mail: [email-masked]
>>>  Tel: (703) 620-9053
>>>  Fax: (703) 620-9071
>>>
>>>  Natick, MA Office
>>>  Tel:  (508) 650 4020
>>>  Fax:  (508) 650 4639
>>>
>>>  _______________________________________________
>>>  Tools-discuss mailing list
>>>  [email-masked]
>>>  https://www1.ietf.org/mailman/listinfo/tools-discuss
>>>
>>
>>
>>
>>**********************************
>>Madrid 2003 Global IPv6 Summit
>>Presentations and videos on line at:
>>http://www.ipv6-es.com
>>
>>This electronic message contains information which may be 
>>privileged or confidential. The information is intended to be for 
>>the use of the individual(s) named above. If you are not the 
>>intended recipient be aware that any disclosure, copying, 
>>distribution or use of the contents of this information, including 
>>attached files, is prohibited.
>>
>>
>>
>>
>>_______________________________________________
>>Tools-discuss mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/tools-discuss
>------------------------------------------------
>Barbara B. Fuller
>Acting Executive Director
>Internet Engineering Task Force
>
>Natick, Massachusetts Office:
>
>Phone: +1-508-650-4020
>Fax:     +1-508-650-4639
>
>Reston, Virginia Office:
>
>Phone: +1-703-620-9053
>Fax:     +1-703-620-9071

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: Adam Roach <[email-masked]>
Date: Thu, 02 Dec 2004 17:26:41 -0600

I apologize if I'm repeating suggestions, but I don't see it brought up 
on this thread yet: it seems that one mechanism that we could employ to 
avoid this kind of mangling is allowing the submission of 
RFC2629-formatted IDs in source form. By allowing the actual drafts to 
be generated on the IETF side of things, there isn't any transport in 
the way to mangle the final output.

/a

Albert Vezza wrote:

> folks and I have concluded that it is just too risky to accept zip and 
> tar files, because  one virus that might get through the virus filters 
> could disrupt operations.  If that disruption came at a busy time such 
> as just before a meeting there would be a great many people unhappy.
>
>>> List-Unsubscribe: 
>>> <https://www1.ietf.org/mailman/listinfo/tools-discuss>,
>>> This electronic message contains information which may be privileged 
>>> or confidential. The information is intended to be for the use of 
>>> the individual(s) named above. If you are not the intended recipient 
>>> be aware that any disclosure, copying, distribution or use of the 
>>> contents of this information, including attached files, is prohibited.
>>>
>>>
>>>
>>>

---

From: "Alex Rousskov" <[email-masked]>
Date: Fri, 03 Dec 2004 13:17:04 -0700

> the way to mangle the final output.

I suspect that if plain text sources can be damaged during shipping and  
handling, then raw XML draft sources can be damaged as well. However,  
submition of XML sources and generation of other formats based on those  
sources will be supported by the ID Submission Toolset.

Thank you,

Alex.