Subject: [Tools-discuss] Re: WG-pages v0.60

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 27 Oct 2005 06:20:55 +0200

Hi Allison,

Thank you.

Yes, there's an RFC index page planned, which links to this presentation
of the RFCs.  That RFC index page will have 2 or 3 different alternative
formats, one being similar to the index page maintained by the RFC
Editor, another being based on the compact index page put together by
Simon Leinen (http://mirror.switch.ch/rfc/mini-index.html) -- he's
already contributed the code, I just have to get it up there...

One additional feature of these html-ized RFCs which you may not have
come across yet is that in addition to showing a link to errata, it
will also show if the RFC has been obsoleted or updated by a later
one - another thing I've been missing when looking up RFCs.  An example:

Our dear 2026 has been updated by a number of RFCs, in addition to
having errata, and if you follow the link to 3667, you'll see that
it, in its turn, has been obsoleted by 3978:

  http://tools.ietf.org/tools/rfcmarkup/rfcmarkup.cgi?rfc=2026

I'll have the RFC indexes up pretty soon, but probably not before
Vancouver - I'm scrambling to get some other stuff in place by then.

	Henrik

on 2005-10-27 05:00 Allison Mankin said the following:
> Henrik,
> 
> Thanks to the Tools Team and you.
> 
> I want to commend this release, and add a note to its
> to its features.  You list adding the published RFCs to
> each working group page, but you didn't mention something
> really neat.  Fetch the html-ized RFC and one finds that
> it contains a link to its errata!  This is such a good idea,
> since of course the real worry is that errata won't be 
> consulted by the RFC readers.
> 
> I just stumbled on this in RFC 4114 through the ENUM WG
> page - tools.ietf.org/wg/enum
> 
> Perhaps as the site plans evolve, we'll see an 
> area with the wg RFCs all together in this form, to
> complement this.
> 
> Allison
> 
> 
>> 
>> Hi,
>> 
>> This is the formal release announcement of version 0.60 of the WG pages
>> available under
>> 
>>     http://tools.ietf.org/wg/
>> 
>> The changes contained in this version have been put in place gradually
>> since IETF-63, but an announcement seems appropriate to point out the
>> changes and improvements which are now in place.  From the changelog:
>> 
>> 
>> wg-pages (0.60)
>> 
>>  * Added WG Agendas back to IETF-59 (earlier agendas are not easily available
>>    without manual handling).
>> 
>>  * Added WG Minutes back to IETF-50.  Minutes which weren't natively in
>>    HTML format, but had some HTML added later, have been stripped to text
>>    format and run through fmt. 
>> 
>>  * Agendas and minutes will now be automatically updated also during coming
>>    IETFs, requiring no manual intervention.
>> 
>>  * Added a list of 'related drafts' at the bottom of the WG drafts page,
>>    based on the drafts being named with -<wg>- in the name.
>> 
>>  * Added updating of closed WGs.  Closed WGs will remain available with no
>>    change of URL, but will not be listed in the WG list on the left-hand
>>    side of the status pages.
>> 
>>  * Added pages for ietf and iab, under /group/iab and /group/ietf.
>> 
>>  * Added listing of published RFCs on the draft pages, with diff against
>>    the last draft version.
>> 
>>  * Added version indication on the WG status pages, with a link to tool
>>    information.
>> 
>> 
>> Feedback on these features, and suggestions for new ones, are always
>> welcome.
>> 
>> 
>> 	Henrik
>> 
> 

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 27 Oct 2005 08:32:32 +0200

> http://tools.ietf.org/tools/rfcmarkup/rfcmarkup.cgi?rfc=2026

Very nice, how about adding a link to the plain text version ?

That's what I missed when it broke at faqs.org, an option to
get the text (for my local / offline collection).  With the
redirection http://purl.net/net/rfc/2026 I get the abstract,
keywords, status, updates, errata, and a link to the text, but
not the links _in_ the text.

With your tool I get links _in_ the text, updates, errata, and
the abstract.  Tough, both views have something I like.

As you see I now managed to subscribe via GMaNe.  One idea...

>>> Feedback on these features, and suggestions for new ones,
>>> are always welcome.

...you could add a link to the jabber archives (and later a
xmpp: URL) to the WG homepages.  http://www.xmpp.org/ietf-logs
is a directory of all (?) WGs.  No idea why they keep empty
logs (= the 6 KB entries).
                          Bye, Frank

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 27 Oct 2005 14:23:35 +0200

Hi Frank,

> Very nice, how about adding a link to the plain text version ?

Sure.  Won't promise it before Vancouver, though :-)

> As you see I now managed to subscribe via GMaNe.  One idea...

Ah, so that was you.  I had my suspicions, but didn't know ,;-)

> logs (= the 6 KB entries).

Good idea.  To make it reasonably useful there really should be
links directly to the non-empty logs, but that will have to wait.
I'm adding a link to the jabber log directory, for now; that's
easy.

	Henrik

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 30 Oct 2005 23:53:13 +0100

Henrik Levkowetz wrote:

> I'm adding a link to the jabber log directory, for now;
> that's easy.

Thanks - just for fun, see...

http://news.spamcop.net/pipermail/spamcop-list/2005-October/105910.html

...for more credits ;-)  Bye, Frank