Subject: Re: Fwd: Re: [Tools-discuss] techspec bof agenda has errors

From: Michael Lee <[email-masked]>
Date: Tue, 01 Nov 2005 14:57:55 -0500

Hi Henrik,

Our file system show that the agenda file of techspec was uploaded on 
October 10th, and it didn't get replaced since then.
I also see that the entire contents of the techspec agenda in your 
system (http://tools.ietf.org/agenda/64/techspec.html) is slightly 
different from the one from the Secretariat's server 
(http://www3.ietf.org/proceedings/05nov/agenda/techspec.txt). Even the 
file format is different (.html in yours and .txt in the Secretariat's.) 
Aren't your system rsyncing those files every five minutes or so?
Is http://www3.ietf.org/proceedings/05nov/agenda is the only source that 
your system generates the agenda pages from?

One thing I need to clear is that I cannot find any evidence from our 
system that the old techspec agenda file was placed in IETF repository 
some time last night.

Thanks,
Michael.

Barbara B. Fuller wrote:

> Hi Mike:
>
> Please check to see if the strange behavior reported by Henrik below 
> was caused by a problem in our systems.
>
> Thanks.
>
> Barbara
> ---------------------------------------------------------------
>
>> Envelope-to: [email-masked]
>> Date: Tue, 01 Nov 2005 08:49:52 +0100
>> From: Henrik Levkowetz <[email-masked]>
>> User-Agent: Mozilla Thunderbird 1.0.7 (Macintosh/20050923)
>> X-Accept-Language: en-us, en
>> To: Aaron Falk <[email-masked]>
>> Subject: Re: [Tools-discuss] techspec bof agenda has errors
>> X-Enigmail-Version: 0.93.0.0
>> X-SA-Exim-Connect-IP: 127.0.0.1
>> X-SA-Exim-Mail-From: [email-masked]
>> X-SA-Exim-Scanned: No (on shiraz.levkowetz.com);
>>         SAEximRunCond expanded to false
>> X-Spam-Score: 0.1 (/)
>> X-Scan-Signature: d6b246023072368de71562c0ab503126
>> Cc: [email-masked], Allison Mankin <[email-masked]>
>> X-BeenThere: [email-masked]
>> X-Mailman-Version: 2.1.5
>> List-Id: IETF Tools Discussion <tools-discuss.ietf.org>
>> List-Unsubscribe: 
>> <https://www1.ietf.org/mailman/listinfo/tools-discuss>,
>>         <mailto:[email-masked]?subject=unsubscribe>
>> List-Archive: <http://www1.ietf.org/pipermail/tools-discuss>
>> List-Post: <mailto:[email-masked]>
>> List-Help: <mailto:[email-masked]?subject=help>
>> List-Subscribe: <https://www1.ietf.org/mailman/listinfo/tools-discuss>,
>>         <mailto:[email-masked]?subject=subscribe>
>> Sender: [email-masked]
>> X-Spam-Score: 0.1 (/)
>> X-Scan-Signature: 93238566e09e6e262849b4f805833007
>>
>> Hi Aaron,
>>
>> on 2005-11-01 06:34 Aaron Falk said the following:
>> > Specifically, on <http://tools.ietf.org/agenda/64/techspec.html> the
>> > draftname should be draft-mankin-pub-req.  There may be other errors.
>>
>> That's interesting.  I noticed that error on Oct. 9th, and notified
>> Leslie.  It was corrected on the 10th.  Now I see that the old file
>> has reappeared, some time last night, in the IETF repositories, been
>> rsynced to tools.ietf.org, and caused a page update back to the old
>> text.  Then the correct version has again been put in place... but with
>> the old date, so no update of the tools.ietf.org webpage has been
>> triggered.
>>
>> Very tricky.
>>
>>
>>         Henrik
>>
>>
>> _______________________________________________
>> Tools-discuss mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/tools-discuss
>
>
> ------------------------------------------------
> Barbara B. Fuller
> Acting Executive Director
> Internet Engineering Task Force
>
> Natick, Massachusetts Office:
>
> Phone: +1-508-650-4020
> Fax:     +1-508-650-4639
>
> Reston, Virginia Office:
>
> Phone: +1-703-620-9053
> Fax:     +1-703-620-9071

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 01 Nov 2005 22:49:56 +0100

Hi Mike,

  Thanks for responding :-)

> file format is different (.html in yours and .txt in the Secretariat's.)

Yes.  The text format is html-ized to provide clickable links to all
the drafts and URLs referred to in the agendas - it's much easier to
keep up with the drafts being discussed in a meeting if you can just
click on a link instead of copying the draft name and adding the
internet-draft http address manually in your browser...

> Aren't your system rsyncing those files every five minutes or so?

Yes, that's right - well, not rsyncing, but using http.  There's no
rsync access provided for this, I think.

> your system generates the agenda pages from?

I originally was getting agendas from http://www.ietf.org/ietf/05nov/,
but then the agendas people were uploading wasn't transferred over
there, so I started also getting what's available at 
http://www3.ietf.org/proceedings/05nov/agenda/.  I'm not not getting
the sources from anywhere else.

> system that the old techspec agenda file was placed in IETF repository 

Right.  I don't think that's what happened.  It's more likely that
there could be something odd with the 3 servers that www.ietf.org
used to resolve to (when I checked a few weeks ago) / the 2
servers it is currently resolving to, and the mirroring solution
used between them.  Could it be that the mirroring is done with some
mechanism which updates all the files, not only the ones which have
changed, and doesn't do it by first transferring and then moving the
files into place by changing names?  Rsync gets this right (unless you
explicitly tell it to do it by a different method), but a lot of other
mirroring software might transfer files directly to a file with the
final name; this could result in a wrong file date if somebody fetched
that freshly transferred file before it had its date corrected to be
the same as the original file's...

Regards,

	Henrik