Subject: [Tools-discuss] drafts trivia

From: Jari Arkko <[email-masked]>
Date: Mon, 07 Nov 2005 23:19:14 +0200

I made a small tool couple of weeks ago to run some
statistics on drafts and people who write them.
This includes things like how many pages drafts
have, statistics on version numbers, who are the
authors who write most drafts, what company
or country drafts come from etc. Mostly trivia,
but it may have at least entertainment
value. The data is available here:

http://www.arkko.com/tools/stats/index.html

Note that there hasn't been all that much testing and
verification of the data produced by this. There could
be errors. In fact, we know there are errors. This
is largely based on heuristics about what author
sections in drafts/RFCs look like, and an attempt to
parse, e.g., country and e-mail domain information
to figure out affiliation and location.

--Jari

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Sun, 20 Nov 2005 15:01:44 +0100

Great stuff, Jari!

I particularly like this one:

57 drafts (2.53%) have authors from Australia.
7 drafts (0.31%) have authors from Africa.
1 drafts (0.04%) have authors from OTHER.
7 drafts (0.31%) have authors from South america.
1701 drafts (75.50%) have authors from North america.
482 drafts (21.39%) have authors from Asia.
1138 drafts (50.51%) have authors from Europe.

Not only are we an international organization, a huge number of our drafts 
are multinational too...

                 Harald