Subject: [Tools-discuss] Time/Deadline tracking tool?

From: Bill Fenner <[email-masked]>
Date: Fri, 16 Dec 2005 08:03:35 -0800

I'm thinking of a tool that knows what steps exist in the process and
has estimates for how long they do or can take (e.g., "IESG Approval -
1 day through 6 weeks"), and then stacks them up to see when an RFC might
pop out.  I'm thinking of this for groups that have external dependencies,
e.g., ITU meetings that need an RFC number for a document by X date -
working backwards from a deadline, with average values for each step,
you can see what deadlines there are for earlier steps (such as WG
consensus or IETF Last Call or ...).

Does anyone know of a tool like this?

Thanks,
  Bill

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 19 Dec 2005 10:25:21 +0100

Aren't we dealing with long-tailed distributions here? I suspect that
makes prediction quite hard.

    Brian

---

From: [email-masked]
Date: Mon, 19 Dec 2005 16:11:43 +0200

I like the idea. Maybe the prediction could be a probability 
distribution as well?

Something like "25% of documents go from WGLC to RFC in <=X1 months,
50% in <=X2 months, 75% in <=X3 months"?  This way, the horribly 
long tail wouldn't skew the figures so much, and you could pick 
either an optimistic or pessimistic estimate depending on the
document and your mood :-)

Speaking about the long tail....

o  draft-ietf-rsvp-proxy has been in AD Evaluation :: 
   Revised ID Needed (jpeterson) for 1082 days
o  draft-ietf-megaco-h248v2 has been in Publication Requested :: 
   External Party (jpeterson) for 928 days
o  draft-bradner-pbk-frame has been in IESG Evaluation :: 
   Revised ID Needed (rhousley) for 891 days
o  draft-polk-ieprep-flow-model-considerations has been in 
   AD Evaluation :: External Party (jpeterson) for 698 days
o  draft-rajeshkumar-mmusic-gpmd has been in IESG Evaluation :: 
   External Party (jpeterson) for 667 days
o  draft-ietf-imapext-sort has been in IESG Evaluation :: 
   AD Followup (sah) for 640 days
o  draft-hardie-bounded-longest-match has been in AD Evaluation :: 
   External Party (azinin) for 629 days
o  draft-ietf-idmr-dvmrp-v3-as has been in Waiting for 
   Writeup (fenner) for 520 days
o  draft-ietf-idmr-dvmrp-v3 has been in Waiting for 
   Writeup (fenner) for 520 days
o  draft-rfc-editor-rfc2223bis has been in IESG Evaluation :: 
   AD Followup (becarpenter) for 516 days
o  draft-ietf-ips-scsi-mib has been in Expert Review :: 
   AD Followup (mankin) for 516 days

:-)

Best regards,
Pasi

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Mon, 19 Dec 2005 15:21:25 +0100

I think the thing you are looking for closely resembles a project planning 
tool.... and I think calibrating it to the 50th percentile would give 
interesting feedback; essentially "if you are here in the process and don't 
believe in miracles, you must start worrying THIS long before the deadline".

I suspect that the "long tail" is mainly stuff where the proponents have 
lost interest; they might either have despaired of ever getting the 
document passed or they might have gone on to other pursuits.

One dose of forgetfulness, carefully applied, works wonders for increasing 
delays.....

                             Harald

--On mandag, desember 19, 2005 10:25:21 +0100 Brian E Carpenter 
<[email-masked]> wrote:

>> pop out.  I'm thinking of this for groups that have external
>> dependencies, e.g., ITU meetings that need an RFC number for a document
>> by X date - working backwards from a deadline, with average values for
>> each step, you can see what deadlines there are for earlier steps (such
>> as WG consensus or IETF Last Call or ...).
>>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 20 Dec 2005 14:11:38 +0100

The *very* long tail is indeed mainly very special cases, and is
mainly a concern because it skews the mean value. So percentiles
are the way to go; we could regard the 50th percentile as a key
indicator for example.

     Brian