Subject: [Tools-discuss] [Fwd: Here's a nifty idea]

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 17 Feb 2006 14:18:12 +0100

Hi,

  I got this from Mark Townsley, and thought it was indeed a nifty idea,
but don't have any cycles to dive into it myself.  Maybe there is
someone on the list who would like to take this on?

Regards,

	Henrik

-------- Original Message --------
Subject: Here's a nifty idea
Date: Thu, 16 Feb 2006 12:55:36 +0100
From: Mark Townsley <[email-masked]>
To: Henrik Levkowetz <[email-masked]>

A firefox plugin search toolbar for ID and RFC search (or, heck, tracker 
search). This could be its own thing, or hang off of the multi-search engine 
toolbar installed by default.

- Mark

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: [email-masked]
Date: Fri, 17 Feb 2006 16:05:46 +0200

BTW, the Firefox seach plugin collection already has an RFC 
search plugin:

http://mycroft.mozdev.org/download.html?name=rfc&submitform=Search 

Seems to work, although I prefer using local copies of IDs and RFCs
(and searching rfc-index.txt/1id-index.txt in Emacs with Ctrl-S,
or all files with grep).

Best regards,
Pasi

> -----Original Message-----
> From: Henrik Levkowetz
> Sent: 17 February, 2006 15:18
> To: [email-masked]; Tools-team
> Subject: [Tools-discuss] [Fwd: Here's a nifty idea]
> 
> Hi,
> 
>   I got this from Mark Townsley, and thought it was indeed a 
> nifty idea, but don't have any cycles to dive into it myself.  
> Maybe there is someone on the list who would like to take 
> this on?
> 
> Regards,
> 
> 	Henrik
> 
> A firefox plugin search toolbar for ID and RFC search (or, 
> heck, tracker search). This could be its own thing, or hang 
> off of the multi-search engine toolbar installed by default.
> 
> - Mark

---

From: Elwyn Davies <[email-masked]>
Date: Tue, 21 Feb 2006 15:15:36 +0000

Both the tools on the page mentioned here work OK but they appear to 
only search the headers.

There seems to be a dearth of tools that do a full text search.  The 
Zvon archive used to have this capbility but the old archive is no 
longer maintained and the new version only does header search.   In 
practice I don't do full searches that frequently and I can usually 
download what I need rather than tying up my disk space with a complete 
set (even if it isn't that big) but an an online service would be helpful.

Regards,
Elwyn

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 21 Feb 2006 20:02:47 +0100

on 2006-02-21 16:15 Elwyn Davies said the following:
...
> set (even if it isn't that big) but an an online service would be helpful.

Noted!  (And I agree.)

	Henrik

---

From: <[email-masked]>
Date: Thu, 23 Feb 2006 18:15:16 +0200

Elwyn Davies wrote:

> download what I need rather than tying up my disk space with 
> a complete set (even if it isn't that big) but an an online 
> service would be helpful.

Google "keyword1 keyword2 site:www.ietf.org/rfc" does a full-text
for RFCs, and "site:www.ietf.org/internet-drafts" works for I-Ds.

It's not an ideal solution; for instance, the page titles shown by
Google are not very informative. Some other sites work better
in this respect, e.g. "site:rfc-archive.org".

It should not be difficult to turn these into a Firefox search plugin,
but on the other hand, typing the "site:" part is not a big job
either :)

Best regards,
Pasi

---

From: Thomas Morin <[email-masked]>
Date: Thu, 23 Feb 2006 17:42:33 +0100

Another solution in Firefox: make parametrized bookmarks with a keyword

- for rfcs:  
   * Location: http://www.faqs.org/rfcs/rfc%s.html
   * Keyword:  rfc
   * Type "rfc 4364" in your URL bar
- for working groups
   * Location: http://tools.ietf.org/wg/%s
   * Keyword: wg
   * type "wg pim" in your URL bar
- for drafts:
   * Location: http://www.ietf.org/internet-drafts/draft-%s.txt
   * keyword: draft
   * type "draft ietf-l3vpn-ppvpn-mcast-reqts-04" in your URL bar
- for working-groups drafts
   * Location:http://tools.ietf.org/wg/l3vpn/draft-ietf-%s/
   * Keyword: wgdraft
   * Type "wgdraft l3vpn-2547bis-mcast"

I'm using at least the first two ones all the time.

-Thomas

---

From: Elwyn Davies <[email-masked]>
Date: Thu, 23 Feb 2006 17:42:27 +0000

OK.  Thanks for the suggestion.

I wasted my substance and produced a Firefox search plugin that does the 
business.

This one does RFCs but it is trivial to modify it to look in I-Ds or to 
look at somebody else's repository.
It is actually more work to create a suitable icon!
(It is just a very slightly hacked version of the example Google search 
plugin given in the Mycroft manual. It could be cleaned up considerably.)

Install the attached two files in Firefoxs's searchplugins directory 
(see http://mycroft.mozdev.org/deepdocs/installing.html#manual for details).
The 'gif' is a very coarse icon that is displayed in the search box.
The 'src' is just a piece of textual xml.
You need to restart Firefox to display it.

If you want to change the site just look for the line containing 
name="sitesearch" in the src file and change the value string.
Change the name and description appropriately (lines 18 and 19), change 
the filename and generate a suitable icon which shares the name part of 
the new src file.

Regards,
Elwyn

Programing note: See items [26] and [27] in the 'contributed notes' 
(http://mycroft.mozdev.org/deepdocs/inputtags.html#usernotes) for info 
on sitesearch and combining user input with fixed strings in a Google 
search.

> but on the other hand, typing the "site:" part is not a big job
# GoogleUK Search plug-in for Mozilla/Netscape 6+
# by amitp at google dot com
# modified by  wolfgang dot schroedl at gmx dot net and  juliusross at mac dot com 

# Last updated: 28 June 2002

# Modification by Elwyn Davies, 23 Feb 2006: Adapted to search the IETF RFC site only

# This plugin can be altered so that it can
# (a) search using any of the google mirrors
# (b) restrict your search to sites from a particular country
# (c) restrict your search to sites in a particular language

# Known issues:
# 1. The previous/next buttons have been disabled.

<search 
   name="RFC Full Text at IETF"
   description="Google Search of IETF RFC Repository"
   method="GET"

#################################################
#						#
#  Choosing a google mirror			#
#						#	
#################################################
#
# To use google from a particular country remove the line 
# which says
# 
#   action="http://www.google.com/search"
#
# and uncomment the appropriate "action" line by removing
# the leading "#".
#
# Note: If you also want to restrict your search to 
# sites from a particular country then see below.

action="http://www.google.com/search"

#action="http://www.google.de/search"
	   #Deutschland

#action="http://www.google.fr/search"
	   #France

#action="http://www.google.co.uk/search"      
	#the UK

#action="http://www.google.co.jp/search"      
	 #Japan

#action="http://www.google.co.kr/search"    
	    #Korea

#action="http://www.google.it/search"    
	#Italia

#action="http://www.google.ch/search"    
 	   #der Schweiz

#action="http://www.google.ca/search"     
	   #Canada

#action="http://www.google.co.il/search"     
	#Israel

#action="http://www.google.nl/search"             
	#Nederland

#action="http://www.google.be/search"            
 	#Belgium

#action="http://www.google.cl/search"            
 	#Chile

#action="http://www.google.com.ar/search"            
 	#Argentina

#action="http://www.google.com.pa/search"            
	 #Panama

#action="http://www.google.at/search"          
   #Austria

#action="http://www.google.com.pl/search"            
	 #Polska

#action="http://www.google.com.ru/search"         
 	#Russian Federation

#action="http://www.google.com.br/search"           
 	#Brasil

#action="http://www.google.co.nz/search"            
	 #New Zealand

#action="http://www.google.vg/search"             
	#Virgin Islands

#action="http://www.google.bi/search"             
	#Burundi

#action="http://www.google.cc/search"            
	 #Cocos Islands

#action="http://www.google.li/search"             
	#Liechtenstein

#action="http://www.google.lt/search"             
	#Lietuvos
 
#action="http://www.google.mw/search"          
   	#Malawi

#action="http://www.google.fm/search"       
	#Micronesia

#action="http://www.google.ms/search"            
	 #Montserrat

#action="http://www.google.com.nf/search"             
	#Norfolk Island

#action="http://www.google.sh/search"             
	#Saint Helena

#action="http://www.google.cd/search"             
	#Rep. Dem. du Congo

#action="http://www.google.co.gg/search"             
	#Guernsey

#action="http://www.google.co.je/search"             
	#Jersey

#action="http://www.google.co.cr/search"            
	 #Costa Rica

#action="http://www.google.lv/search"          
   	#Latvija

# There are several bugs in the code for the Next and Previous buttons; therefore, they are disabled
#<inputnext name="start" factor="20">
#<inputprev name="start" factor="20">

<input name="q" user>
<input name="sourceid" value="Mozilla-search">

# Added line to force search of just the IETF RFC repository
<input name="sitesearch" value="www.ietf.org/rfc">

#################################################
#						#
#  Setting the number of hits			#
#						#	
#################################################
#
# You may change the number below if you want

<input name="num" value="20">

#################################################
#						#	
#  Restricting your search to sites in		#
#  a particular language			#
#						#	
#################################################
#
# To restrict your search to sites in a particular language
# uncomment one of the following lines by removing the leading "#"
# from the appropriate <input> line.
#

#<input name="lr" value="lang_ar">        
       # Arabic

#<input name="lr" value="lang_bg">        
       # Bulgarian

#<input name="lr" value="lang_ca">        
       # Catalan

#<input name="lr" value="lang_zh-CN">        
       # Chinese (Simplified)

#<input name="lr" value="lang_zh-TW">        
       # Chinese (Traditional)

#<input name="lr" value="lang_hr">        
       # Croatian

#<input name="lr" value="lang_cs">        
       # Czech

#<input name="lr" value="lang_da">        
       # Danish

#<input name="lr" value="lang_nl">        
       # Dutch

#<input name="lr" value="lang_en">        
       # English

#<input name="lr" value="lang_et">        
       # Estonian

#<input name="lr" value="lang_fi">	 
       # Finnish

#<input name="lr" value="lang_fr">        
       # French

#<input name="lr" value="lang_de">	 
       # German

#<input name="lr" value="lang_el">	  
       # Greek

#<input name="lr" value="lang_iw">	   
       # Hebrew

#<input name="lr" value="lang_hu">        
       # Hungarian

#<input name="lr" value="lang_is">        
       # Icelandic

#<input name="lr" value="lang_id">        
       # Indonesian

#<input name="lr" value="lang_it">        
       # Italian

#<input name="lr" value="lang_ja">        
       # Japanese

#<input name="lr" value="lang_ko">        
       # Korean

#<input name="lr" value="lang_lv">        
       # Latvian

#<input name="lr" value="lang_lt">        
       # Lithuanian

#<input name="lr" value="lang_no">        
       # Norwegian

#<input name="lr" value="lang_pl">        
       # Polish

#<input name="lr" value="lang_pt">        
       # Portuguese

#<input name="lr" value="lang_ro">        
       # Romanian

#<input name="lr" value="lang_ru">        
       # Russian

#<input name="lr" value="lang_sr">        
       # Serbian

#<input name="lr" value="lang_sk">        
       # Slovak

#<input name="lr" value="lang_sl">	  
       # Slovenian

#<input name="lr" value="lang_es">        
       # Spanish

#<input name="lr" value="lang_sv">        
       # Swedish

#<input name="lr" value="lang_tr">          
       # Turkish

#################################################
#						#	
#  Restricting your search to sites in		#
#  a particular country				#
#						#	
#################################################
#
# To restrict your google search to a particular country
# uncomment one of the following lines by removing the leading "#"
# from the appropriate <input> line.
#

#<input name="cr" value="countryAT">        
	# Austria

#<input name="cr" value="countryAU">        
	# Australia

#<input name="cr" value="countryBE">      
	# Belgium

#<input name="cr" value="countryBR">     
	# Brazil

#<input name="cr" value="countryCA">     
	  # Canada

#<input name="cr" value="countryCN">    
	# China

#<input name="cr" value="countryCZ">    
	# Czech Republic

#<input name="cr" value="countryDK">        
	# Denmark

#<input name="cr" value="countryDE">        
	# Germany

#<input name="cr" value="countryUK|countryGB">       
	# Great Britain

#<input name="cr" value="countryFR">       
       # France

#<input name="cr" value="countryFI">       
	# Finland

#<input name="cr" value="countryIT">        
	# Italy

#<input name="cr" value="countryJP">      
	# Japan

#<input name="cr" value="countryKR">     
	# Korea

#<input name="cr" value="countryNL">     
	# Netherlands

#<input name="cr" value="countryNO">     
	# Norway

#<input name="cr" value="countryPL">    
	# Poland

#<input name="cr" value="countryRU">    
	# Russian Federation

#<input name="cr" value="countryES">    
	# Spain

#<input name="cr" value="countrySE">    
	# Sweden

#<input name="cr" value="countryCH">    
	# Switzerland

#<input name="cr" value="countryTW">    
	# Taiwan

#<input name="cr" value="countryUK">        
	# United Kingdom

#<input name="cr" value="countryUS">        
	# United States

<interpret 
    browserResultType="result" 
    resultListStart="<!--a-->" 
    resultListEnd="<!--z-->" 
    resultItemStart="<!--m-->" 
    resultItemEnd="<!--n-->"
</search>

<BROWSER
   alsomatch="'http://www.google.com/search','http://www.google.de/search','http://www.google.fr/search','http://www.google.co.uk/search','http://www.google.co.jp/search','http://www.google.co.kr/search','http://www.google.it/search','http://www.google.ch/search','http://www.google.ca/search','http://www.google.co.il/search','http://www.google.nl/search','http://www.google.be/search','http://www.google.cl/search','http://www.google.com.ar/search','http://www.google.com.pa/search','http://www.google.at/search','http://www.google.com.pl/search','http://www.google.com.ru/search','http://www.google.com.br/search','http://www.google.co.nz/search','http://www.google.vg/search','http://www.google.bi/search','http://www.google.cc/search','http://www.google.li/search','http://www.google.lt/search','http://www.google.mw/search','http://www.google.fm/search','http://www.google.ms/search','http://www.google.com.nf/search','http://www.google.sh/search','http://www.google.cd/search','http://www.google.co.gg/search','http://www.google.co.je/search','http://www.google.co.cr/search','http://www.google.lv/search'"   
   update="http://mycroft.mozdev.org/update.php/id0/google.src" 
   updateIcon="http://mycroft.mozdev.org/update.php/id0/google.gif" 
   updateCheckDays="7"