Subject: [Tools-discuss] Idnits-1.92 feedback: reference checking

From: "Thomson, Martin" <[email-masked]>
Date: Thu, 27 Apr 2006 20:52:12 -0500

Nothing drastic, but bomething to consider with the experimental reference checking:

  - Missing Reference: [A-Z] is mentioned on line 375, but not defined
        '         <xs:pattern value="[A-Z]{2}"/>'

On a related node, xml2rfc often wraps references in text if they contain a hyphen, like most I-D references do.  The reference checker isn't picking these up either.

Enjoy,
Martin

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 28 Apr 2006 21:15:42 +0200

Hi Martin,

> '         <xs:pattern value="[A-Z]{2}"/>'

Hmm, something has really gone wrong here.  Is the document which caused
this available?

> On a related node, xml2rfc often wraps references in text if they
> contain a hyphen, like most I-D references do.  The reference checker
> isn't picking these up either.

Ah.  I'll have a look at that.  Thanks.

Regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 30 Apr 2006 17:07:51 +0200

Hi again,

  Both of the issues described below should be fixed in version 1.93,
available now from http://tools.ietf.org/tools/idnits .

Regards,

	Henrik