Subject: [Tools-discuss] Re: Request for publication of draft-ietf-ipr-ietf-trust-update-01 as a BCP

From: Frank Ellermann <[email-masked]>
Date: Tue, 22 Aug 2006 11:59:13 +0200

Hi, apparently something that could be improved: 

> idnits 1.106
[...]
> Experimental warnings:
> - Missing Reference: 'RFC3978' is mentioned on line 56, but not defined
> - Missing Reference: 'BCP101' is mentioned on line 64, but not defined
> - Unused Reference: 'RFC 3978' is defined on line 134, but not referenced
> - Unused Reference: 'BCP 101' is defined on line 137, but not referenced

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 22 Aug 2006 13:07:26 +0200

No, it is actually an internal consistency in the draft, entirely
possible with nroff and almost impossible with xml2rfc.

I think the warning is useful, if trivial.

    Brian

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 22 Aug 2006 15:20:11 +0200

> I think the warning is useful, if trivial.

Okay, no radical "white space canonicalization" for
the idnits, let it treat <FWS> as space, not as empty.

Frank

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 22 Aug 2006 18:19:53 +0200

Hi Frank,

>> - Unused Reference: 'BCP 101' is defined on line 137, but not referenced

Are you sure that it's OK that references are inconsistently used/defined,
and idnits should ignoring embedded spaces?  I can make it so, but it's not
obvious to me that the warnings above are wrong...

Of course, what could be improved is to change the warning to say that the
definition has embedded spaces and is different from the used form, but
that seems to be a small benefit for the extra complexity...

Regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 22 Aug 2006 18:26:04 +0200

Hi again,

> the idnits, let it treat <FWS> as space, not as empty.

Ah.  I see you already landed regarding this.  Right.
Please disregard my previous message, then.

	Henrik

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 23 Aug 2006 06:01:28 +0200

Henrik Levkowetz wrote:

> I see you already landed regarding this.

Yes, when I first saw "BCP78" != "BCP 78" I thought that
this is a bit extreme.  But actually it's okay - authors
can always avoid it, and a "FWS-canonicalization" matching
in this case would also match clear typos.

Sorry for the unnecessary confusion: Frank