Subject: [Tools-discuss] Idnits-1.114 feedback

From: Love Hörnquist Åstrand <[email-masked]>
Date: Mon, 23 Oct 2006 12:22:55 +0200

Experimental warnings:
   - Missing Reference: '0' is mentioned on line 186, but not defined
   - Missing Reference: '1' is mentioned on line 187, but not defined
   - Missing Reference: '2' is mentioned on line 189, but not defined
   - Missing Reference: '3' is mentioned on line 182, but not defined

this is part of asn.1 spec of the file, so the tool is a little bit  
oversealous,.

Other that that, thanks for a great and useful tool.
Love

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 23 Oct 2006 20:26:44 +0200

Hi Love,

> this is part of asn.1 spec of the file, so the tool is a little bit  

Ah.  Yes, I know there are some cases where it produces false positives,
and it's not always easy for a script to realize when [something] is a
reference and when it's something else entirely.  But if you'll indicate
which draft we're dealing with, I'll have a look at the context and see
if some tweak is possible.

> Other that that, thanks for a great and useful tool.

Thanks :-)  You're welcome!

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 23 Oct 2006 23:25:51 +0200

Hi Love,

on 2006-10-23 23:11 Love Hörnquist Åstrand said the following:
...
> 
> Really, any draft containing asn.1 should trigger the problem because
> int asn.1 its common to have data look like this
> 
> Foo ::= SEQUENCE {
>     field [0] Fieldtype
> }

Hmm.  Ok.

Could any other keyword occur in place of 'SEQUENCE' ?

I assume the syntax doesn't care about amount of whitespace between
e.g. "::=" and "SEQUENCE"?

Can there be nested '{' ... '}' inside the outer '{', '}' ?

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 24 Oct 2006 01:15:15 +0200

Hi Love,

on 2006-10-24 00:14 Love Hörnquist Åstrand said the following:
> Yes, SET
> There is also SEQ OF SEQ {
> 
> }
> 
> and there can be nesting in all levels to your hearts content (both  
> with SET/SET OF/SEQ/SEQ OF
> and {}).

Ugh.

I looked a bit more on some samples, and I see that there can also
be occurrences of real references in strings and comments.  This
starts to look at needing to half-way write an asn.1 parser in order
to keep apart the references from the non-references.  I thought I
might exclude all "["..."]" on the inside of asn.1 "{" and "}",
counting nesting levels to know when to stop the exclusion, but that
won't work here...

Unless you have some way of quickly get around this, I'm going to
let this bug remain for now, I think.

	Henrik

---

From: Jari Arkko <[email-masked]>
Date: Tue, 24 Oct 2006 09:02:22 +0300

>> There is also SEQ OF SEQ {
Not to forget CHOICE { ... }
>> with SET/SET OF/SEQ/SEQ OF
And there is no requirement, only a convention, that
the newlines are placed as they are. And there can be
"--" comments everywhere.
>> let this bug remain for now, I think.
Letting it remain would be my recommendation.
(Speaking as someone who has a long time ago
implemented an ASN.1 parser and lived to tell
others about it.)

--Jari

---

From: Love Hörnquist Åstrand <[email-masked]>
Date: Mon, 23 Oct 2006 23:11:17 +0200

Foo ::= SEQUENCE {
    field [0] Fieldtype
}

In this case, its the upcoming draft-ietf-krb-wg-pkinit-alg- 
agility-01.txt
(if I manged to submit it).

Love

---

From: Love Hörnquist Åstrand <[email-masked]>
Date: Mon, 23 Oct 2006 23:11:17 +0200

Foo ::= SEQUENCE {
    field [0] Fieldtype
}

Love

---

From: Love Hörnquist Åstrand <[email-masked]>
Date: Tue, 24 Oct 2006 00:14:27 +0200

Yes, SET

}

Enjoy.

Love

---

From: Love Hörnquist Åstrand <[email-masked]>
Date: Tue, 24 Oct 2006 00:14:27 +0200

Yes, SET

}

Enjoy.

Love