Subject: [Tools-discuss] Re: ion-ion-format open for public comment

From: Frank Ellermann <[email-masked]>
Date: Sat, 16 Dec 2006 22:10:38 +0100

Henrik Levkowetz wrote on the general list:
 
> I just tried the recommended command:
>  $ svn co https://www1.tools.ietf.org/svn/group/iesg/ions
[...]
> If you have a password for authenticated access on tools.ietf.org

Yes, I replaced the <button> by <input type="submit">, that
works.  Of course I can't really test it anywhere, but your
form wants it twice, and I used copy & paste, the chances for
stupid typos at this stage are zero.

With the same password still in the clipboard I filled out:

svn --non-interactive --username [email-masked]
 --password munged co https://www1.tools.ietf.org/svn/group/iesg/ions

Result:
 svn: PROPFIND request failed on '/svn/group/iesg/ions'
 svn: PROPFIND of '/svn/group/iesg/ions': authorization failed
(https://www1.tools.ietf.org)

It's similar if I use the interactive version, it only asks 
for a user and password then.  Apparently the username fails.
The real password is longer (30 characters).  The SVN client
works elsewhere, example:

http://openspf.org/svn/project/specs/drafts/draft-ellermann-spf-options-01.xml

The version is:

| svn, version 1.2.3 (r15833)
|    compiled Sep  5 2005, 20:34:09
|
| Copyright (C) 2000-2005 CollabNet.
[...]
| * ra_dav : Module for accessing a repository via WebDAV (DeltaV)
protocol.
|   - handles 'http' scheme
|   - handles 'https' scheme
| * ra_svn : Module for accessing a repository using the svn network
protocol.
|   - handles 'svn' scheme
| * ra_local : Module for accessing a repository on local disk.
|   - handles 'file' scheme

Unfortunately svn co doesn't support "-v" (verbose).  I also
tried http instead of https. same effect.  AFAIK there is no
fresher / better client for OS/2.

Frank

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 16 Dec 2006 22:48:21 +0100

Hi Frank,

on 2006-12-16 22:10 Frank Ellermann said the following:
...
> stupid typos at this stage are zero.

Yes, your username and password has gone in fine, I see the
entry in the digest file, and I see the accesses in the apache
log file.

> (https://www1.tools.ietf.org)

Right -- in this case, I *dont* see any accesses with http auth
username in the apache log files.  Somehow it seems the --username
in the svn command isn't sent along for http auth??

> fresher / better client for OS/2.

Hmm.  Svn on shiraz is 1.4.2, but I really don't think that should
matter.  I'm baffled by your auth name not showing up in the apache
logs.

I don't have any immediate bright ideas; I'm going to try the svn
version on my laptop, that only has version 1.1.4, so that may give
some indication.  More later.

Let me know if you have further ideas, too.

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 16 Dec 2006 22:59:36 +0100

Hi again,

...

> some indication.  More later.

Ok, so I tried this with svn 1.1.4.  It doesn't understand https, but
this command worked without asking for auth at all:

  henrik@marsanne $ svn co http://www1.tools.ietf.org/svn/group/iesg/ions
  A  ions/dated
  A  ions/dated/ion-ion-format-2006-07-03.txt
  A  ions/dated/ion-ion-store-2006-07-07.txt
  A  ions/drafts
  A  ions/drafts/ion-procdocs.html
  A  ions/drafts/ion-ion-store.html
  A  ions/drafts/ion-ion-format.txt
  A  ions/drafts/ion-procdocs.xml
  Checked out revision 56.

[?? Svn must have cached the password somewhere??]

Trying as another user:

  henrik@marsanne $ sudo -u nobody svn co http://www1.tools.ietf.org/svn/group/iesg/ions
  Authentication realm: <http://www1.tools.ietf.org:80> IETF
  Password for 'nobody': 
  Authentication realm: <http://www1.tools.ietf.org:80> IETF
  Username: [email-masked]
  Password for [email-masked]': 
  A  ions/dated
  A  ions/dated/ion-ion-format-2006-07-03.txt
  A  ions/dated/ion-ion-store-2006-07-07.txt
  A  ions/drafts
  A  ions/drafts/ion-procdocs.html
  A  ions/drafts/ion-ion-store.html
  A  ions/drafts/ion-ion-format.txt
  A  ions/drafts/ion-procdocs.xml
  Checked out revision 56.

So this works with http and svn version 1.1.4 - I'm still baffled
with respect to your failure...

	Henrik

---

From: Frank Ellermann <[email-masked]>
Date: Sat, 16 Dec 2006 23:10:42 +0100

> Let me know if you have further ideas, too.

s/https/svn/ in the URL doesn't help.  

Here's something I see only in the interactive
version, your side says:

Authentication realm: <https://www1.ietf.tools.org:443> IETF

---
LOL... what was that, do new version have a chat ?
My shell tried desperately to execute whatever
you said, the error results garbled the message ;-)

Frank

---

From: Frank Ellermann <[email-masked]>
Date: Sat, 16 Dec 2006 23:31:03 +0100

>   henrik@marsanne $ svn co http://www1.tools.ietf.org/svn/group/iesg/ions

At that point it asks me for the password for user 'frank',
because that's my default user name (noted by SVN somewhere)

> [?? Svn must have cached the password somewhere??]

Yes, in your home directory ~/.subversion/auth/svn.simple
You can disable the password cache in ~/.subversion/config

> I'm still baffled with respect to your failure...

Same here.  No problem at another site (svn update worked).

Frank

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 16 Dec 2006 23:56:32 +0100

Hi Frank,

> s/https/svn/ in the URL doesn't help.  

No, that would require me to make an svn server available,
something I've chosen not to do because it's not obvious
how to arrange for the same user/password for that as for
the http auth.

> you said, the error results garbled the message ;-)

Ah.  To be clear, I've here replaced all characters typed by me
with '@' in the interaction after the initial command:

  Password for 'nobody': @
  Username: @@@@@@@@@@@@@@@@@@@@
  Password for [email-masked]': @@@@@@@@@@@

	Henrik

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 17 Dec 2006 00:10:48 +0100

>> LOL... what was that, do new version have a chat ?

Strike that, I managed to paste the complete body of your

>   Password for [email-masked]': @@@@@@@@@@@

Yes, that's the point where it's good to have a password
in the clipboard, not some other text.  Just for info,
here's the (munged) auth cache for the working site, the
format is K (key) length, name, V (val) length, content:

K 8
passtype
V 6
simple
K 8
password
V 20
munged-munged-munged
K 15
svn:realmstring
V 41
<http://www.openspf.org:80> SPF Internals
K 8
username
V 15
-munged-munged-
END