Subject: [Tools-discuss] idnits: amusing bug

From: Brian E Carpenter <[email-masked]>
Date: Mon, 04 Jun 2007 13:13:31 +0200

> idnits 2.04.07 
> 
> tmp/draft-carpenter-idloc-map-cons-01.txt:

(not yet posted.)
...

>   == Unused Reference: 'RFC4864' is defined on line 914, but no explicit
>      reference was found in the text

The actual referring sentence is:

   Also, is there any relation to topology hiding [RFC4864]?

It looks as if the '?' confuses the checker. When I remove it, the warning
goes away.

    Brian

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 04 Jun 2007 17:38:04 +0200

Hi Brian,

> It looks as if the '?' confuses the checker. When I remove it, the warning

Right.  '?' wasn't listed among the permitted characters following a
reference.  Testing a new version now which will permit this.

	Henrik