Subject: [Tools-discuss] updating the editors list for drafts...

From: Tim Polk <[email-masked]>
Date: Fri, 7 Sep 2007 13:27:11 -0400

I find the email lists for Internet Draft editors (e.g., draft- 
[email-masked])
to be an extraordinarily useful and efficient mechanism.  (I can't  
believe
how many hours I've wasted in the past cutting and pasting editors'
names out of the documents before I discovered this feature was
available.  Sigh.)

However, I have recently encountered several drafts where one of the
email addresses needed to be updated.  Every time a discussion
was initiated, I would end up forwarding at least one message to the
editor's new email address.  Oftentimes, I would forward three or four
before everyone on the thread worked it out!

I assume that the ID editors lists are generated automatically when the
ID is submitted.  Does a mechanism exist to update these email lists,
other than submission of a new draft, when an editor's email changes?
It really streamlines the discussion process if the list is current...

Thanks,

Tim Polk

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: Jari Arkko <[email-masked]>
Date: Sun, 16 Sep 2007 13:23:22 +0300

I believe Henrik's servers are using the data from
getauthors, a tool that I wrote to extract all sorts
of information from the documents themselves.

There is a plan to move to a secretary-maintained
author information. I suspect this happens when
the I-D submission tool becomes fully operational.

There's a related issue that Henrik and I have
talked about. Namely, I've run into a couple of
bugs in the getauthors tool, and currently the
updates in the tool are not getting reflected
in what the tools server does. This should be
fixed soon.

I don't think either the secretary or the tool
based model currently accommodates
e-mail address changes without document
resubmission. If a feature like that were available,
do you believe people would update their
information?

Jari

Tim Polk kirjoitti:
>
> I find the email lists for Internet Draft editors (e.g.,
> [email-masked])

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 16 Sep 2007 17:39:13 +0200

Hi Jari, Tim,

> of information from the documents themselves.

Correct.

> the I-D submission tool becomes fully operational.

... and used by the majority of submitters.

> in what the tools server does. This should be

Right.  Will continue a conversation with Jari off-list
about this...

> do you believe people would update their

There exists a specification for an email update tool,
but it's completely undefined when this might be
implemented.

	Henrik

---

From: Tim Polk <[email-masked]>
Date: Sun, 16 Sep 2007 16:53:59 -0400

Jari,

Thanks for the background...

On Sep 16, 2007, at 6:23 AM, Jari Arkko wrote:

(stuff deleted)/
> do you believe people would update their

I don't think the authors would update their information, but the
WG chair or AD *might*.  There have been a couple of cases
where I would have updated it, anyway.

Tim