Subject: [Tools-discuss] new submission tool & tools site sync

From: Jari Arkko <[email-masked]>
Date: Sat, 06 Oct 2007 00:49:26 +0300

I've had a lot of good experiences with the submission
tool from an AD perspective this week (see below).

But I also noticed an issue. I depend on the tools site
for much of my drafts handling, including nits, diffs, etc.
But with the submission tool the pace of activity
can be higher, e.g., drafts can be discussed, revised,
submitted, and approved during a conference call.
Given that the tools server updates the drafts
daily (?) its no longer always the case that the latest
drafts and diffs are available from the tools site. I've
done some manual comparisons because of this, but
I wonder if there'd be a way to make the updates more
frequent, or perhaps driven by the actual updates.

Any ideas?

Jari

> By the way, the tool seems to be making the positive changes
> in our process that we have waiting for so long. This week there
> has been several cases where we talked with the authors
> and an hour or sometimes minutes after this there's a
> new draft version up in the IETF site, allowing us to
> clear a Discuss or otherwise move forward. Quoting
> one of the authors that I worked with: "The new I-D
> submission tool rocks".
>
> I'm sorry Keith that you run into problems. I hope they
> will be resolved.
>
> Jari
>
>
>   

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 06 Oct 2007 21:26:50 +0200

Hi Jari,

> submitted, and approved during a conference call.

Right.

> drafts and diffs are available from the tools site.

It's actually hourly, but I'm rsyncing against the rsync draft  
repository, and I think that it still lags behind the http repository;  
probably with an hour too. Finally there's the re-generation of the WG  
index pages which can be less frequent and  not immediately show the  
new drafts even if they are available.

> I've

Getting the updates driven directly by the new draft availability  
seems like the right way to go.  An XMPP publish/subscribe mechanism  
would be a good generic and scslable solution, but I don't think  
Michael is up to putting that in place on very short notice. I think  
I'll set up a http notification URL he can GET with the final path  
component being the new draft, as a very simple notification mechanism  
-- as a stopgap.  Then I'll do all the fetching and generation needed  
when I get that.

     Henrik
-- 
(sent from the iPhone :)