Subject: [Tools-discuss] Document fetch function

From: Philip Matthews <[email-masked]>
Date: Wed, 10 Oct 2007 15:31:29 -0400

The document fetch function in the side bar on many tools pages seems  
to work only if the word "rfc" is typed in lower case, and there is  
no space between "rfc" and the RFC number. It would be nice if the  
function was a bit more accepting of alternative inputs.

- Philip

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 13 Oct 2007 19:11:16 +0200

Hi Philip,

On 2007-10-10 21:31 Philip Matthews said the following:
> I have noticed that the page number links in HTML-ized documents on  
> the tools website don't always work, at least using Safari 2.0.4. It  
> seems to be a bit of a hit-or-miss affair: they work fine for some  
> documents, but always jump to the top of the document for others. (I  
> am running Safari on a Mac, and this is the production version, not  
> the new Beta version.)
> 
> For example, it works on:
>       http://tools.ietf.org/html/draft-matthews-p2psip-nats-and- 
> overlays-01
>       http://tools.ietf.org/html/draft-ietf-behave-rfc3489bis-09
>       http://tools.ietf.org/html/rfc4787
> 
> but they always jump to the top of the document for:
>       http://tools.ietf.org/html/draft-ietf-p2psip-concepts-00
>       http://tools.ietf.org/html/draft-bryan-p2psip-requirements-00
>       http://tools.ietf.org/html/draft-matthews-p2psip-hip-hop-00
>       http://tools.ietf.org/html/draft-ietf-behave-turn-04
> 
> Just wondering if anyone else has noticed this?

I'm aware of it, but haven't been able to work out why it happens.
If anybody has a clue regarding the why, I should be able to update
the htmlization script to work around this Safari quirk. (Firefox
doesn't exhibit this behaviour as far as I'm aware).

Regards,

	Henrik

---

From: "Frank Ellermann" <[email-masked]>
Date: Mon, 15 Oct 2007 08:09:13 +0200

Henrik Levkowetz wrote:
 
> the htmlization script to work around this Safari quirk.

Wild guess:  The working examples have no "media screen class break",
the bad examples have "media screen class break display none".  Maybe
Safari decides that "display none" anchors shouldn't work.

 Frank

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 16 Oct 2007 11:29:51 +0200

Hi Philip,

On 2007-10-16 01:26 Philip Matthews said the following:
> Could it be a Safari bug?

I consider it as such, but that doesn't mean I can't try to
work around it if I understand the problem sufficiently well...

	Henrik

> - Philip
> 
> 
> On 13-Oct-07, at 13:11 , Henrik Levkowetz wrote:
> 
>> Hi Philip,
>>