Subject: [Tools-discuss] Request for comments: New BNF syntax verification tool

From: "Gotthard, Petr" <[email-masked]>
Date: Wed, 17 Oct 2007 10:40:02 +0200

Hi,
I'd like to show off a new verification tool that is being implemented as a student work at Masaryk University in Brno. Our goal was to create a generic syntax verification utility for any syntax definition described in any Backus-Naur Form (BNF) dialect. It is based on a dynamic parser that is configured at run-time (without recompilation) by one or more BNF syntax specifications copy-pasted from RFC's. The parser then verifies that input messages conform to this specification.

An alpha version of this tool is already available (LGPL) via http://sourceforge.net/projects/bnfparser2. "Alpha" means the tool "still awaits full testing of all its functionality and is not feature complete". Once it's mature enough, we'd like to offer this tool to be listed in the IETF Tool Inventory http://tools.ietf.org.
We intend to use this tool for syntax verification of SIP (Session Initiation Protocol) and HTTP messages. However, it can be used for syntax verification of any text-based protocol, including syntax verification of BNF specifcations.

I'm very interested to hear from you if you have any comments or suggestions concerning this tool.

Best regards,
Petr

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Gotthard, Petr
Sent: Tuesday, October 16, 2007 4:55 PM
To: [email-masked]; [email-masked]
Subject: [SIP] bnfparser2-0.1.0 released

Hello,
on behalf of all the contributors (see AUTHORS), I'm proudly announcing a first alpha release of bnfparser2, the generic BNF-adaptable parser, a joint project of http://iti.fi.muni.cz and http://www.anfdata.cz.

Learn more on http://bnfparser2.sourceforge.net.

BNF Parser² 0.1.0 can be downloaded from:
http://sourceforge.net/project/showfiles.php?group_id=192851&package_id=226956&release_id=546315

What works:
 - the parser is able to read syntax specification in any (defined) variant of BNF
 - the parser can parse input words
 - if an syntax error is detected, the error position is returned
 - otherwise, the parser returns a "semantic string"
 - can be used under both Linux/BSD and Microsoft Windows

It's a first alpha version, so please be tolerant! Build instruction for Linux/BSD are described in README. The build for Windows can be currently done only by advanced users who need no instructions.

TODO:
 - performance optimizations (current performance is not satisfying)
 - better handling of syntactic strings
 - better warnings (non-reachable nonterminals, possible errors in BNF specification, localication of undefined non-terminals)
 - error recovery supporting ambiguous grammars

Best regards,

Petr Gotthard
Research Engineer
 
Multimedia & Mobile Applications (TMM MMA)
ANF DATA spol. s r.o.
Siemens IT Solutions and Services 
PSE Czech Republic
 
Office:
M-Palac, Herspicka 5, 639 00 Brno, Czech Republic
 
Phone: +420 5 4310 6562
Fax: +420 5 4310 6540
mailto:[email-masked]
http://www.anfdata.cz

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 17 Oct 2007 11:37:59 +0200

On Wed, Oct 17, 2007 at 10:40:02AM +0200,
 Gotthard, Petr <[email-masked]> wrote 
 a message of 65 lines which said:

> An alpha version of this tool is already available (LGPL) via
> http://sourceforge.net/projects/bnfparser2.

It seems a very good idea but, at this time, the tool is a bit
difficult to install. I did not find binary packages for SimpleOpt and
the Makefile shipped with the sources do not even have a target
"install" so I really wonder where to put these files (I have no C++
experience).

---

From: "Gotthard, Petr" <[email-masked]>
Date: Wed, 17 Oct 2007 12:46:35 +0200

SimpleOpt needs no binaries; copy SimpleOpt.h to /usr/include, that's
enough

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 17 Oct 2007 20:04:31 +0200

Hi Petr,

On 2007-10-17 10:40 Gotthard, Petr said the following:
> Hi, I'd like to show off a new verification tool that is being
> implemented as a student work at Masaryk University in Brno. Our goal
> was to create a generic syntax verification utility for any syntax
> definition described in any Backus-Naur Form (BNF) dialect. It is
> based on a dynamic parser that is configured at run-time (without
> recompilation) by one or more BNF syntax specifications copy-pasted
> from RFC's. The parser then verifies that input messages conform to
> this specification.
> 
> http://sourceforge.net/projects/bnfparser2. "Alpha" means the tool
> "still awaits full testing of all its functionality and is not
> feature complete". Once it's mature enough, we'd like to offer this
> tool to be listed in the IETF Tool Inventory http://tools.ietf.org.

Sounds good to me.  Let me know when you feel it's ready for listing,
and I'll add it.

	Henrik