Subject: [Tools-discuss] Problem sending to [email-masked]

From: Cullen Jennings <[email-masked]>
Date: Fri, 23 Nov 2007 16:02:37 -0800

I'm having a problem with email going to draft-ietf-avt-rtp- 
[email-masked] and I have three questions

1) where is the right place to report a problem like this?

2) uh, given this is 99:1 a stupid user problem, can anyone point out  
what I'm doing wrong here.

Thanks, Cullen

Begin forwarded message:

> The following message to <draft-ietf-avt-rtp- 
> [email-masked]> was undeliverable.
> The reason for the problem:
> 5.1.0 - Unknown address error 550-'Unrouteable address'
> Final-Recipient: rfc822;[email-masked]
> Action: failed
> Status: 5.0.0 (permanent failure)
> Remote-MTA: dns; [194.146.105.14]
> Diagnostic-Code: smtp; 5.1.0 - Unknown address error  
> 550-'Unrouteable address' (delivery attempts: 0)
> Reporting-MTA: dns; sj-iport-6.cisco.com
>
> From: Cullen Jennings <[email-masked]>
> Date: November 23, 2007 3:34:19 PM PST
> To: Thomas Edwards <[email-masked]>, Colin Perkins  
> <[email-masked]>
> Cc: [email-masked]
> Subject: Re: draft-ietf-avt-rtp-jpeg2000 Question about sampling  
> parameter
>

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: Jari Arkko <[email-masked]>
Date: Sat, 24 Nov 2007 09:00:39 +0200

I'm the right recipient of these errors.

I see what the bug is (confusion about contact
information in the body of the document vs.
the author section). I'm working on a fix.

Jari

Cullen Jennings kirjoitti:
>
> I'm having a problem with email going to
> [email-masked] and I have three questions
>
>> The following message to <[email-masked]>
>> was undeliverable.
>> Diagnostic-Code: smtp; 5.1.0 - Unknown address error 550-'Unrouteable
>> address' (delivery attempts: 0)

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 24 Nov 2007 11:04:11 +0100

Hi Jari, Cullen,

>> 1) where is the right place to report a problem like this?

It involves both the alias list at tools.ietf.org, and the generation
of the email address information.  The latter is Jari's thing, as
indicated above; the former is mine, and email to this list or either
of us should do fine.

>> what I'm doing wrong here.

As Jari's indicated, there is a problem with the author info extraction;
the result is that with no valid info, there is no alias generated for
this draft currently.

(I first thought that it was a user error, since I found the following
alias in the list, but then I checked and saw that both the draft name
you used and this one exist: "draft-ietf-avt-rtp-jpeg2000-beam: ...")

	Henrik

---

From: Cullen Jennings <[email-masked]>
Date: Sat, 24 Nov 2007 09:54:09 -0800

Yah, Jari and I IM'd about it a bit and I understand the  
complications. Thanks

---

From: Jari Arkko <[email-masked]>
Date: Sun, 25 Nov 2007 23:02:03 +0200

I have gone through the known problems in the draft e-mail aliases.

There are no longer any drafts that do not have an author e-mail address
at all (previously, there were three). Also, the number of drafts with
at least one unknown e-mail address for one of the authors has gone
down to 19 from 58. The remaining ones

     http://www.arkko.com/tools/stats/bademails.html

are hard to fix, due to lack of information anywhere. I've sent a
few e-mails to the other authors to have them update the draft
or otherwise send information. There's also the possibility that
some of the information that I have is incorrect; its hard to know
how widespread this might be.

Henrik, you should pull the newest getauthors and getauthors.data
files, and run it at least for the drafts below

Jari

draft-ali-arp-over-gmpls-controlled-ethernet-psc-i-05.txt
draft-ali-ccamp-gmpls-lsp-ping-traceroute-00.txt
draft-archana-pimwg-pim-ping-00.txt
draft-atlas-bryant-shand-lf-timers-03.txt
draft-atlas-icmp-unnumbered-04.txt
draft-auerbach-mgcp-rtcpxr-07.txt
draft-bajko-mip6-rrtfw-02.txt
draft-bajko-mos-dhcp-options-01.txt
draft-balus-l2vpn-vpls-802.1ah-01.txt
draft-barreto-ietf-dhhmac-sas-00.txt
draft-behringer-bgp-session-sec-req-02.txt
draft-bergek-mipp-00.txt
draft-borman-1323bis-00.txt
draft-cassen-access-right-distribution-protocol-04.txt
draft-cornish-qtp-05.txt
draft-daniel-6lowpan-commissioning-00.txt
draft-daniel-6lowpan-hilow-hierarchical-routing-01.txt
draft-daniel-6lowpan-load-adhoc-routing-03.txt
draft-daniel-6lowpan-sslp-01.txt
draft-davey-iialp-08.txt
draft-dearlove-olsrv2-metrics-00.txt
draft-deng-multimob-ps-mobilemulticast-00.txt
draft-dharkins-siv-aes-01.txt
draft-doherty-keyprov-dskpp-01.txt
draft-dolganow-pwe3-ospf-ms-pw-ext-01.txt
draft-fang-mpls-gmpls-security-framework-01.txt
draft-frost-packet-timing-framework-00.txt
draft-gurbani-sip-domain-certs-06.txt
draft-gurbani-sip-ipv6-abnf-fix-00.txt
draft-haddad-cgaext-optisend-00.txt
draft-haddad-mipshop-optisend-03.txt
draft-haluska-sipping-directory-assistance-04.txt
draft-hart-pwe3-segmented-pw-vccv-02.txt
draft-hathcock-minger-04.txt
draft-hoffman-dac-vbr-02.txt
draft-iab-ip-config-00.txt
draft-iab-protocol-success-01.txt
draft-ietf-16ng-ipv4-over-802-dot-16-ipcs-01.txt
draft-ietf-16ng-ipv6-over-ipv6cs-11.txt
draft-ietf-avt-rtcpssm-14.txt
draft-ietf-avt-rtp-atrac-family-10.txt
draft-ietf-avt-rtp-jpeg2000-18.txt
draft-ietf-avt-rtp-jpeg2000-beam-09.txt
draft-ietf-avt-tfrc-profile-10.txt
draft-ietf-bmwg-protection-meth-02.txt
draft-ietf-btns-c-api-01.txt
draft-ietf-ccamp-mpls-graceful-shutdown-04.txt
draft-ietf-ccamp-te-node-cap-05.txt
draft-ietf-dna-protocol-06.txt
draft-ietf-dnsop-as112-under-attack-help-help-01.txt
draft-ietf-enum-cnam-07.txt
draft-ietf-enum-unused-03.txt
draft-ietf-enum-vmsg-00.txt
draft-ietf-hip-applications-02.txt
draft-ietf-hip-dns-09.txt
draft-ietf-hip-native-api-03.txt
draft-ietf-hip-nat-traversal-02.txt
draft-ietf-hip-registration-02.txt
draft-ietf-hip-rvs-05.txt
draft-ietf-idr-flow-spec-00.txt
draft-ietf-isis-wg-extlsp-01.txt
draft-ietf-l2vpn-arp-mediation-08.txt
draft-ietf-l2vpn-vpls-mcast-03.txt
draft-ietf-l3vpn-2547bis-mcast-05.txt
draft-ietf-l3vpn-2547bis-mcast-bgp-04.txt
draft-ietf-magma-mgmd-mib-10.txt
draft-ietf-manet-jitter-03.txt
draft-ietf-manet-nhdp-04.txt
draft-ietf-manet-olsrv2-04.txt
draft-ietf-manet-packetbb-11.txt
draft-ietf-manet-timetlv-04.txt
draft-ietf-mip4-dsmipv4-05.txt
draft-ietf-mip6-nemo-v4traversal-06.txt
draft-ietf-mipshop-4140bis-01.txt
draft-ietf-mpls-mp-ldp-reqs-03.txt
draft-ietf-mpls-mpls-and-gmpls-security-framework-01.txt
draft-ietf-mpls-p2mp-lsp-ping-05.txt
draft-ietf-nea-requirements-05.txt
draft-ietf-netlmm-mn-ar-if-02.txt
draft-ietf-pana-ipsec-07.txt
draft-ietf-pwe3-fc-encap-06.txt
draft-ietf-pwe3-ms-pw-arch-03.txt
draft-ietf-rtgwg-ipfrr-framework-07.txt
draft-ietf-rtgwg-ipfrr-notvia-addresses-01.txt
draft-ietf-rtgwg-lf-conv-frmwk-01.txt
draft-ietf-shim6-multihome-shim-api-03.txt
draft-ietf-sieve-notify-10.txt
draft-ietf-trill-rbridge-protocol-06.txt
draft-imajuku-ccamp-rtg-switching-constraint-02.txt
draft-irtf-cfrg-rhash-01.txt
draft-janardhan-naveen-rtgwg-equalcostroutes-rip-00.txt
draft-jen-apt-01.txt
draft-jiang-p2psip-stun-turn-discovery-00.txt
draft-kappler-nsis-qosmodel-controlledload-06.txt
draft-kulkarni-pim-gr-enhancement-00.txt
draft-lafon-rfc2616bis-04.txt
draft-laganier-ike-ipv6-cga-02.txt
draft-lapuh-network-smlt-07.txt
draft-legg-xed-matching-03.txt
draft-legg-xed-protocols-05.txt
draft-legg-xed-roadmap-06.txt
draft-legg-xed-schema-05.txt
draft-lewis-peppermint-enum-reg-if-01.txt
draft-lhotka-relaxng-to-rfc-00.txt
draft-livingood-enum-videomsg-01.txt
draft-livingood-enum-voicemsg-01.txt
draft-madanapalli-16ng-ipv4-over-802-dot-16-ipcs-01.txt
draft-mammoliti-l2tp-accessline-avp-01.txt
draft-manand-test-sip-ims-compliance-00.txt
draft-manning-opcode-discover-02.txt
draft-manyfolks-hip-sturn-01.txt
draft-marques-idr-flow-spec-04.txt
draft-melia-mipshop-mstp-solution-01.txt
draft-melnikov-sieve-external-lists-01.txt
draft-montenegro-6lowpan-dymo-low-routing-03.txt
draft-muley-dutta-pwe3-redundancy-bit-02.txt
draft-muley-pwe3-redundancy-02.txt
draft-nadeau-l2tpext-pw-l2tpv3-mib-01.txt
draft-otani-ccamp-gmpls-mib-update-00.txt
draft-pan-pwe3-pbb-tunnels-00.txt
draft-salsano-sipping-siphandover-solution-01.txt
draft-sayre-http-security-variance-00.txt
draft-simon-emu-rfc2716bis-11.txt
draft-soliman-firewall-control-00.txt
draft-soliman-monami6-flow-binding-05.txt
draft-sommer-ipfix-mediator-ext-00.txt
draft-stjohns-sipso-02.txt
draft-terrell-cidr-net-descrpt-expands-iptx-add-spc-21.txt
draft-terrell-iptx-mx-dhcp-specification-02.txt
draft-terrell-iptx-mx-dns-specification-04.txt
draft-terrell-math-quant-ternary-logic-of-binary-sys-12.txt
draft-tschofenig-mip6-ice-01.txt
draft-turner-symmetrickeyformat-00.txt
draft-vapiwala-bmwg-rsvpte-convergence-motivation-01.txt
draft-vidya-ip-mobility-multihoming-interactions-01.txt
draft-yang-multimob-mip6-mc-tunnel-opt-00.txt
draft-yangshi-capwap-802dot11-mib-00.txt
draft-yangshi-capwap-base-mib-00.txt

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 25 Nov 2007 22:25:09 +0100

Hi Jari,

> files, and run it at least for the drafts below

Great!

I've pulled the updated getauthors files, and started the update
run.  Should be done in about 30 minutes.

	Henrik