Subject: [Tools-discuss] Fwd: Initial Version Approval Request for draft-ietf-geopriv-lis-discovery

From: Robert Sparks <[email-masked]>
Date: Mon, 17 Dec 2007 16:03:52 -0600

So, an anecdotal data point:

I clicked on the link below and was surprised. Yes, the mail itself  
detailed exactly what was going to happen, but somehow I had
morphed my expectations into being presented a page with a link to  
the document being asked for approval (from which I would
check that it was appropriate and then hit approve).

In this case, I would have hit approve anyhow (luckily).

Would it be reasonable to ask for the link to goto a "Review this  
information and then say OK" page? (As a bonus, that page would already
contain idnits output).

It would also be ok for that to be a second link in the email if some  
folks want to keep the one-click does it all feature of the current  
system.

RjS

Begin forwarded message:

> From: IETF I-D Submission Tool <[email-masked]>
> Date: December 10, 2007 10:48:18 PM CST
> To: [email-masked]
> Subject: Initial Version Approval Request for  draft-ietf-geopriv- 
> lis-discovery
>
> Martin Thomson ([email-masked]) has requested approval  
> to post the initial version of draft-ietf-geopriv-lis-discovery.
> Please click the link below to approve this document.
>
> Once the link is clicked, you will be brought to a Web site that will
> ask for login information. (You can use the same user name and  
> password
> that you use for other IETF WG tools.)
> Upon a successful login, the document will immediately be approved,
> and you will see a notification message.
>
> If the document has already been approved by the other chair, then
> the Web site will display an appropriate indication.
>
> https://datatracker.ietf.org/cgi-bin/wg/wg_init_rev_approval.cgi? 
> command=record_approval&filename=draft-ietf-geopriv-lis-discovery
>
> The IETF Secretariat.

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: Dean Willis <[email-masked]>
Date: Tue, 18 Dec 2007 11:04:13 -0600

Robert Sparks wrote:
> morphed my expectations into being presented a page with a link to the
> document being asked for approval (from which I would
> folks want to keep the one-click does it all feature of the current system.

I find the same thing surprising every time I use the approval tool. The
first time I ended up approving the draft nine times and then turning in
a trouble ticket because it kept giving me an error message that in
retrospect probably meant the draft had already been approved. I finally
decided maybe my co-chair had already approved the draft. It took
several drafts before I realized how the tool works. Ok, maybe I am kind
of dense, but not THAT much below average. I hope.

Simply visiting a link should be without side-effects.

I'd much rather the "approve this draft" messages took me to a form
where I could optionally read the draft and then click buttons for
"accept" and "reject".

--
Dean

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 18 Dec 2007 22:07:07 +1100

Your concern is well-placed; a HTTP URI's dereference action (i.e.,  
the default action when you 'click' it) is a GET, which is specified  
to be safe -- i.e., to not have any side effects. A form that POSTs  
something to signify such intent would be more appropriate.

Cheers

On 18/12/2007, at 9:03 AM, Robert Sparks wrote:

> It would also be ok for that to be a second link in the email if  
> some folks want to keep the one-click does it all feature of the  
> current system.
>
> RjS
>
> Begin forwarded message:
>
>> https://datatracker.ietf.org/cgi-bin/wg/wg_init_rev_approval.cgi?command=record_approval&filename=draft-ietf-geopriv-lis-discovery
>>
>> The IETF Secretariat.
>
>