Subject: [Tools-discuss] rfcdiff

From: "Frank Ellermann" <[email-masked]>
Date: Sun, 2 Dec 2007 20:39:32 +0100

Hi, I've found a new rfcdiff trick, it can also compare
a local (filename2= upload) with a public (url1=) file,
demo: <http://xyzzy.webhop.info/ietftool.htm#rfcdiff>

 Frank

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: <[email-masked]>
Date: Mon, 3 Dec 2007 23:01:33 +0200

> demo: <http://xyzzy.webhop.info/ietftool.htm#rfcdiff>

Coincidentally, this was one of the things I hacked at the
Saturday code sprint! Henrik has now put the new version
online:

http://tools.ietf.org/rfcdiff

(Another improvement: you can enter just "draft-foobar-03" or 
"rfc 5054" instead of a complete URL; the tool automatically
adds the "http://tools.ietf.org/something/ part.)

Best regards,
Pasi

---

From: "Frank Ellermann" <[email-masked]>
Date: Tue, 4 Dec 2007 01:09:26 +0100

<[email-masked]> wrote:

> Henrik has now put the new version online:

Anxiously checking that you didn't change the names of the
parameters, one of the drawbacks of my tools form fan page:
No, still url1/2 and filename1/2.

Great, I guess it isn't too unusual that folks want to see
a diff of a not yet submitted filename2 against the last
url1.  Without all those clicks needed to transform url1
in filename1 (or filename2 to url2) for the old official
rfcdiff page, plus all the wasted bandwidth (looking at
my blinking Courier, twelve years old and still working)

> Another improvement: you can enter just "draft-foobar-03"
> or "rfc 5054" instead of a complete URL; the tool 
> automatically adds the "http://tools.ietf.org/something/
> part.

Excellent.  I hope it still accepts other locations for
e.g. a public "editor's copy".  If I ever arrange that I
can got to an IETF meeting I'll bring some dark chocolate
for Henrik... :-)

 Frank

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 03 Dec 2007 16:41:57 -0800

On 2007-12-03 16:09 Frank Ellermann said the following:
...
> e.g. a public "editor's copy".

Sure.

> If I ever arrange that I

In this case, the new functionality is due to Pasi, so he
should get some too, if you make it some time :-)

Thanks, Frank.

	Henrik