Subject: Re: [Tools-discuss] Repository?

From: Mark Nottingham <[email-masked]>
Date: Tue, 4 Dec 2007 12:35:59 -0800

Thanks; I'll have a look. I'm not terribly familiar with SVN  
administration; what do I use to control who can check in changes?

Cheers,

On 27/11/2007, at 6:20 AM, Henrik Levkowetz wrote:

>
>
> On 2007-11-27 08:10 Mark Nottingham said the following:
>> Hi,
>>
>> I note that Trac has a "Browse Source" link <http://tools.ietf.org/ 
>> wg/
>> httpbis/trac/browser>. Does this mean that a repository (CVS? SVN?)
>> is available for working groups?
>
> Yes.  Working groups which has Trac set up also has a SVN repository
> available, at http://svn.tools.ietf.org/svn/wg/<WGNAME>/.
>
> However, this has not been used much so far; if you start using it and
> run into any access issues at all, let me know and I'll fix as needed.
>
>
> 	Henrik

--
Mark Nottingham     http://www.mnot.net/

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 04 Dec 2007 13:53:10 -0800

> administration; what do I use to control who can check in changes?

Access control is through httpd ACLs which use the same login/passwd
as people use for wiki and tracker access on the tools server.  

I don't have a web interface in place for you to control the ACLs
currently, so I do it manually as needed.  You'll have to send me
the logins (email addresses) which should have access.

But as with the password updates, if the ACL changes become a noticeable
time drain, I'll set up a web interface that the respective chairs
can use.

Best,

	Henrik

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 4 Dec 2007 14:42:12 -0800

Great. Please give write access to myself (using [email-masked]),  
Julian, Yves and Roy (all CC:ed).

Thanks,

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 4 Dec 2007 14:42:53 -0800

... to the httpbis repository.

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 04 Dec 2007 16:51:24 -0800

Hi Mark,

> Julian, Yves and Roy (all CC:ed).

Done.  Should read access (checkout, but not commit) be provided
to no others, to authenticated users, or to anybody?

	Henrik

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 4 Dec 2007 18:29:14 -0800

Yes please (anybody).

Please also add Alexey and Paul (CC:ed).

Thanks!

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 05 Dec 2007 13:08:15 -0800

Hi Mark,

> Please also add Alexey and Paul (CC:ed).

Fixed.

	Henrik