Subject: Re: [Tools-discuss] search engine for IETF mailing list archives

From: Lars Eggert <[email-masked]>
Date: Fri, 18 Jul 2008 09:58:25 +0300

Hi

On 2007-4-17, at 16:04, ext Lars Eggert wrote:
> I used the Google Coop system to hack together a custom search  
> engine IETF WG list archives and some other IETF/IRTF lists: http://tinyurl.com/2f79lm

FYI, I've recently made some pretty massive changes to this, by screen- 
scraping the tools pages for mailing list archive information for both  
current and historic WGs and using that to generate URL search  
patterns (instead of doing this by hand).

Let me know if anything is broken: http://people.nokia.net/~lars/ietfsearch.html

Lars
_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: "Frank Ellermann" <[email-masked]>
Date: Fri, 18 Jul 2008 12:10:04 +0200

Lars Eggert wrote:
 
> Let me know if anything is broken: 
> http://people.nokia.net/~lars/ietfsearch.html

Hard to judge without seeing the source, there
are so many IETF lists with various archives.

Example of a "public XML annotations backup":
<http://hmdmhdfmhdjmzdtjmzdtzktdkztdjz.googlepages.com/xyzzy.ann.xml>

Do you want an OpenSearch description for your
CSE ?  For the IETF Tools form and my CSE I've
done that.  Maybe they could be hosted on the
IETF Tools server if folks are interested to
get it (without the IETFTOOLS description I'd
be lost... :-)

 Frank
-- 
<http://omniplex.blogspot.com/2008/04/custom-search-googlet.html>
Reposted bypassing GMaNe and IETF C/R oddities
_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Jari Arkko <[email-masked]>
Date: Fri, 18 Jul 2008 15:12:15 +0300

It seems to work well, after I tested it on a number of topics.

One thing that I noticed is that RRG list topics may not be found 
correctly -- is that list included? Other IRTF RG lists seem to be.

Jari

---

From: Lars Eggert <[email-masked]>
Date: Fri, 18 Jul 2008 15:51:40 +0300

> correctly -- is that list included? Other IRTF RG lists seem to be.

It is included, with the URL pattern psg.com/lists/rrg/*/msg*.html.

But you're right that something strange is going on. Searching "rrg  
clean slate" in the custom search engine only returns 4 hits, whereas  
searching searching "clean slate rrg site:psg.com" on the main Google  
site returns 16 hits.

Lars

---

From: "Frank Ellermann" <[email-masked]>
Date: Fri, 18 Jul 2008 10:11:02 +0200

Frank