Subject: Re: [Tools-discuss] Feature suggestion for idnits: "PK" check

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 01 Feb 2009 10:05:21 +0100

Hi Pasi,

I've added a comment about this in idnits v2.11.02.

Best,

	Henrik

On 2009-01-26 14:44 [email-masked] said the following:
> Hi,
> 
> I have one suggestion for idnits: it could issue some kind of mild
> warning if the first two letters in the file are "P" and "K".
> 
> Apparently, Internet Explorer gets confused by this, and thinks the
> draft is a ZIP file (ignoring the MIME type returned by the web server).
> For example:
> 
> http://www.ietf.org/internet-drafts/draft-ietf-pkix-rfc4055-update-01.txt
> 
> This is clearly IE's fault (www.ietf.org is returning "Content-Type:
> text/plain" as it should), but since this will cause lot of confusion,
> it wouldn't hurt to warn about it.
> 
> (BTW -- this never happens with xml2rfc, since it always begins
> the file with an empty line.)
> 
> Best regards,
> Pasi
> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: <[email-masked]>
Date: Mon, 2 Feb 2009 08:55:34 +0100

Hi Henrik,

Thanks -- I've tested this with rfc4055-update-01, and it
seems to work!

Best regards,
Pasi

> -----Original Message-----
> From: ext Henrik Levkowetz [mailto:[email-masked]]
> Sent: 01 February, 2009 11:05
> To: Eronen Pasi (Nokia-NRC/Helsinki)
> Cc: [email-masked]
> Subject: Re: [Tools-discuss] Feature suggestion for idnits: "PK" check
>
> Hi Pasi,
>