Subject: [Tools-discuss] [Fwd: New Version Notification - draft-ietf-dkim-overview-11.txt]

From: Dave CROCKER <[email-masked]>
Date: Mon, 20 Apr 2009 09:07:44 -0700

Hi.

Not sure who to send this to, so this list gets nominated:

There is a bug in the automatic diff mechanism.  The diff pointed to, below, 
says there are no changes.  Whereas, running rfcdiff on:

    <http://www.ietf.org/internet-drafts/draft-ietf-dkim-overview-10.txt>
vs.
    <http://www.ietf.org/internet-drafts/draft-ietf-dkim-overview-11.txt>

produces a lengthy set of differences.

d/

-------- Original Message --------
Subject: New Version Notification - draft-ietf-dkim-overview-11.txt
Date: Mon, 20 Apr 2009 09:00:01 -0700 (PDT)
From: [email-masked]
To: [email-masked], [email-masked], 
[email-masked]

New version (-11) has been submitted for draft-ietf-dkim-overview-11.txt.
http://www.ietf.org/internet-drafts/draft-ietf-dkim-overview-11.txt

Diff from previous version:
http://tools.ietf.org/rfcdiff?url2=draft-ietf-dkim-overview-11

IETF Secretariat.

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: <[email-masked]>
Date: Mon, 20 Apr 2009 21:11:43 +0200

Hi,

I added the "Diff from previous version" link to the new version
notification emails in the San Francisco tools code sprint.
The short URL in the email works the same way as:

http://tools.ietf.org/rfcdiff?url1=http://tools.ietf.org/id/draft-ietf-dkim-overview-10.txt&url2=http://tools.ietf.org/id/draft-ietf-dkim-overview-11.txt

which doesn't work until the tools.ietf.org server has rsync'd the new
draft (30 minutes on average, I think). Until the server has the new
draft, it says "The files are identical", which is clearly wrong.

I'll try to come up with a fix in a week or two (probably something
along the lines "check if we have this version; if we don't, use
URL pointing to www.ietf.org instead")....

Best regards,
Pasi

> -----Original Message-----
> From: Dave CROCKER
> Sent: 20 April, 2009 19:08
> To: [email-masked]
> Subject: [Tools-discuss] [Fwd: New Version Notification - draft-ietf-
> dkim-overview-11.txt]
> 
> Hi.
> 
> There is a bug in the automatic diff mechanism.  The diff pointed
> to, below, says there are no changes.  Whereas, running rfcdiff on:
> 
> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Dave CROCKER <[email-masked]>
Date: Mon, 20 Apr 2009 12:17:13 -0700

thanks!

d/

-- 

   Dave Crocker

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 21 Apr 2009 15:19:25 +0200

Hi,

> draft, it says "The files are identical", which is clearly wrong.

Right.  Should be fixed now.  The diff service will try to retrieve
the desired version locally, and if that fails, will try the master
repository, and if that fails will pop up an error message, instead
of falling back to the latest available version when a document can't
be found.

> URL pointing to www.ietf.org instead")....

Should be no need for that workaround now.  Hopefully.

Best,

	Henrik

---

From: Dave CROCKER <[email-masked]>
Date: Tue, 21 Apr 2009 06:24:25 -0700

Henrik Levkowetz wrote:
> Right.  Should be fixed now.  
...
>> I'll try to come up with a fix in a week or two 

By the way, I really appreciate having this feature added to the service.

Circulating a diff to the working group has become pretty much standard fare in 
the efforts I've been involved in.

While the steps for doing it manually, using rfcdiff, aren't onerous, having it 
be automatically available is a nice win.

d/

-- 

   Dave Crocker

---

From: Tony Hansen <[email-masked]>
Date: Tue, 21 Apr 2009 11:33:36 -0400

+1!!!

Dave CROCKER wrote:
> Circulating a diff to the working group has become pretty much standard
> fare in the efforts I've been involved in.
> 
> While the steps for doing it manually, using rfcdiff, aren't onerous,
> having it be automatically available is a nice win.
> 
> d/
>