Subject: [Tools-discuss] missing data and/or rfcmarkup script problem?

From: Jelte Jansen <[email-masked]>
Date: Mon, 18 May 2009 12:06:19 +0200

hi,

something seems to be a bit off:

http://tools.ietf.org/html/rfc5011

/www/tools.ietf.org/tools/rfcmarkup/rfcmarkup in markup()
<type 'exceptions.TypeError'>: 'NoneType' object is unsubscriptable
       args = ("'NoneType' object is unsubscriptable",)
       message = "'NoneType' object is unsubscriptable"

other rfcs seem to work fine

Jelte

ps. i see recurring v6 problems as well (and right now), usually my traces stop 
somewhere near occaid.net (like now).

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 18 May 2009 15:49:48 +0200

Hi Jelte,

> other rfcs seem to work fine

This one had IPR notices associated with the RFC, and that code seems like
it has only been excercised with drafts.  Fixed now.

> somewhere near occaid.net (like now).

tools.ietf.org currently has two AAAA records; which one is causing trouble?

Best,

	Henrik

---

From: Jelte Jansen <[email-masked]>
Date: Mon, 18 May 2009 15:59:53 +0200

> it has only been excercised with drafts.  Fixed now.

Great! (the fix, not the ipr notice)

thank you

> tools.ietf.org currently has two AAAA records; which one is causing trouble?

2001:1890:1112:1:214:22ff:fe1f:1e54

the other one appears to work fine (at least for traceroute)

here's a paste of the failing one:

jelte@eeetjeb:~> traceroute 2001:1890:1112:1:214:22ff:fe1f:1e54
traceroute to 2001:1890:1112:1:214:22ff:fe1f:1e54 
(2001:1890:1112:1:214:22ff:fe1f:1e54), 30 hops max, 80 byte packets
  1  sixgate.nlnetlabs.nl (2001:7b8:206:1:250:bfff:fe5e:33e0)  1.462 ms  2.604 
ms  2.626 ms
  2  i204.jun1.sara.ipv6.network.bit.nl (2001:7b8:40:1::1)  7.871 ms  14.784 ms 
  33.159 ms
  3  ibr02-ve26.lndn01.occaid.net (2001:7f8:4:1::7577:2)  43.839 ms  44.354 ms 
47.642 ms
  4  bbr01-p1-0.nwrk01.occaid.net (2001:4830:fe:1010::2)  116.916 ms  118.370 ms 
  118.394 ms
  5  * * *
  6  * * *
(etc.)

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 18 May 2009 17:01:36 +0200

Hi Jelte,

(Adding Glen as Cc: in case this is something he can influence, which I'm
not so sure about...)

More below:

On 2009-05-18 15:59 Jelte Jansen said the following:
...
>   4  bbr01-p1-0.nwrk01.occaid.net (2001:4830:fe:1010::2)  116.916 ms  118.370 ms 

Hmm.  Seems to be some trouble on your route, which isn't visible in my
traceroute, then -- from here it looks fine (at the moment, at least):

16:55 ~
henrik@brunello $ traceroute6 2001:1890:1112:1:214:22ff:fe1f:1e54
traceroute6 to 2001:1890:1112:1:214:22ff:fe1f:1e54 (2001:1890:1112:1:214:22ff:fe1f:1e54) from 2a01:3f0:1::21e:c2ff:fe13:7e3e, 30 hops max, 12 byte packets
 1  ge-8-2.au-gw.autonomica.se  17.338 ms  12.397 ms  0.216 ms
 2  ge-8-20.bellman-gw.sth.netnod.se  0.315 ms  0.218 ms  0.248 ms
 3  10ge-2-2.inner-b-gw.sth.netnod.se  0.452 ms  0.391 ms  0.385 ms
 4  10ge-2-1.outer-b-gw.sth.netnod.se  0.472 ms  0.413 ms  10.541 ms
 5  mtu4470.ge-b.netnod.nordu.net  0.639 ms  0.624 ms  0.582 ms
 6  2001:7f8:d:fb::139  20.013 ms  19.421 ms  19.421 ms
 7  2001:440:1239:1018::2  89.259 ms  89.138 ms  91.17 ms
 8  2001:1890:61:8908::1  108.756 ms  104.291 ms  103.227 ms
 9  2001:1890:61:9117::2  228.531 ms  211.594 ms  195.202 ms
10  2001:1890:1112:1:214:22ff:fe1f:1e54  205.407 ms  186.966 ms  181.581 ms

I'm afraid I don't know who and how to ping to get this sorted.

Best,

	Henrik

---

From: Glen <[email-masked]>
Date: Mon, 18 May 2009 08:47:44 -0700

We're showing a valid route from here to there.  BUT this is the second
complaint I've gotten in 24 hours about the route from there to here.
OCCAID is definitely having trouble.

Jelte - please file a trouble report with your ISP.  We will add this
information to the open report with OUR ISP.  Filing from both sides is
imperative to getting IPV6 problems resolved.

Thanks,
Glen