Subject: Re: [Tools-discuss] meta-issues on charter discussions

From: Tony Hansen <[email-masked]>
Date: Fri, 21 Aug 2009 10:57:08 -0400

This was posted to the ietf list.

While the charter history pages are nice, they can be made better using 
a format similar to how tools.ietf.org presents RFCs and I-Ds: a 
non-printing list of versions at the top with ways to show differences 
between versions.

Sounds like a job for the tools team. :-)

	Tony Hansen
	[email-masked]

Thomas Narten wrote:
> Re: old charters and such.
> 
> While poking around earlier this week, I found:
> 
>       http://www.ietf.org/dyn/wg/charter/history/
> 
> (it is hanging of the WG pages, so not that hard to find.)
> 
> It appears to be a snapshot of charters whenever they change. But,
> they "change" often due to events that are probably not the kind of
> changes we are thinking about, and there is no indication about what
> has changed, so there are a lot of copies and wading through them to
> find stuff appears pretty daunting. And the history only goes back 3
> years or so...
> 
> But they might be a basis for some tools to extract stuff. But, if
> tools are going to do this, it seems like an archival format other
> than HTML would be desirable.

---

From: "Spencer Dawkins" <[email-masked]>
Date: Sat, 22 Aug 2009 09:47:14 -0500

This was one of the more attractive parts of the suggestion to use IDs for 
charter revisions. If we don't use IDs for charter revisions, I'd like to 
see similar functionality provided for the approach that IS chosen...

(so, if you're reading this on tools-discuss, this is probably an 
opportunity to weigh in on the IETF list about whether you're willing to 
develop this functionality :-)

Spencer

> While the charter history pages are nice, they can be made better using a 
> format similar to how tools.ietf.org presents RFCs and I-Ds: a 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: <[email-masked]>
Date: Mon, 24 Aug 2009 09:55:52 +0200

The tools WG pages used to have diffs between charter versions
(see e.g. http://tools.ietf.org/wg/tls/charters/ -- the "delta"
symbol leads to side-by-side diff between the versions), but 
it looks like this broke when new www.ietf.org was deployed
in July.... 

Best regards,
Pasi

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> ext Tony Hansen
> Sent: 21 August, 2009 17:57
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: meta-issues on charter discussions
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 24 Aug 2009 18:11:48 +0200

Hi Tony, Pasi,

> it looks like this broke when new www.ietf.org was deployed

Ouch.  Mmm.  I'll see if I can fix this.

	Henrik

> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Richard Barnes <[email-masked]>
Date: Mon, 24 Aug 2009 12:15:38 -0400

As a side issue, it appears that Ekr is chairing TLS twice, at least
according to the linked TLS tools page.
--Richard

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 25 Aug 2009 00:23:32 +0200

> according to the linked TLS tools page.

Yah.  That's something the secretariat will have to fix in the metadata
for the WG; the tools page just uses the info which is in the database.

Best,

	Henrik