Subject: [Tools-discuss] How could get XML file of old rfc

From: Hui Deng <[email-masked]>
Date: Sun, 23 Aug 2009 21:23:58 +0800

Hello, all

May I know how could I get xml file for RFC 3*** and RFC 2***.

Many thanks for your kind help

Best regards,

-Hui

---

From: Alice Hagens <[email-masked]>
Date: Mon, 24 Aug 2009 09:40:52 -0400

Hui,

Please contact the RFC Editor to get the source files of RFCs.  For  
all RFCs we have archived the NROFF source file.  If the authors  
provided an XML source file before publication (which is more likely  
for recent RFCs), then we have an XML source file as well.

Thank you.

Alice
for the RFC Editor

On Aug 23, 2009, at 9:23 AM, Hui Deng wrote:

> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Julian Reschke <[email-masked]>
Date: Mon, 24 Aug 2009 15:58:32 +0200

Alice Hagens wrote:
> Hui,
> 
> Please contact the RFC Editor to get the source files of RFCs.  For all 
> RFCs we have archived the NROFF source file.  If the authors provided an 
> XML source file before publication (which is more likely for recent 
> RFCs), then we have an XML source file as well.
> 
> Thank you.
> ...

Or just google for the filename (rfcnnnn.xml); somebody may have done 
the work already.

BR, Julian

---

From: Hui Deng <[email-masked]>
Date: Mon, 24 Aug 2009 23:08:49 +0800

no results from this search,

thanks anyhow

-Hui

2009/8/24 Julian Reschke <[email-masked]>:
>> RFCs we have archived the NROFF source file.  If the authors provided an XML
>> source file before publication (which is more likely for recent RFCs), then
>> we have an XML source file as well.
>>
>> Thank you.
>> ...
>
> Or just google for the filename (rfcnnnn.xml); somebody may have done the
> work already.
>
> BR, Julian
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 25 Aug 2009 00:21:27 +0200

Hi Hui,

> May I know how could I get xml file for RFC 3*** and RFC 2***.

You'll have to email the RFC-Editor directly, to ask if they have the XML
file available, and you'll have to ask for the file for specific RFCs, I
believe -- they don't make the XML files available in bulk.

Best,

	Henrik

---

From: Hui Deng <[email-masked]>
Date: Tue, 25 Aug 2009 22:05:48 +0800

thanks  henrik, will do it asap

-Hui