Subject: [Tools-discuss] BCP 47 not updated?

From: "Martin J. Dürst" <[email-masked]>
Date: Fri, 30 Oct 2009 18:25:38 +0900

http://tools.ietf.org/html/bcp47 contains RFC 4646, when it should be 
RFC 5646 (see http://tools.ietf.org/html/rfc5646). I know it's a very 
special case (one BCP consisting of two RFCs), but it would still be 
very nice if it were updated.

Thanks and regards,    Martin. (LTRU co-chair)
-- 
#-# Martin J. Dürst, Professor, Aoyama Gakuin University
#-# http://www.sw.it.aoyama.ac.jp   mailto:[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 31 Oct 2009 07:59:38 +1300

On my screen today it contains 4647 followed by 5646, which is
correct and matches the RFC Editor site
(http://www.rfc-editor.org/bcp/bcp47.txt)

Regards
   Brian Carpenter

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 31 Oct 2009 11:07:24 +1300

It's updated on the tools server at
http://[2001:1890:1112:1:214:22ff:fe1f:1e54]/html/bcp47

Maybe you are seeing a cached copy?

I also see it updated on 208.66.40.242 and 64.170.98.42

The third A record is 194.146.105.14, and that one 404's
on http://194.146.105.14/html/bcp47, looks like a faulty redirect.

Regards
   Brian Carpenter

On 2009-10-31 08:12, Phillips, Addison wrote:
> The RFC Editor has it correctly, but the tools page (the link Martin sent, which is the text marked up with HTML links and such, at http://tools.ietf.org/html/bcp47 ) is not updated.
> 
> Addison
> 
> Addison Phillips
> Globalization Architect -- Lab126
> 
> Internationalization is not a feature.
> It is an architecture.
> 
> 
>> -----Original Message-----
>> From: Brian E Carpenter [mailto:[email-masked]]
>> Sent: Friday, October 30, 2009 12:00 PM
>> To: "Martin J. Dürst"
>> Cc: [email-masked]; Randy Presuhn; Mark Davis; Phillips,
>> Addison; Alexey Melnikov
>> Subject: Re: [Tools-discuss] BCP 47 not updated?
>>

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 31 Oct 2009 13:15:11 +1300

Hi Mark,

I assume you mean requests to the RFC Editor, since that's
where the concatentation originates. I assume that their procedure
just concatenates the files in numerical order.

I suspect that this will have to wait now until the RFC publication
service has been migrated over to the new contractor, in a few
months. I doubt that ISI will be touching their procedures again.

Regards
   Brian Carpenter

On 2009-10-31 11:32, Mark Davis ☕ wrote:
> For me, both http://www.rfc-editor.org/bcp/bcp47.txt and
> http://tools.ietf.org/html/bcp47 show the same contents, and both correctly
> include 5646 and 4647.
> 
> However, and they both *still* show the RFCs in the wrong order: 5646 is far
> and away the most important one, and is necessary for understanding 4647,
> but 4647 comes first in BCP 47. Despite requests, that still hasn't changed.
> 
> Mark
> 
> 
> On Fri, Oct 30, 2009 at 15:07, Brian E Carpenter <
> [email-masked]> wrote:
> 
>>> The RFC Editor has it correctly, but the tools page (the link Martin
>> sent, which is the text marked up with HTML links and such, at
>> http://tools.ietf.org/html/bcp47 ) is not updated.
>>> Addison
>>>
>>> Addison Phillips

---

From: Mark Davis ☕ <[email-masked]>
Date: Fri, 30 Oct 2009 15:32:43 -0700

Mark

---

From: Mark Davis ☕ <[email-masked]>
Date: Fri, 30 Oct 2009 20:39:53 -0700

Thanks; glad to hear there is a reason behind it.

Mark