Subject: [Tools-discuss] WG-chairs alias lifetime?

From: Brian E Carpenter <[email-masked]>
Date: Mon, 26 Oct 2009 09:04:19 +1300

I'm curious, do the [email-masked] addresses persist
indefinitely after the WG is closed?

I've just hit an instance where
(a) the WG has been formally closed before all its drafts were approved
(b) one of the WG chairs has recently changed email address
(c) the [email-masked] alias still exists, but with an
    obsolete email address for one of the chairs.

It occurs to me that if these aliases exist for ever, they will
end up valueless because the addresses will rot.

Regards
   Brian Carpenter

> -------- Original Message --------
> Subject: Mail delivery failed: returning message to sender
> Date: Sat, 24 Oct 2009 19:23:24 -0700
> From: Mail Delivery System <[email-masked]>
> To: [email-masked]
>
> This message was created automatically by mail delivery software.
>
> A message that you sent could not be delivered to one or more of its
> recipients. This is a permanent error. The following address(es) failed:
>
>   [email-masked]
>     (generated from [email-masked])
>     SMTP error from remote mail server after RCPT TO:<[email-masked]>:
>     host mx.its.monash.edu.au [130.194.11.147]: 550 5.7.1 <[email-masked]>:
>     Recipient address rejected: Mailbox does not exist

---

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 27 Oct 2009 12:13:49 -0500

The next time someone is bundling changes for xml2rfc ...

xml2rfc generates the label "Email:", and the RFC editor changes these to 
"EMail:" with capitalized "M".

I'm scanning for diffs in a soon-to-appear RFC in AUTH48, and I'm thinking 
the fewer automatically-generated text strings that the RFC editor is going 
to change, the better.

Thanks,

Spencer

---

From: Julian Reschke <[email-masked]>
Date: Tue, 27 Oct 2009 18:23:27 +0100

Spencer Dawkins wrote:
> xml2rfc generates the label "Email:", and the RFC editor changes these 
> to "EMail:" with capitalized "M".
> 
> I'm scanning for diffs in a soon-to-appear RFC in AUTH48, and I'm 
> thinking the fewer automatically-generated text strings that the RFC 
> editor is going to change, the better.
> ...

<?rfc rfcedstyle="yes" ?>

should do that.

BR, Julian

---

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 27 Oct 2009 12:36:17 -0500

Ah - thank you! I should have known about this one...

Spencer

---

From: Richard Barnes <[email-masked]>
Date: Tue, 27 Oct 2009 21:38:37 +0200

Is there a reason that that is an option and not the default?

On Tue, Oct 27, 2009 at 7:23 PM, Julian Reschke <[email-masked]> wrote:
> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 28 Oct 2009 16:09:08 +1100

Hmm. My understanding is that most style guides* recommend "e-mail."

IIRC this is because there at one point was an Australian appliance  
manufacturer called Email <http://en.wikipedia.org/wiki/Email_Limited>  
and there is concern about confusion (or even trademark issues,  
although I think that's a bit more tenuous).

Just as we'd like publishers to follow our technical standards, I'd  
submit that we'd do best to bow to theirs, unless we have a compelling  
reason not to.

Cheers,

* e.g., the Economist's <http://www.economist.com/research/styleGuide/index.cfm?page=1746394 
 >. Unfortunately, I no longer have a copy of the AP style guide handy.

On 28/10/2009, at 4:13 AM, Spencer Dawkins wrote:

> xml2rfc generates the label "Email:", and the RFC editor changes  
> these to "EMail:" with capitalized "M".
>

--
Mark Nottingham     http://www.mnot.net/