Subject: [Tools-discuss] idnits not ignoring tombstones?

From: Elwyn Davies <[email-masked]>
Date: Mon, 14 Dec 2009 18:35:51 +0000

Hi.

I updated a draft today using xml2rfc bibxml3 repository and then ran
idnits.  I got the following warnings:
>   Checking references for intended status: Informational
>   ----------------------------------------------------------------------------
>
>   == Outdated reference: A later version (-22) exists of
>      draft-ietf-nsis-qspec-21
>
>   == Outdated reference: A later version (-06) exists of
>      draft-cordeiro-nsis-hypath-05
>
>   == Outdated reference: A later version (-01) exists of
>      draft-manner-nsis-gist-dccp-00
>
>   == Outdated reference: A later version (-05) exists of
>      draft-manner-nsis-nslp-auth-04
>
>   == Outdated reference: A later version (-02) exists of
>      draft-manner-nsis-peering-data-01
It looks to me as if several of these are incorrect - the most recent
versions are 'tombstones' for expired drafts in some cases
(draft-cordeiro and draft-manner-nsis-gist at least).  Isn't idnits
supposed to ignore tombstones?
[The draft-ietf-nsis-qspec problem is not idnits' fault - the bibxml3
database is out of date as well.]

Regards,
Elwyn

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 15 Dec 2009 00:08:28 +0100

Hi Elwyn,

> supposed to ignore tombstones?

It is, indeed.  I'll have a look at the drafts above, and fix as needed.

Regards,

	Henrik