Subject: [Tools-discuss] ANN: xml2rfc 1.35 released

From: Julian Reschke <[email-masked]>
Date: Thu, 01 Apr 2010 13:21:08 +0200

Hi,

...I always wanted to make a release announcement on April 1 :-)

Here we go:

Tony Hansen, Tom Taylor and I, with the help of Henrik Levkowetz, have 
upgraded xml2rfc to produce the latest and greatest boilerplate for use 
in Internet Draft submissions (just make sure to specify a submission 
date after 2010-03-31).

The full set of changes compared to the latest "experimental" release 
(1.35pre1) is:

- <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/1> -- fixed typo 
in historic (RFC 2026 10.4) boilerplate

- <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/2> -- support 
Trust Legal Provisions 4.0 (first of two boilerplate changes)

- <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/3> -- whitespace 
appearing in reference when using annotation (fixed by Tony Hansen; 
thanks a lot)

- <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/4> -- support 
new ID boilerplate proposed by IESG (second of two boilerplate changes, 
contributed by Lars Eggert)

- <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/5> -- remove 
nonsense http-equiv=expires output   	

There are some more outstanding issues, see 
<http://trac.tools.ietf.org/tools/xml2rfc/trac/report/6> for an 
overview. In particular, xml2rfc does NOT yet create the RFC boilerplate 
defined in RFC 5741, see 
<http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/6> for details.

Also, this release is NOT yet available on xml.resource.org, nor as a 
web service. People running it locally (which I recommend anyway) can 
get the update from 
<http://trac.tools.ietf.org/tools/xml2rfc/trac/export/83/website/web/authoring/xml2rfc-1.35.tgz> 
and 
<http://trac.tools.ietf.org/tools/xml2rfc/trac/export/83/website/web/authoring/xml2rfc-1.35.zip>.

We're working on getting the online version up; hopefully we can get 
this done today.

Furthermore note that this is the first release since Marshall T. Rose 
stopped working on xml2rfc -- so I wouldn't be surprised if we screwed 
up something. Please report back ASAP if you encounter a problem. 
Speaking of which, THANKS to Marshall for the many years of development 
and support for this tool.

People interested in future development of this tool are encouraged to 
check out the source from 
<http://trac.tools.ietf.org/tools/xml2rfc/trac/wiki>, and in particular 
have a look at the open issues 
(<http://trac.tools.ietf.org/tools/xml2rfc/trac/report/6>).

Related to this, I also updated rfc2629.xslt accordingly; get the full 
release from <http://greenbytes.de/tech/webdav/rfc2629xslt.zip> (it's 
not bundled anymore with xml2rfc).

Best regards, Julian

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 01 Apr 2010 08:11:46 -0600

> in Internet Draft submissions (just make sure to specify a submission

Thanks for working on this, and to Marshall for his many years of service!

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Adam Roach <[email-masked]>
Date: Thu, 01 Apr 2010 09:17:10 -0500

> Thanks for working on this, and to Marshall for his many years of service!

+1. Thanks to all four of you.

/a

---

From: Julian Reschke <[email-masked]>
Date: Thu, 01 Apr 2010 16:54:12 +0200

On 01.04.2010 13:21, Julian Reschke wrote:
> ...

Clarifying: there are no new values for the @ipr attribute, both xml2rfc 
and rfc2629.xslt just pick the right boilerplate based on the document's 
publication date.

See 
<http://greenbytes.de/tech/webdav/rfc2629xslt/rfc2629xslt.html#attribute-ipr>.

Best regards, Julian

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 1 Apr 2010 08:07:24 -0700

><http://greenbytes.de/tech/webdav/rfc2629xslt/rfc2629xslt.html#attribute-ipr>.

For quite some time, the common advice has been "if your doc might have some text from before 2008-11-10,  just use 'pre5378Trust200902' as the @ipr attribute value". How does the new version change the processing of drafts with this value?

--Paul Hoffman, Director
--VPN Consortium

---

From: Julian Reschke <[email-masked]>
Date: Thu, 01 Apr 2010 17:33:41 +0200

> For quite some time, the common advice has been "if your doc might have some text from before 2008-11-10,  just use 'pre5378Trust200902' as the @ipr attribute value". How does the new version chang…

It doesn't; the "pre5378" escape clause is generated just like before, 
but now according to TLP 4.0, not TLP 3.0 or 2.0.

Best regards, Julian

---

From: Fred Baker <[email-masked]>
Date: Thu, 1 Apr 2010 09:19:23 -0700

Thanks for doing this.

On Apr 1, 2010, at 4:21 AM, Julian Reschke wrote:

> Tony Hansen, Tom Taylor and I, with the help of Henrik Levkowetz, have upgraded xml2rfc to produce the latest and greatest boilerplate for use in Internet Draft submissions (just make sure to specify a submission date after 2010-03-31).
> 
> The full set of changes compared to the latest "experimental" release (1.35pre1) is:
> 
> - <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/1> -- fixed typo in historic (RFC 2026 10.4) boilerplate
> 
> - <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/2> -- support Trust Legal Provisions 4.0 (first of two boilerplate changes)
> 
> - <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/3> -- whitespace appearing in reference when using annotation (fixed by Tony Hansen; thanks a lot)
> 
> - <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/4> -- support new ID boilerplate proposed by IESG (second of two boilerplate changes, contributed by Lars Eggert)
> 
> - <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/5> -- remove nonsense http-equiv=expires output   	
> 
> There are some more outstanding issues, see <http://trac.tools.ietf.org/tools/xml2rfc/trac/report/6> for an overview. In particular, xml2rfc does NOT yet create the RFC boilerplate defined in RFC 5741, see <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/6> for details.
> 
> Also, this release is NOT yet available on xml.resource.org, nor as a web service. People running it locally (which I recommend anyway) can get the update from <http://trac.tools.ietf.org/tools/xml2rfc/trac/export/83/website/web/authoring/xml2rfc-1.35.tgz> and <http://trac.tools.ietf.org/tools/xml2rfc/trac/export/83/website/web/authoring/xml2rfc-1.35.zip>.
> 
> We're working on getting the online version up; hopefully we can get this done today.
> 
> Furthermore note that this is the first release since Marshall T. Rose stopped working on xml2rfc -- so I wouldn't be surprised if we screwed up something. Please report back ASAP if you encounter a problem. Speaking of which, THANKS to Marshall for the many years of development and support for this tool.
> 
> People interested in future development of this tool are encouraged to check out the source from <http://trac.tools.ietf.org/tools/xml2rfc/trac/wiki>, and in particular have a look at the open issues (<http://trac.tools.ietf.org/tools/xml2rfc/trac/report/6>).
> 
> Related to this, I also updated rfc2629.xslt accordingly; get the full release from <http://greenbytes.de/tech/webdav/rfc2629xslt.zip> (it's not bundled anymore with xml2rfc).
> 
> Best regards, Julian
> 
> 
> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss

http://www.ipinc.net/IPv4.GIF

---

From: Julian Reschke <[email-masked]>
Date: Fri, 02 Apr 2010 14:29:30 +0200

> We're working on getting the online version up; hopefully we can get

Thanks to Henrik this is now online at <http://xml.resource.org/>.

Unrelated to this, I got a few questions about what the actual 
boilerplate change for the new Trust Legal Provisions is.

Pointers:

- TLP 4.0 with change tracking info: 
<http://trustee.ietf.org/license-info/archive/IETF-Trust-License-Policy-4-Diff.pdf>

- The actual change in xml2rfc (have a look at the sample files): 
<http://trac.tools.ietf.org/tools/xml2rfc/trac/changeset/48>

Best regards, Julian

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 02 Apr 2010 18:44:41 +0200

> <http://trac.tools.ietf.org/tools/xml2rfc/trac/changeset/48>

There are also (unauthoritative!) text versions of, and textual diffs
between the different trust documents at: http://tools.ietf.org/trust/

Regards,

	Henrik