Subject: Re: [Tools-discuss] [TOOLS-DEVELOPMENT] Request for feature: use of "current" in a draft filename

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 15 Feb 2011 16:34:48 +0100

Hi Paul,

(Responding on the tools-discuss list):

On 2011-02-12 03:36 Paul Hoffman said:
> Greetings. If I want to give out a URL that points to the latest diff on 
> a draft, I need to know the version number. That is, my URL needs to 
> look like:
> 
> http://tools.ietf.org/rfcdiff?url2=draft-ietf-somewg-someprot-10.txt
> 
> and I need to know that "10" is the latest version. What I would like is 
> to have the URL always be:
> 
> http://tools.ietf.org/rfcdiff?url2=draft-ietf-somewg-someprot-current.txt

Fixed.  (Except that the tools server doesn't seem to have this
'someprot-current' draft in it's repository ,;-D )

Best,

	Henrik

> Thanks for considering this!
> 
> --Paul Hoffman

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 15 Feb 2011 07:48:32 -0800

> 'someprot-current' draft in it's repository ,;-D )

Thanks! And you hopefully do not have a record for the somewg WG either!

--Paul Hoffman

---

From: Scott W Brim <[email-masked]>
Date: Tue, 15 Feb 2011 10:49:27 -0500

I believe you can just say <
http://tools.ietf.org/rfcdiff?url2=draft-ietf-somewg-someprot>

In fact I just tried <http://tools.ietf.org/rfcdiff?url2=draft-mrw-nat66>
and got a diff between the two latest versions.

swb

On Tue, Feb 15, 2011 at 10:34, Henrik Levkowetz <[email-masked]>wrote:

> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 15 Feb 2011 08:11:14 -0800

On 2/15/11 7:49 AM, Scott W Brim wrote:
> I believe you can just say
> <http://tools.ietf.org/rfcdiff?url2=draft-ietf-somewg-someprot>

Correct. My suggestion was for -current, but y'all implemented it 
without the need for that.

--Paul Hoffman

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 15 Feb 2011 17:29:19 +0100

> On 2/15/11 7:34 AM, Henrik Levkowetz wrote:
...
> Thanks! And you hopefully do not have a record for the somewg WG either!

Correct :-)

Best,

	Henrik