Subject: [Tools-discuss] ID upload tool bug

From: Lars Eggert <[email-masked]>
Date: Wed, 16 Feb 2011 10:46:02 +0200

Hi,

I'm trying to upload the -01 version of draft-eggert-tcpm-historicize, and I get this error: "Previous version does not exist for this document".

This is after I cancelled a previous submission of -01 where I forgot to bump the version from -00 to -01 inside the .txt file.

Bug?

Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 16 Feb 2011 12:24:26 +0100

Hi Lars,

> This is after I cancelled a previous submission of -01 where I forgot to bump the version from -00 to -01 inside the .txt file.

Maybe.  I can't see anything weird in the database entry for this
draft, and the old perl code seems fairly simple and transparent
for this case, so it's not obvious how a cancelled submission could
cause this.

Could you have introduced some extraneous character before or after
the draft name ('draft-eggert-tcpm-historicize-01') on the first page?

Best,

	Henrik

---

From: Lars Eggert <[email-masked]>
Date: Wed, 16 Feb 2011 14:04:45 +0200

> the draft name ('draft-eggert-tcpm-historicize-01') on the first page?

No, I was even stupider. I had changed s/eggert/ietf/ and there obviously is no draft-ietf-...-00.

Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 16 Feb 2011 14:16:04 +0100

Hi Lars,

> No, I was even stupider. I had changed s/eggert/ietf/ and there obviously is no draft-ietf-...-00.

Ah.  Yes, that would do it, too.  Good it got cleared up.

Best,

	Henrik

---

From: Julian Reschke <[email-masked]>
Date: Wed, 16 Feb 2011 14:25:45 +0100

> Ah.  Yes, that would do it, too.  Good it got cleared up.

So, maybe the error message could be enhanced to say exactly what draft 
file it attempted to find. In this case:

"Previous version 'draft-ietf-tcpm-historicize-00' does not exist for 
this document."

?

Best regards, Julian

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 16 Feb 2011 14:45:11 +0100

Hi Julian,

I've forwarded this to the developer who's doing the submission tool
rewrite.

Best,

	Henrik