Subject: [Tools-discuss] Fwd: #120 (Re: [core] #107: Remove Max-Age from requests...) – core

From: Carsten Bormann <[email-masked]>
Date: Wed, 9 Mar 2011 18:00:48 +0100

I apologize for opening too many issues this week...

This time we have a new ticket that appears to have been opened by a response to an old one.
(See the weird subject of this message or:

http://trac.tools.ietf.org/wg/core/trac/ticket/120

Core is participating in the "mailing list can respond to tracker" experiment.)

Gruesse, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 14 Mar 2011 17:01:34 +0100

Hi Carsten,

> I apologize for opening too many issues this week...

No no, please keep the reports coming!

> http://trac.tools.ietf.org/wg/core/trac/ticket/120

Hmm.  The email2trac component is set up to not create new issues,
only to update existing ones.  Additionally, I can't find any trace
of this in the log files -- the entries which email2trac has seen
during the last 6 days are these:

Mar 13 20:55:02 zinfandel email2trac: subject: Re: [core] #118: Block URI Transmission
Mar 11 01:01:09 zinfandel email2trac: subject: Re: [core]  #123: Etag size
Mar 11 01:04:11 zinfandel email2trac: subject: Re: [core]  coap #101 (new): Review media type registry
Mar 11 01:05:05 zinfandel email2trac: subject: Re: [core]  coap #101 (new): Review media type registry
Mar 11 03:23:38 zinfandel email2trac: subject: Re: [core] #95: Remove hierarchy recommendation
Mar 11 03:51:58 zinfandel email2trac: subject: Re: [core]  #126: Drop Lifetime
Mar  9 17:16:29 zinfandel email2trac: subject: Re: [core] #117: Block Response Code Mapping

I'll see if I can update the code to more clearly show if an entry has been
updated by email rather than directly through a browser, and also review
the possible paths for creating a new issue, as opposed to updating an
issue.

> Core is participating in the "mailing list can respond to tracker" experiment.)

And it's appreciated! :-)

Best,

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 14 Mar 2011 18:29:40 +0100

> Mar 13 20:55:02 zinfandel email2trac: subject: Re: [core] #118: Block URI Transmission
Led to #128

> Mar 11 01:01:09 zinfandel email2trac: subject: Re: [core]  #123: Etag size
Led to #124

> Mar 11 01:05:05 zinfandel email2trac: subject: Re: [core]  coap #101 (new): Review media type registry

Aha!
These two actually did go in right!
One difference in the Subject is that there is a component name in front of the ticket number and a status behind it.
So what made the original message have those when the others didn't?

The one that worked came from:
	From: 	core issue tracker <[email-masked]>
It was the original announcement of the ticket.

All the others (above and below) came from:
	From: 	core issue tracker <[email-masked]>
They were comments entered to the ticket.

There we have one explanation!

> Mar 11 03:23:38 zinfandel email2trac: subject: Re: [core] #95: Remove hierarchy recommendation
Led to #125

> Mar 11 03:51:58 zinfandel email2trac: subject: Re: [core]  #126: Drop Lifetime
Led to #127

> Mar  9 17:16:29 zinfandel email2trac: subject: Re: [core] #117: Block Response Code Mapping
Led to #122

(And, as the subject says, we also have #120, from Mar 7.)

Gruesse, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 14 Mar 2011 18:37:30 +0100

On 2011-03-14 17:01 Henrik Levkowetz said:
...
> the possible paths for creating a new issue, as opposed to updating an

I've identified additional paths to ticket creation, and added a configuration
setting to enable/disable this for all paths.

Email2trac now also inserts a line at the beginning of the comment body
indicating that the comment has been received by email and inserted by
email2trac.

Best,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 14 Mar 2011 18:57:30 +0100

Hi Carsten,

> There we have one explanation!

Right.

The messages from the tracker to which the two that worked are replies were
probably newer; I changed the subject format for some groups to match that
which had been requested for others after some discussion.

I have now tweaked the regular expression which the subject line has to
match so that it should recognize both the old and the new subject format.

Best,

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 14 Mar 2011 18:59:02 +0100

Interestingly, the messages from "core issue tracker" <[email-masked]>
this morning have an empty reply-to, so replies don't get back to the issue tracker unless that is specifically added back.
I'll now try putting back <[email-masked]> -- which one is right?

Gruesse, Carsten

On Mar 14, 2011, at 18:37, Henrik Levkowetz wrote:

> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 15 Mar 2011 09:35:14 +0100

Hi Carsten,

> I'll now try putting back <[email-masked]> -- which one is right?

<[email-masked]> is right.  I can easily configure the
tracker to set reply-to to that, too; but that would possibly loose the
list address, instead.  Reply-to-all should do the right thing in both
cases, but I don't know whether it's better to have reply-to set to the
tracker or not.  I'll change it to have this field set now, but please let
me know if you want that changed again.

Best,

	Henrik