Subject: [Tools-discuss] Fwd: [[email-masked]: googlebot to the rescue]

From: Mark Nottingham <[email-masked]>
Date: Wed, 23 Mar 2011 10:25:31 +1100

In case this hasn't been seen -- it needs to be fixed (i.e., a GET shouldn't have such side effects).

Cheers,

Begin forwarded message:

> Resent-From: [email-masked]
> From: Stephane Bortzmeyer <[email-masked]>
> Date: 23 March 2011 12:01:23 AM AEDT
> To: HTTP Working Group <[email-masked]>
> Subject: [[email-masked]: googlebot to the rescue]
> organization: NIC France
> archived-at: <http://www.w3.org/mid/[email-masked]>
> 
> The draft management tool apparently can change the state of a draft
> in response to a simple GET...
> 
> Nice violation of the HTTP standard :-)
> 
> From: Paul Vixie <[email-masked]>
> Date: 19 March 2011 2:50:30 AM AEDT
> To: [email-masked]
> Subject: googlebot to the rescue
> 
> 
> i think the 0x20 draft was going nowhere in any case so cancelling it is fine.
> 
> 	148.68.249.66.in-addr.arpa domain name pointer
> 		crawl-66-249-68-148.googlebot.com.
> 
> 	crawl-66-249-68-148.googlebot.com has address 66.249.68.148
> 
> it's interesting that it can be done by a web crawler, though.
> 
> re:
> 
> 
> From: IETF I-D Submission Tool <[email-masked]>
> Date: 18 March 2011 10:36:25 PM AEDT
> To: [email-masked], [email-masked], [email-masked]
> Subject: Submission of draft-vixie-dnsext-dns0x20-00 has been Cancelled 
> 
> 
> This message is to notify you that submission of an Internet-Draft, draft-vixie-dnsext-dns0x20-00, has just been cancelled by a user whose computer has an IP address of 66.249.68.148.
> 
> The IETF Secretariat.
> 
> 
> 
> _______________________________________________
> dnsext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsext
> 
> 

--
Mark Nottingham   http://www.mnot.net/

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 26 Mar 2011 10:23:41 +0100

Hi,

The new draft submission tool doesn't have this problem.  I'm about to
start merging that code to the trunk of the datatracker svn repository
in something like 10 minutes from now, and do the first deployment today.

Best,

	Henrik

On 2011-03-23 00:25 Mark Nottingham said the following:
>> *Resent-From: [email-masked] <mailto:[email-masked]>
>> *From: *Stephane Bortzmeyer <[email-masked] <mailto:[email-masked]>>
>> *Date: *23 March 2011 12:01:23 AM AEDT
>> *To: *HTTP Working Group <[email-masked] <mailto:[email-masked]>>
>> *Subject: **[[email-masked]: googlebot to the rescue]*
>> *organization: *NIC France
>> *archived-at: *<http://www.w3.org/mid/[email-masked]>
>>
>> *From: *Paul Vixie <[email-masked] <mailto:[email-masked]>>
>> *Date: *19 March 2011 2:50:30 AM AEDT
>> *To: [email-masked] <mailto:[email-masked]>
>> *Subject: **googlebot to the rescue*
>>
>>
>> crawl-66-249-68-148.googlebot.com <http://crawl-66-249-68-148.googlebot.com>.
>>
>> crawl-66-249-68-148.googlebot.com <http://crawl-66-249-68-148.googlebot.com> has address 66.249.68.148
>>
>> *From: *IETF I-D Submission Tool <[email-masked] <mailto:[email-masked]>>
>> *Date: *18 March 2011 10:36:25 PM AEDT
>> *To: [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>
>> *Subject: **Submission of draft-vixie-dnsext-dns0x20-00 has been Cancelled *
>>
>>
>> [email-masked] <mailto:[email-masked]>
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss