Subject: [Tools-discuss] http://tools.ietf.org/html/draft-faltstrom-5892bis-04 HTML page

From: Mykyta Yevstifeyev <[email-masked]>
Date: Mon, 25 Apr 2011 19:20:50 +0300

Hello,

This page:

http://tools.ietf.org/html/draft-faltstrom-5892bis-04

in its 'header' has a mention of this draft obsoleting RFC 5892.  Yes, 
it is in the draft's name, but the draft actually has no such regulation.

I think there is a minor problem in rfcmarkup tool with this issue that, 
IMO, should be corrected.  This may make the reader a bit confused.

Mykyta Yevstifeyev

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 25 Apr 2011 09:32:31 -0700

On Apr 25, 2011, at 9:20 AM, Mykyta Yevstifeyev wrote:

> in its 'header' has a mention of this draft obsoleting RFC 5892.  

The header that I see doesn't say anything about "obsoleting". Where do you see that word? In the view I see, it lists RFC 5892 as an earlier version, which is a reasonable guess.

--Paul Hoffman

---

From: Bob Hinden <[email-masked]>
Date: Mon, 25 Apr 2011 09:34:38 -0700

Mykyta,

On Apr 25, 2011, at 9:20 AM, Mykyta Yevstifeyev wrote:

> in its 'header' has a mention of this draft obsoleting RFC 5892.  Yes, it is in the draft's name, but the draft actually has no such regulation. 

Read the last sentence of the abstract:

>    This document specifies IETF consensus for IDNA derived character
>    properties related to the three code points, existing in Unicode 5.2,
>    that changed property values when version 6.0 was released.  The
>    consensus is that no update is needed to RFC 5892 based on the
>    changes made in Unicode 6.0.

Also, Section 2. of the draft.

I don't think there is a tool problem here.

Bob

> 
> I think there is a minor problem in rfcmarkup tool with this issue that, IMO, should be corrected.  This may make the reader a bit confused.
> 
> Mykyta Yevstifeyev
> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Mykyta Yevstifeyev <[email-masked]>
Date: Mon, 25 Apr 2011 20:08:32 +0300

> The header that I see doesn't say anything about "obsoleting". Where do you see that word? In the view I see, it lists RFC 5892 as an earlier version, which is a reasonable guess.
The (RFCnnnn) occurs when there is a "Obsoletes: nnnn" in the header, 
like http://tools.ietf.org/html/draft-yevstifeyev-rfc862bis-echo-01.  In 
this case there is no any mention like this in the draft.  rfcmarkup 
added this because there is 5892bis in the name; the draft actually does 
not perform such action.  This is what I'm pointing to - such behavior 
is caused by the name, but not the actual contents.

Mykyta Yevstifeyev

---

From: Bob Hinden <[email-masked]>
Date: Mon, 25 Apr 2011 10:20:59 -0700

On Apr 25, 2011, at 10:08 AM, Mykyta Yevstifeyev wrote:

> The (RFCnnnn) occurs when there is a "Obsoletes: nnnn" in the header, like http://tools.ietf.org/html/draft-yevstifeyev-rfc862bis-echo-01.  In this case there is no any mention like this in the draft.  rfcmarkup added this because there is 5892bis in the name; the draft actually does not perform such action.  This is what I'm pointing to - such behavior is caused by the name, but not the actual contents.

OK, but I don't see "Obsoletes:" in any headers?

Bob

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 25 Apr 2011 10:23:20 -0700

On Apr 25, 2011, at 10:08 AM, Mykyta Yevstifeyev wrote:

> The (RFCnnnn) occurs when there is a "Obsoletes: nnnn" in the header, like http://tools.ietf.org/html/draft-yevstifeyev-rfc862bis-echo-01.

You did not answer my question. You said "in its 'header' has a mention of this draft obsoleting RFC 5892". I believe that statement is wrong. The fact that the (RFCnnnn) appears for some draft doesn't mean that reason applies to every draft.

>  In this case there is no any mention like this in the draft.  rfcmarkup added this because there is 5892bis in the name; the draft actually does not perform such action.  This is what I'm pointing to - such behavior is caused by the name, but not the actual contents.

And many of us would consider that a good thing. You are complaining about a useful feature by stating something untrue about it.

--Paul Hoffman

---

From: Patrik Fältström <[email-masked]>
Date: Tue, 26 Apr 2011 06:43:37 +0200

> in its 'header' has a mention of this draft obsoleting RFC 5892.  Yes, it is in the draft's name, but the draft actually has no such regulation.

No, as other people say it references that RFC, as in updating or obsoleting or....

It does not say anything about obsoleting RFC 5892.

  Patrik

---

From: Mykyta Yevstifeyev <[email-masked]>
Date: Tue, 26 Apr 2011 18:00:09 +0300

Hello all,

I think all who took time to comment my message are losing my point.

I complained about Rfcmarkup tool analyzing the draft's name, not its 
contents when deciding to put pr not to put some RFC as the previous 
version of the draft.  It is logically useful when some draft obsoletes 
another RFC when approved, eg. 
http://tools.ietf.org/html/draft-iesg-rfc1150bis-00 where we have "(RFC 
1150) 00" label.

The draft I pointed to has no any regulations regarding obsoleting 
anything; Rfcmarkup, though, added the label of RFC 5892 being the 
previous version of it.  My complaint was about abnormal handling of the 
draft name/header while finding out Obsoletes/Updates relationships.

Mykyta Yevstifeyev

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 26 Apr 2011 08:28:57 -0700

On Apr 26, 2011, at 8:00 AM, Mykyta Yevstifeyev wrote:

> I complained about Rfcmarkup tool analyzing the draft's name, not its contents when deciding to put pr not to put some RFC as the previous version of the draft.  It is logically useful when some draft obsoletes another RFC when approved, eg. http://tools.ietf.org/html/draft-iesg-rfc1150bis-00 where we have "(RFC 1150) 00" label.
> 
> The draft I pointed to has no any regulations regarding obsoleting anything; Rfcmarkup, though, added the label of RFC 5892 being the previous version of it.  My complaint was about abnormal handling of the draft name/header while finding out Obsoletes/Updates relationships.

With all due respect, your first complaint was without any merit. Your new complaint, that the header listing an RFC as a version of a draft as being "abnormal", is silly as well. The link there is advisory and for the benefit of someone reading the current draft. If you don't like that link, ignore it.

--Paul Hoffman

---

From: Mykyta Yevstifeyev <[email-masked]>
Date: Tue, 26 Apr 2011 20:22:33 +0300

> On Apr 26, 2011, at 8:00 AM, Mykyta Yevstifeyev wrote:
Since there is nobody who managed to understand my complaint and it is 
very unlikely somebody who would understand it will appear, I see there 
is no sense in continuing this discussion.  I won't insist on any 
actions regarding it, even though I do not renounce my complaint.

Mykyta Yevstifeyev