Subject: [Tools-discuss] An error on http://tools.ietf.org/html/rfc6247

From: Mykyta Yevstifeyev <[email-masked]>
Date: Wed, 18 May 2011 06:39:47 +0300

Hello,

Trying to access http://tools.ietf.org/html/rfc6247 I get the following 
page:

> rfcmarkup: Warning: Skipping unexpected draft name: 'rfc6247' --> -->
>
>
> *<type 'exceptions.TypeError'>* 	Python 2.6.6: /usr/local/bin/python
> Wed May 18 05:00:08 2011
>
> A problem occurred in a Python script. Here is the sequence of 
> function calls leading up to the error, in the order they occurred.
>
> /www/tools.ietf.org/tools/rfcmarkup/rfcmarkup in **()
>  1359     if "--help" in sys.argv:
>  1360         usage()
>  1361         sys.exit()
>  1362
>  1363     markup()
> *markup* = <function markup>
>
> /www/tools.ietf.org/tools/rfcmarkup/rfcmarkup in *markup*()
>   899
>   900         elif rfc:
>   901             attribs.update(stateinfo("rfc%s" % (rfc)))
>   902             args["favicon"] = "/images/rfc.png"
>   903             if filetext("/home/ietf/rfc/meta/rfc%s.errata" % rfc):
> *attribs* = {'doc': 'rfc6247.txt', 'robots': 'index,follow', 
> 'staticpath': 'true', 'topmenu': 'true'}, attribs.*update* = <built-in 
> method update of dict object>, *stateinfo* = <function stateinfo>, 
> *rfc* = '6247'
>
> *<type 'exceptions.TypeError'>*: 'NoneType' object is not iterable
> args = ("'NoneType' object is not iterable",)
> message = "'NoneType' object is not iterable" 
I am not technically familiar with Python and I don't know what it is.  
A bug?

Mykyta Yevstifeyev

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 17 May 2011 21:42:06 -0600

> Trying to access http://tools.ietf.org/html/rfc6247 I get the following

Try this:

http://www.rfc-editor.org/rfc/rfc6247.txt

The tool.ietf.org website is not the canonical location for RFCs and is
not always updated immediately (RFC 6247 was published less than 10
hours ago).

Peter

-- 
Peter Saint-Andre
https://stpeter.im/