Subject: Re: [Tools-discuss] [BOFCHAIRS] New datatracker release

From: Fred Baker <[email-masked]>
Date: Wed, 1 Jun 2011 17:37:34 -0700

On Jun 1, 2011, at 5:02 PM, Ed Juskevicius wrote:

> A WG Chair is aware of an I-D and has chosen to place the document in a separate state in order to monitor it (for whatever reason).  I-Ds in this state are not (yet) WG documents in the sense that no formal decision has been made by the WG Chair to call for the WG to adopt the document.  The WG Chair has chosen to put the I-D into this state, to make it easier to keep track of it (for his or her own reasons).

From my perspective, this would be backwards. When a draft is initially submitted by an individual to a working group (draft-juskevicius-v6ops-who-knows...), I would hope that the working group would start "watching" (eg, discussing) it. The outcome of that discussion might be "we aren't interested", it might be to move quickly to adopt it as a working group draft, and it might well be to think about it a while. But I would expect an individual submission to start out in the "WG is watching" (perhaps better "WG is discussing"?) state and move from there to something else, perhaps "WG expresses a sense of disgust" or whatever :-)
 
> Having postulated the above, I wonder if an I-D  could (or should) be able to be "watched" in more than one WG at time.  If yes, then in how many different WG should the same I-D be able to be in the "WG Chair is Watching" state?  If no, them what should be the criteria to determine which WG Chair can place an I-D into this state? 

I don't have an answer to that. It does happen that a draft is looked at in multiple working groups; it generally doesn't have a wg name in its filename.

---

From: Adam Roach <[email-masked]>
Date: Wed, 01 Jun 2011 21:14:49 -0500

On 6/1/11 19:02, Jun 1, Ed Juskevicius wrote:
> Having postulated the above, I wonder if an I-D  could (or should) be 
> able to be "watched" in more than one WG at time.

Yes, yes, a million times yes.

Consider draft-ietf-rohc-sigcomp-sip (ROHC and SIP), 
draft-ietf-sip-compression (ROHC and SIP), 
draft-ietf-sipping-sigcomp-dictionary (SIPPING and ROHC), 
draft-garcia-simple-presence-dictionary (SIMPLE and ROHC), and 
draft-ietf-sipcore-location-conveyance (SIPCORE and GEOPRIV). And those 
are just documents that I've personally been involved with (either as an 
author, a major contributor, or a document shepherd). I imagine there 
are documents that straddle GEOPRIV and ECRIT as well, but I'm not 
following those groups closely enough to cite specific ones.

I would have to imagine that other areas have similar situations arise 
from time to time.

In any case, we do quite occasionally produce documents that necessarily 
straddle working groups, in that they deal with the intersection of the 
technologies that those groups have been chartered to address.

> If yes, then in how many different WG should the same I-D be able to 
> be in the "WG Chair is Watching" state? 

 From a practical perspective, there *probably* won't ever be more than 
two groups watching at a time. From a tools perspective, I think it 
would be artificial to limit the number at all. It would be infuriating 
to be bitten by a tools limitation when and if the first legitimately 
three-group document comes floating along. So, if there is a hard limit, 
it should be >>2.

/a

---

From: Ted Lemon <[email-masked]>
Date: Wed, 1 Jun 2011 23:07:19 -0400

Le Jun 1, 2011 à 10:14 PM, Adam Roach a écrit :
>> Having postulated the above, I wonder if an I-D  could (or should) be able to be "watched" in more than one WG at time.
> 

Yup, this comes up in dhc a *lot*, because other working groups typically generate dhcp options for the protocols they are working on, and even when they realize that they need to liaise with the dhc working group, the ball gets dropped and the document goes to the IESG without final review from the dhc working group.   It would help a lot even if the only thing that changed was that the IETF last call notice went to the working group mailing list.

---

From: Scott Brim <[email-masked]>
Date: Thu, 2 Jun 2011 07:11:10 -0400

I just tried to add a 'call for adoption' at
<http://datatracker.ietf.org/streams/draft-george-ipv6-required/edit/state/>,
specifying a time of 0 weeks, and got an internal server error.

---

From: "David Harrington" <[email-masked]>
Date: Thu, 2 Jun 2011 08:27:04 -0400

I recommend it be possible to go from "Chair is Watching" to "ID
Exists" (i.e., Chair is no longer watching) 

dbh

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Donald Eastlake
> Sent: Wednesday, June 01, 2011 8:37 PM
> To: Ed Juskevicius
> Cc: IETF WG Chairs; Henrik Levkowetz; Paul Hoffman; Tools 
> Team Discussion; Brian E Carpenter
> Subject: Re: [BOFCHAIRS] New datatracker release
> 
> I kind of think that a working group chair ought to be keeping an
eye
> on all of their WG drafts... But watching a document in another
> working group or a non-wg document sound like it might be a useful
> state. Presumably one effect would be that the WG chair would get
> notice of changes in state for the draft.
> 
> Thanks,
> Donald
> =============================
>  Donald E. Eastlake 3rd
>  155 Beaver Street
>  Milford, MA 01757 USA
>  [email-masked]
> 
> On Wed, Jun 1, 2011 at 8:02 PM, Ed Juskevicius 
> <[email-masked]> wrote:
> > AD is Watching is defined as follows (Ref: RFC 6174, Appendix A):
> >
> >
> > A.1.16. AD is Watching
> >
> > An AD is aware of the document and has chosen to place the 
> document in a
> > separate state in order to monitor it (for whatever 
> reason).  Documents in
> > this state are not actively tracked by the IESG in the 
> sense that no formal
> > request has been made to publish or advance the document.  
> The AD has chosen
> > to put the I-D into this state, to make it easier to keep 
> track of (for his
> > or her own reasons).
> >
> >
> > If we were to propose a state called "WG Chair is 
> Watching", then a first
> > attempt at defining such WG state might be:
> >
> >
> > WG Chair is Watching
> >
> > A WG Chair is aware of an I-D and has chosen to place the 
> document in a
> > separate state in order to monitor it (for whatever 
> reason).  I-Ds in this
> > state are not (yet) WG documents in the sense that no 
> formal decision has
> > been made by the WG Chair to call for the WG to adopt the 
> document.  The WG
> > Chair has chosen to put the I-D into this state, to make it 
> easier to keep
> > track of it (for his or her own reasons).
> >
> >
> > Having postulated the above, I wonder if an I-D  could (or 
> should) be able
> > to be "watched" in more than one WG at time.  If yes, then 
> in how many
> > different WG should the same I-D be able to be in the "WG 
> Chair is Watching"
> > state?  If no, them what should be the criteria to 
> determine which WG Chair
> > can place an I-D into this state?
> >
> >
> > Regards,
> >
> > Ed
> >
> >
> >
> >
> > On Tue, May 31, 2011 at 5:32 PM, Fred Baker <[email-masked]>
wrote:
> >>
> >> On May 31, 2011, at 1:57 PM, Brian E Carpenter wrote:
> >>
> >> > We have "AD is watching", used as one step up from "I-D 
> exists". Why not
> >> > define "WG is watching"?
> >>
> >> wfm
> >>
> >> >   Brian
> >> >
> >> > On 2011-05-27 04:54, Fred Baker wrote:
> >> >> On May 26, 2011, at 8:32 AM, Paul Hoffman wrote:
> >> >>
> >> >>> Sure there is. Looking at Fred's WG,
> >> >>> <https://datatracker.ietf.org/wg/v6ops/>, I see many 
> WG drafts in "I-D
> >> >>> exists".
> >> >>
> >> >> That's not a "WG State". That's, if anything, an IESG 
> state, or a
> >> >> statement about the draft itself - it's not dead and it 
> hasn't gone
> >> >> anywhere. From a WG perspective, I think the question 
> is "it claims, in its
> >> >> moniker, to be an individual submission to <wg>; what 
> does <wg> think about
> >> >> it?". From my perspective, there are three possible WG 
> states there - the WG
> >> >> is thinking about the individual submission to the 
> working group, it has
> >> >> decided to no longer think about it, or it is in the 
> process of deciding
> >> >> whether to make it a WG document; after that, it is of 
> course a WG document
> >> >> and has more states.
> >> >> _______________________________________________
> >> >> BOFCHAIRS mailing list
> >> >> [email-masked]
> >> >> https://www.ietf.org/mailman/listinfo/bofchairs
> >> >>
> >>
> >
> >
>

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Thu, 02 Jun 2011 13:04:51 -0400

On Wed, 2011-06-01 at 17:37 -0700, Fred Baker wrote:
> > A WG Chair is aware of an I-D and has chosen to place the document in
>  a separate state in order to monitor it (for whatever reason).  I-Ds
>  in this state are not (yet) WG documents in the sense that no formal
>  decision has been made by the WG Chair to call for the WG to adopt the
>  document.  The WG Chair has chosen to put the I-D into this state, to
>  make it easier to keep track of it (for his or her own reasons).
> 
> From my perspective, this would be backwards. When a draft is initially
>  submitted by an individual to a working group
>  (draft-juskevicius-v6ops-who-knows...), I would hope that the working
>  group would start "watching" (eg, discussing) it. The outcome of that
>  discussion might be "we aren't interested", it might be to move
>  quickly to adopt it as a working group draft, and it might well be to
>  think about it a while. But I would expect an individual submission to
>  start out in the "WG is watching" (perhaps better "WG is discussing"?)

I really wish people would stop conflating filenames with process.

Anyone can submit any document they like with a name like
draft-smith-foo-blah-blah.  Of late, the submission process sometimes
(but not always) requires that their name at least be smith.  It
certainly doesn't require that the foo WG or its chairs know anything
about the document, be interested in considering it, or even that its
content have anything to do with the foo WG.  And, often documents go
through several revisions before they are ready for a WG to consider
them, especially in WGs that basically adopt only nearly-complete work.

So no, I don't think a document should automatically move to "wg is
discussing" just because it was submitted.

On a separate note, I think we're now talking about two different
possible new states.  One is the "wg is discussing" state, which applies
to a document that the WG has not (yet) adopted but which is being
discussed, possibly in advance of a call for adoption.  The other is the
"WG Chair is Watching" state, which is an analogue to "AD is Watching".
It lets a chair mark a document so it gets included in the list of
things potentially relevant to the WG, but _without_ any process
implication.  This is key -- the whole point of having such a state is
that it doesn't mean anything except to the person who set it.

> state and move from there to something else, perhaps "WG expresses a
> sense of disgust" or whatever :-)

Sounds like a good name for an annotation on "Dead WG Document".

> 
> > Having postulated the above, I wonder if an I-D  could (or should)
> be able to be "watched" in more than one WG at time.  If yes, then in
> how many different WG should the same I-D be able to be in the "WG
> Chair is Watching" state?  If no, them what should be the criteria to
> determine which WG Chair can place an I-D into this state? 
> 
> I don't have an answer to that. It does happen that a draft is looked
> at in multiple working groups; it generally doesn't have a wg name in
> its filename.

Again, I don't think filenames are relevant here.  There is nothing in
process that says that a WG can only consider documents that have its
name in their filenames and, thankfully, nothing in the tools that
enforces such a requirement.

However, the current datatracker implementation does have the
restriction that it can only represent a WG state for one WG per
document.  While this is fine for a document that's working its way
through a working group, I think I agree with others that it would be
useful for chairs of more than WG to be able to set the "WG Chair is
Watching" state.  And in fact, even when a document has been adopted by
one WG, Ted and others have pointed out cases where it is desirable to
indicate another WG's interest in the document.

-- Jeff

---

From: Ed Juskevicius <[email-masked]>
Date: Wed, 1 Jun 2011 20:02:44 -0400

A.1.16. AD is Watching

An AD is aware of the document and has chosen to place the document in a
separate state in order to monitor it (for whatever reason).  Documents in
this state are not actively tracked by the IESG in the sense that no formal
request has been made to publish or advance the document.  The AD has chosen
to put the I-D into this state, to make it easier to keep track of (for his
or her own reasons).

If we were to propose a state called "WG Chair is Watching", then a first
attempt at defining such WG state might be:

WG Chair is Watching

A WG Chair is aware of an I-D and has chosen to place the document in a
separate state in order to monitor it (for whatever reason).  I-Ds in this
state are not (yet) WG documents in the sense that no formal decision has
been made by the WG Chair to call for the WG to adopt the document.  The WG
Chair has chosen to put the I-D into this state, to make it easier to keep
track of it (for his or her own reasons).

Having postulated the above, I wonder if an I-D  could (or should) be able
to be "watched" in more than one WG at time.  If yes, then in how many
different WG should the same I-D be able to be in the "WG Chair is Watching"
state?  If no, them what should be the criteria to determine which WG Chair
can place an I-D into this state?

Regards,

Ed

On Tue, May 31, 2011 at 5:32 PM, Fred Baker <[email-masked]> wrote:

> > We have "AD is watching", used as one step up from "I-D exists". Why not
> define "WG is watching"?
>
> wfm
>
> >   Brian
> >
> >>> Sure there is. Looking at Fred's WG, <
> https://datatracker.ietf.org/wg/v6ops/>, I see many WG drafts in "I-D
> exists".
> >>
> >> That's not a "WG State". That's, if anything, an IESG state, or a
> statement about the draft itself - it's not dead and it hasn't gone
> anywhere. From a WG perspective, I think the question is "it claims, in its
> moniker, to be an individual submission to <wg>; what does <wg> think about
> it?". From my perspective, there are three possible WG states there - the WG
> is thinking about the individual submission to the working group, it has
> decided to no longer think about it, or it is in the process of deciding
> whether to make it a WG document; after that, it is of course a WG document
> and has more states.

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 1 Jun 2011 20:36:41 -0400

I kind of think that a working group chair ought to be keeping an eye

Thanks,
Donald

On Wed, Jun 1, 2011 at 8:02 PM, Ed Juskevicius <[email-masked]> wrote:
>> >>> <https://datatracker.ietf.org/wg/v6ops/>, I see many WG drafts in "I-D
>> >>> exists".
>> >>

---

From: [email-masked]
Date: Thu, 2 Jun 2011 12:40:14 +0000

The status to be displayed (by the Datatracker) in such a case needs a few "if/then" tests.

If an I-D is being watched by just one WG Chair, then OK.

If an I-D is being watched by two WGs and one loses interest in the draft, there does need to be some way to indicate this change in the status ... but the state of the draft can't revert back to just "I-D Exists" if the document has some state in another WG. 

Creating a "(insert WG acronym here) Chair is No Longer Watching" state might work.

Regards,

Ed 

-----Original Message-----
From: "David Harrington" <[email-masked]>
Date: Thu, 2 Jun 2011 08:27:04 
To: 'Donald Eastlake'<[email-masked]>; 'Ed Juskevicius'<[email-masked]>
Cc: 'IETF WG Chairs'<[email-masked]>; 'Henrik Levkowetz'<[email-masked]>; 'Paul Hoffman'<[email-masked]>; 'Tools Team Discussion'<[email-masked]>; 'Brian E Carpenter'<[email-masked]>
Subject: RE: [BOFCHAIRS] New datatracker release

dbh

eye

---

From: Jouni Korhonen <[email-masked]>
Date: Wed, 15 Jun 2011 11:32:50 +0300

Hi,

The datatracker view does not seem to list expired WG drafts, whereas Tools
WG page does. I would prefer to see them so I could mark some I-Ds 'dead'..

When entering the document view, the top of page navigation bar disappears
(which has Documents|Charter|Manage workflow|..). You get that back when
entering either to "Change draft writeup"  or to "Change draft shepherd".

- Jouni

On 5/25/11 8:14 PM, "ext IETF Chair" <[email-masked]> wrote:

> We have now deployed new features in the IETF Datatracker (which you can find
> at http://datatracker.ietf.org/) that provide support for display and
> management of working group document status according to RFC 6174 and RFC
> 6175.
> 
> The WG Chairs can assign states to WG Internet-Drafts:
>  -  WG Document 
>  -  Parked WG Document
>  -  Dead WG Document
>  -  In WG Last Call
>  -  Waiting for WG Chair Go-Ahead
>  -  WG Consensus: Waiting for Writeup
>  -  Submitted to IESG for Publication
> 
> A subset of these states will be set automatically for WG documents by the
> system if no action is taken by the WG Chairs.  You can see the new states on
> the WG document summary pages in the datatracker, see for instance
> http://datatracker.ietf.org/wg/v6ops/
> 
> The new datatracker release also provides support for showing and assigning
> shepherds for WG Internet-Drafts, for recording proto write-ups for WG
> Internet-Drafts, for defining a custom document workflow for a WG, and more.
> 
> We hope these new datatracker features will provide more information about the
> state and progress of WG documents for all IETF participants. We hope these
> new datatracker features will also provide tools for WG Chairs that make it
> easier to manage WG documents.
> 
> Thanks,
> Russ
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 16 Jun 2011 04:31:39 -0400

I agree - I had to use the tools page to clean up the status of the
expired WG drafts.

Cheers,
Andy