Subject: [Tools-discuss] SSL negotiation errors on svn.tools.ietf.org

From: "Roy T. Fielding" <[email-masked]>
Date: Sun, 24 Jul 2011 16:31:26 -0700

Does anyone have a solution to the problem described in

  http://www.ietf.org/mail-archive/web/ietf/current/msg66647.html

I am using OS X 10.6.8 and svn 1.6.16 and OpenSSL 0.9.8r

% svn up
svn: OPTIONS of 'https://svn.tools.ietf.org/svn/wg/httpbis': SSL negotiation failed: SSL error code -1/1/336032856 (https://svn.tools.ietf.org)

It has been failing that way for over a month now.  What changed?

....Roy

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 25 Jul 2011 10:43:32 -0400

Hmm, this suggests a fix:
  http://wiki.networksecuritytoolkit.org/nstwiki/index.php/HowTo_Configure_Apache_SSL_For_davfs,_subversion,_etc.

On 24/07/2011, at 7:31 PM, Roy T. Fielding wrote:

> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss

--
Mark Nottingham   http://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 26 Jul 2011 05:47:51 -0400

FWIW -- the workaround is to change your repository URL to 'http'. I've confirmed that my client (OSX svn) does use Digest auth.

Cheers,