Subject: Re: [Tools-discuss] [TOOLS-DEVELOPMENT] MPLS WG Secretary with real problems

From: Glen <[email-masked]>
Date: Fri, 26 Aug 2011 09:44:32 -0700

Adrian -

Yes, this is a database problem, and is being handled in the redesign.  But
there is no solution for it at this time.  The short email address is the
correct solution.  Something from gmail would be fine.

Then have him contact the IETF secretariat, and they will make the change.

Glen
Glen Barney
IT Director
AMS (IETF Secretariat)

On Fri, Aug 26, 2011 at 05:38:17PM +0100, Adrian Farrel wrote:
> HI,
> 
> We are in a bit of a mess.
> 
> The MPLS WG secretary is blessed with a long email address
> ([email-masked]). Apparently this causes tools login a big
> problem with truncation at 30 characters. 
> 
> The result seems to be a variety of messy symptoms not limited to:
> 
> - duplicate login credentials created
> - tools crashes on login
> - able to log in but not to do anything
> - duplicate entry appearing on MPLS charter page
> 
> This is stopping Martin from doing work and pushing the work back on chairs, AD,
> and secretariat.
> 
> My ideal fix would be that we support >30 characters. I going to guess this is a
> DB problem not just a compile-time limit.
> 
> Failing that, and assuming that martin does not want to change job to work for a
> company with a shorter name (or change his own name to something more compact)
> we will find a suitable short email address for him, and ask you to flush his
> record and start again.
> 
> Please advise.
> 
> Thanks,
> Adrian
> 
> 
> > -----Original Message-----
> > From: Martin Vigoureux [mailto:[email-masked]]
> > Sent: 26 August 2011 17:11
> > To: [email-masked]
> > Cc: [email-masked]
> > Subject: Re: Tidying links on the MPLS charter page
> > 
> > Adrian,
> > 
> > I had some fears about this and it might be that I had good reason
> > to have some:
> > I can log on the Meeting Material Manager but do not have any right
> > any more to do anything ... (can't upload the minutes for example)
> > I do not know if it is a bug of the MMM or that removing an instance
> > of my address from the charter page had this impact.
> > A similar thing happened in the past when I was removed from the
> > list [email-masked]. I lost all my rights.
> > 
> > I'll send the minutes to Wanda but we'll need to have this fixed.
> > 
> > Thanks for your help.
> > -m
> > 
> > Le 14/08/2011 16:49, Adrian Farrel a ?crit :
> > > Hi,
> > >
> > > Two things that I don't believe need IESG approval.
> > >
> > > http://datatracker.ietf.org/wg/mpls/charter/ shows...
> > >
> > >     Secretaries:
> > >         Martin Vigoureux<[email-masked]>
> > >         Martin Vigoureux<[email-masked]>
> > >
> > > Although Martin is remarkably present, I think there is only one of him. Can
> you
> > > sort this out?
> > >
> > >
> > > http://datatracker.ietf.org/wg/mpls/charter/ also shows...
> > >
> > >       The Working Group chairs tracking of the working group documents can
> be
> > >        viewed at http://www.tla-group.com/~mpls/mpls-wg-docs.htm
> > >
> > > The content at this is URL is very out of date and is not maintained. Could
> you
> > > please remove this paragraph?
> > >
> > > Thanks,
> > > Adrian.
> > >
> > >
> 
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 29 Aug 2011 15:08:52 +0200

Hi,

I've now changed the 30-character limit on usernames in the IETF database
and in Django's User model (the new limit is 64 characters).  Unless there
are limitations elsewhere in the system, it should now be possible for people
with long email addresses to log as WG chairs and do their stuff.  

Best regards,

	Henrik

On 2011-08-26 18:44 Glen said:
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>