Subject: [Tools-discuss] Python exception at idtracker login

From: Enrico Marocco <[email-masked]>
Date: Fri, 19 Aug 2011 10:01:11 +0200

Hi,

I get the following error when attempting to log in the idtracker
section of the datatracker (to request the publication of a WG doc):

> IntegrityError: (1062, "Duplicate entry [email-masked]' for key 2")

Trying to guess from the error string, the problem may be related to the
fact that my account was in fact created twice, the second time when I
became chair of an additional WG. Anyone experienced the same issue?

Below's the full tracecback, will be happy to help in troubleshooting.

> MOD_PYTHON ERROR
> 
> ProcessId:      17237
> Interpreter:    'datatracker.ietf.org'
> 
> ServerName:     'datatracker.ietf.org'
> DocumentRoot:   '/a/www/ietf-datatracker/web/static/'
> 
> URI:            '/accounts/login/'
> Location:       '/accounts'
> Directory:      None
> Filename:       '/a/www/ietf-datatracker/web/static/accounts'
> PathInfo:       '/login/'
> 
> Phase:          'PythonHandler'
> Handler:        'django.core.handlers.modpython'
> 
> Traceback (most recent call last):
> 
>   File "/usr/lib64/python2.6/site-packages/mod_python/importer.py", line 1537, in HandlerDispatch
>     default=default_handler, arg=req, silent=hlist.silent)
> 
>   File "/usr/lib64/python2.6/site-packages/mod_python/importer.py", line 1229, in _process_target
>     result = _execute_target(config, req, object, arg)
> 
>   File "/usr/lib64/python2.6/site-packages/mod_python/importer.py", line 1128, in _execute_target
>     result = object(arg)
> 
>   File "/a/www/ietf-datatracker/web/django/core/handlers/modpython.py", line 228, in handler
>     return ModPythonHandler()(req)
> 
>   File "/a/www/ietf-datatracker/web/django/core/handlers/modpython.py", line 201, in __call__
>     response = self.get_response(request)
> 
>   File "/a/www/ietf-datatracker/web/django/core/handlers/base.py", line 73, in get_response
>     response = middleware_method(request)
> 
>   File "/a/www/ietf-datatracker/web/django/contrib/auth/middleware.py", line 63, in process_request
>     user = auth.authenticate(remote_user=username)
> 
>   File "/a/www/ietf-datatracker/3.59/django/contrib/auth/__init__.py", line 37, in authenticate
>     user = backend.authenticate(**credentials)
> 
>   File "/a/www/ietf-datatracker/web/ietf/ietfauth/auth.py", line 91, in authenticate
>     user = RemoteUserBackend.authenticate(self, remote_user)
> 
>   File "/a/www/ietf-datatracker/web/django/contrib/auth/backends.py", line 116, in authenticate
>     user, created = User.objects.get_or_create(username=username)
> 
>   File "/a/www/ietf-datatracker/3.59/django/db/models/manager.py", line 123, in get_or_create
>     return self.get_query_set().get_or_create(**kwargs)
> 
>   File "/a/www/ietf-datatracker/3.59/django/db/models/query.py", line 343, in get_or_create
>     raise e
> 
> IntegrityError: (1062, "Duplicate entry [email-masked]' for key 2")

-- 
Ciao,
Enrico

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 19 Aug 2011 15:39:40 +0200

Hi Enrico,

Good guess, but the reason is actually somewhat different.  Notice that
the login name is cut of, missing the last letter.  The problem is that
the login name field is limited to 30 characters in the database, and your
login name (email address) is longer...

This will be handled eventually, but right now it would be best if it was
possible for your to use a shorter email address, and ask the secretariat
to change over to that for your WG chair duties.

Sorry for the trouble :-(

Best regards,

	Henrik

On 2011-08-19 10:01 Enrico Marocco said the following:
> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss